Clusterboard startup issues
(05-08-2019, 04:21 PM)WhiteDragon Wrote: That's strange indeed! I tried tried both the Xenial (3.x Kernel) and stable releases (Stretch and Bionic 4.x Kernel) before I built from source but to no avail. The only thing the Xenial (3.x Kernel) provided was a light on the built-in Heartbeat LED. However I did not try any of the precompiled releases with neither USB NIC nor UART (since I did not have a UART to USB dongle at hand as stated in the original post).
I only got the idea to try the USB NIC after I built a Kernel from scratch and reached a point of fair frustration and figured it might work as a last resort before I through the board out of a window, since there are USB NICs listed as working on the Armbian section on the SoPine board. (I can add the Apple USB NIC to that list for what it is worth...)
I never tried the nightly builds though. Maybe that would have worked as well, but I don't know. I try to stay away from nightlies; got some bad memories from Debian Etch on a Fujitsu Notebook back in the day... 
When I read that a Kernel built from the master branch sources would work I was delighted, but unfortunately it did not do so for me. After I modified the  the dtb file according to the the Armbian Forums thread (there was no line towards tx delay whatsoever in the unmodified version of the .dtb file) it started working, albeit after I pulled out the USB NIC. I cannot fathom if it would have worked if I just pulled out the USB NIC without modifying the dtb file, but I hightly doubt it.
I'm glad that you don't experience the same issues I did, but maybe it's due to a different revision of the board? Mine's a Rev. 2.3. What's yours? I don't have the foggiest as to why I was having these issues and would be glad if the root of the problem could be found, so others won't have to go through the hassle of modifying the dtb file after every update or freeze packages. But as of now I blame it on machine heuristics...

The nightly builds are just like building from scratch and won't be much different from the releases mentioned. My board is mounted in a case. I can't see the rev number. I took apart the dtb and it does not look like the delay is in there. I think they might have fixed it upstream. I'm going to rebuild my system within the next couple of days. As far as I know, as of right now, everything should work "out of the box" with the images downloaded from Armbian.

Messages In This Thread
Clusterboard startup issues - by WhiteDragon - 05-05-2019, 03:32 PM
RE: Clusterboard startup issues - by WhiteDragon - 05-06-2019, 06:10 AM
RE: Clusterboard startup issues - by WhiteDragon - 05-07-2019, 02:45 PM
RE: Clusterboard startup issues - by WhiteDragon - 05-08-2019, 04:21 PM
RE: Clusterboard startup issues - by AZClusterboard - 05-08-2019, 05:46 PM
RE: Clusterboard startup issues - by WhiteDragon - 05-09-2019, 06:07 AM
RE: Clusterboard startup issues - by WhiteDragon - 05-09-2019, 12:32 PM
RE: Clusterboard startup issues - by WhiteDragon - 05-09-2019, 01:34 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Managed Ethernet switch on the Clusterboard dsimic 6 5,343 01-16-2024, 02:05 AM
Last Post: hazcam
  Selling Clusterboard + 4 sopine xblack86 7 5,836 09-26-2022, 03:09 AM
Last Post: poVoq
  clusterboard availability? linear 1 1,620 07-17-2022, 06:44 AM
Last Post: poVoq
  Clusterboard not getting IP address after network fix Norlark 14 12,525 08-30-2021, 05:00 PM
Last Post: poVoq
  When would be the Clusterboard back on stock? __kzl__ 5 5,233 08-16-2021, 03:52 AM
Last Post: poVoq
  Schematics for customising the Clusterboard TechDragon 0 2,072 05-25-2021, 10:28 AM
Last Post: TechDragon
Information Clusterboard Guide AZClusterboard 9 23,304 04-06-2021, 06:32 AM
Last Post: poVoq
Brick Clusterboard CAD drawings TeaPack 1 3,811 03-31-2021, 01:38 PM
Last Post: Pine
  New Clusterboard Setup wargfn 5 7,316 01-01-2021, 10:10 AM
Last Post: poVoq
  Clusterboard does not even turn on? poVoq 3 6,205 08-15-2020, 07:31 AM
Last Post: poVoq

Forum Jump:

Users browsing this thread: 1 Guest(s)