pinebook black screen when booting with "different power mode than last used"
#1
Sorry for the weird thread subject but I'm not able to summarize better this behavior.

Scenario:
Pinebook 14" with default Ubuntu 16.04 (same shipped with the pinebook itself, just updated with apt + pine* scripts for uboot and kernel)

Problem:
Sometimes when powered off it cannot correctly power back on in a useful state since, even if the system is running, the screen is black (may lit up but no X session is there)

How to replicate:
Use the pinebook with AC adapter plugged in (charging), power it off, unplug the AC adapter, power back on --> black screen of death
Use the pinebook with battery, power it off, plug the AC adapter in, power back on --> black screen again

How to "workaround":
Just randomly powering it off and on again with AC adapter in until I get the "pinebook splashscreen" --> at this point boots fine

Tried different OSes:
Yes same thing on a SD card installed OS, or even worse --> with that never gets to a working X session (boots and does all stuff lilke expanding the ext4 partition) but screen just flashes in backlit black for 2 times and never comes along  (tried this image as last one: https://osdn.net/projects/manjaro-arm/st...03.img.xz/)
Sometimes I've successfully used a plain vanilla console-based armbian to try to recover a "always in black screen mode" (I discovered that I had ext4 to be checked due to my poweroff/on to restore a usable screen).

Battery state:

It's OK. It can stand many hours of work, and voltages are fine, charges regularly (if we exclude the black screen issue)

Image flashing issues:

I dont' think so, really, checked the sums, flashed with different sdcarcs and different methods  (dd with conv=fsync, etcher, name it... I do this stuff on a daily basis so at least here it's not a place to check for possible issues I think).


that said...


Any clues any of you mighty piners?

I suspect my pinebook is just faulty, but maybe I'm getting something wrong or we can discover something potentially useful for others users as well.


Messages In This Thread
pinebook black screen when booting with "different power mode than last used" - by penzoiders - 04-29-2019, 01:39 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Stock Debian on original Pinebook moonwalkers 0 346 07-02-2021, 12:18 PM
Last Post: moonwalkers
  E: The repository 'http://pinebook.kde.org.uk bionic Release' no longer has a Release pixelpaperyarn 3 1,231 05-07-2021, 10:20 AM
Last Post: tophneal
  Slarm64 on Pinebook [Slackware Arm - 64 bit] KRT 29 16,620 05-04-2021, 11:34 PM
Last Post: mara
  DietPi OS for Pinebook MichaIng 1 1,247 03-10-2021, 02:45 PM
Last Post: MichaIng
  pinebook.kde.org.uk no longer has release file?? supermassive 1 1,143 01-20-2021, 11:18 AM
Last Post: tophneal
Question Ran apt update on my Pinebook.. ford442 0 924 12-25-2020, 04:40 PM
Last Post: ford442
Information Manjaro ARM for Pinebook erchache2000 88 48,675 11-29-2020, 04:36 PM
Last Post: Mr.Fermer
  Pinebook is going the way of Betamax? trigger 10 6,962 11-01-2020, 02:02 PM
Last Post: leperotero
  Pinebook Pro (i3 WM): Confirm Shutdown on Power Button etothepii 3 2,920 08-14-2020, 06:03 AM
Last Post: loblik
  Manjaro sway profile for pinebook e-minguez 3 2,391 07-21-2020, 03:25 PM
Last Post: jezek

Forum Jump:


Users browsing this thread: 1 Guest(s)