After power loss, boot never gets to white LED
#5
(02-06-2019, 09:36 PM)evilbunny Wrote:
(02-06-2019, 08:52 PM)josepht Wrote: Don't know what to try next...


Have you tried turning flow control off in minicom?

ctrl+a+z -> o -> serial port setup

I had not.  That did the trick, thanks!  Not only did the transmission come through in minicom after doing that, but boot was successful as well.  I'm curious why that would be the case, but happy to be up and running regardless.

Playing around with it some more, I've found that if I have the serial adapter connecting the rockpro64 to my desktop, then the system can boot and function correctly.  But if I disconnect the serial adapter, I get the same behavior as before where the white LED never comes on and the red one blinks.

Is that normal?  I haven't found any mention of others having that issue online.  Am I missing some setup step to configure the system to not need the serial connection on boot?


The early boot spew (on a successful boot with the serial adapter attached) has a couple warnings, not sure if they're relevant:

```
U-Boot SPL board init
 
U-Boot SPL 2017.09-rockchip-ayufan-1025-g482cd6ec8b (Jul 26 2018 - 08:18:48)
booted from eMMC
Trying to boot from MMC1
NOTICE:  BL31: v1.3(debug):d98d16e
NOTICE:  BL31: Built : 15:03:07, May 10 2018
NOTICE:  BL31: Rockchip release version: v1.1
INFO:    GICv3 with legacy support detected. ARM GICV3 driver initialized in EL3
INFO:    Using opteed sec cpu_context!
INFO:    boot cpu mask: 0
INFO:    plat_rockchip_pmu_init(1151): pd status 3e
INFO:    BL31: Initializing runtime services
WARNING: No OPTEE provided by BL2 boot loader, Booting device without OPTEE initialization. SMC`s destined for OPTEE will return SMC_UNK
ERROR:   Error initializing runtime service opteed_fast
INFO:    BL31: Preparing for EL3 exit to normal world
INFO:    Entry point address = 0x200000
INFO:    SPSR = 0x3c9
 
 
U-Boot 2017.09-rockchip-ayufan-1025-g482cd6ec8b (Jul 26 2018 - 08:18:55 +0000)
 
Model: Pine64 RockPro64
DRAM:  3.9 GiB
DCDC_REG1@vdd_center: ; enabling
DCDC_REG2@vdd_cpu_l: ; enabling
DCDC_REG3@vcc_ddr: ; enabling (ret: -38)
DCDC_REG4@vcc_1v8: set 1800000 uV; enabling
LDO_REG1@vcc1v8_dvp: set 1800000 uV; enabling
LDO_REG2@vcc3v0_touch: set 3000000 uV; enabling
LDO_REG3@vcc1v8_pmu: set 1800000 uV; enabling
LDO_REG4@vcc_sd: set 3300000 uV; enabling
LDO_REG5@vcca3v0_codec: set 3000000 uV; enabling
LDO_REG6@vcc_1v5: set 1500000 uV; enabling
LDO_REG7@vcca1v8_codec: set 1800000 uV; enabling
LDO_REG8@vcc_3v0: set 3000000 uV; enabling
SWITCH_REG1@vcc3v3_s3: ; enabling (ret: -38)
SWITCH_REG2@vcc3v3_s0: ; enabling (ret: -38)
vcc1v8-s0@vcc1v8_s0: set 1800000 uV; enabling (ret: -38)
dc-12v@dc_12v: set 12000000 uV; enabling (ret: -38)
vcc-sys@vcc_sys: set 5000000 uV; enabling (ret: -38)
vcc3v3-sys@vcc3v3_sys: set 3300000 uV; enabling (ret: -38)
vcc-phy-regulator@vcc_phy: ; enabling (ret: -38)
vdd-log@vdd_log: ; enabling (ret: -38)
MMC:   sdhci@fe330000: 0, dwmmc@fe320000: 1
SF: Detected gd25q128 with page size 256 Bytes, erase size 4 KiB, total 16 MiB
*** Warning - bad CRC, using default environment
 
In:    serial@ff1a0000
Out:   serial@ff1a0000
Err:   serial@ff1a0000
Model: Pine64 RockPro64
normal boot
```


Thanks again for all the help!


Messages In This Thread
RE: After power loss, boot never gets to white LED - by josepht - 02-06-2019, 10:18 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Automatic power on after power outage gechu 0 161 08-29-2021, 01:46 PM
Last Post: gechu
  Flashed SPI, able to ping RP64 but not boot from sdcard/usb korefuji 2 249 08-26-2021, 11:41 AM
Last Post: LMM
  ROCKPro64 sometimes doesn't Power On Pete Tandy 2 216 08-24-2021, 05:50 AM
Last Post: Pete Tandy
  Mainline U-Boot with SPI, NVMe and SATA boot support sigmaris 103 47,041 07-08-2021, 04:55 PM
Last Post: Mentaluproar
  Device unable to boot Lunix33 7 1,043 07-05-2021, 08:25 PM
Last Post: t4_4t
  Power Supply availability S265 2 752 06-07-2021, 09:20 PM
Last Post: S265
  First boot - no fan, no display... is it broken? rantoie 1 549 04-28-2021, 04:41 PM
Last Post: rantoie
  PXE boot - unable to login LMM 2 592 04-22-2021, 02:59 PM
Last Post: LMM
  control RP64 power on LMM 0 537 04-15-2021, 02:59 AM
Last Post: LMM
  Performance and Power Demand RockPro64 fotastisch 7 5,524 02-05-2021, 07:45 PM
Last Post: foresto

Forum Jump:


Users browsing this thread: 1 Guest(s)