USB3 external disk not showing up
#1
[edit 3] Think I traced the problem to ehci --- does anyone know how to disable it in the kernel ? 

Hello

I connected an external usb3 hdd to the Pine64 (formated ext4) and it cannot see it. I have tried fdisk -l and nothing. 

Any suggestions would be very welcome. 

Cheers ! 

Luke

[edit] Dont know if this helps but the the bus with the drive connected returns no id: 

Bus 002 Device 125: ID 2537:1066

[edit 2] I did  "dmesg | more" to see if the drive is throwing out any errors and, as it turns out, it keeps connecting and disconnecting. Does anyone have any idea what is causing this ? 

Here is tiny fraction of the output im getting: 

412] usb 2-1: new high-speed USB device number 72 using sunxi-ehci
[ 9395.840400] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 9395.840952] scsi1924 : usb-storage 2-1:1.0
[ 9400.188888] ehci_irq: highspeed device disconnect
[ 9400.188987] usb 2-1: USB disconnect, device number 72
[ 9400.256204] ehci_irq: highspeed device connect
[ 9400.559142] usb 2-1: new high-speed USB device number 73 using sunxi-ehci
[ 9400.711193] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 9400.711743] scsi1925 : usb-storage 2-1:1.0
[ 9405.069650] ehci_irq: highspeed device disconnect
[ 9405.069741] usb 2-1: USB disconnect, device number 73
[ 9405.136752] ehci_irq: highspeed device connect
[ 9405.439593] usb 2-1: new high-speed USB device number 74 using sunxi-ehci
[ 9405.591582] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 9405.592130] scsi1926 : usb-storage 2-1:1.0
[ 9409.940942] ehci_irq: highspeed device disconnect
[ 9409.941035] usb 2-1: USB disconnect, device number 74
[ 9410.006389] ehci_irq: highspeed device connect
[ 9410.310268] usb 2-1: new high-speed USB device number 75 using sunxi-ehci
[ 9410.462265] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 9410.462816] scsi1927 : usb-storage 2-1:1.0
[ 9414.812111] ehci_irq: highspeed device disconnect
[ 9414.812208] usb 2-1: USB disconnect, device number 75
[ 9414.877459] ehci_irq: highspeed device connect
[ 9415.180944] usb 2-1: new high-speed USB device number 76 using sunxi-ehci
[ 9415.333959] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 9415.334531] scsi1928 : usb-storage 2-1:1.0
[ 9419.683033] ehci_irq: highspeed device disconnect
[ 9419.683130] usb 2-1: USB disconnect, device number 76
[ 9419.748463] ehci_irq: highspeed device connect
[ 9420.051623] usb 2-1: new high-speed USB device number 77 using sunxi-ehci
[ 9420.203615] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 9420.204156] scsi1929 : usb-storage 2-1:1.0
[ 9424.564167] ehci_irq: highspeed device disconnect
[ 9424.564263] usb 2-1: USB disconnect, device number 77
[ 9424.629605] ehci_irq: highspeed device connect
[ 9424.941981] usb 2-1: new high-speed USB device number 78 using sunxi-ehci
[ 9425.094025] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 9425.094565] scsi1930 : usb-storage 2-1:1.0
[ 9429.435213] ehci_irq: highspeed device disconnect
[ 9429.435307] usb 2-1: USB disconnect, device number 78
[ 9429.500659] ehci_irq: highspeed device connect
[ 9429.812656] usb 2-1: new high-speed USB device number 79 using sunxi-ehci
[ 9429.964652] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 9429.965191] scsi1931 : usb-storage 2-1:1.0
[ 9434.306259] ehci_irq: highspeed device disconnect
[ 9434.306356] usb 2-1: USB disconnect, device number 79
[ 9434.371675] ehci_irq: highspeed device connect
[ 9434.683325] usb 2-1: new high-speed USB device number 80 using sunxi-ehci
[ 9434.835319] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 9434.835868] scsi1932 : usb-storage 2-1:1.0
[ 9439.207440] ehci_irq: highspeed device disconnect
[ 9439.207537] usb 2-1: USB disconnect, device number 80
  Reply


Messages In This Thread
USB3 external disk not showing up - by Luke - 04-18-2016, 07:52 AM
RE: USB3 external disk not showing up - by Luke - 04-18-2016, 10:24 AM
RE: USB3 external disk not showing up - by Luke - 04-18-2016, 11:23 AM
RE: USB3 external disk not showing up - by Luke - 04-18-2016, 11:28 AM
RE: USB3 external disk not showing up - by Luke - 04-18-2016, 11:31 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  [suggestion] Use powered USB Hubs to connect external hard disks melao 0 523 06-08-2016, 09:45 PM
Last Post: melao

Forum Jump:


Users browsing this thread: 1 Guest(s)