Rockpro64 doesn't boot
#1
I recently received a Rockpro64 board and am having difficulty getting it to boot. I've searched through the forum and haven't found quite the same issue. The board itself is the 4GB version with a 20 mm heat sink, no eMMC module installed, powered by a 12V-5A power supply. and labeled V2.1 2018-07-02. The keyboard and mouse are both USB and an HDMI monitor is attached, as well as an Ethernet cable.

I used Etcher to try the following images: bionic-minimal-rockpro64-0.7.9-1067-arm64.img.xz, bionic-lxde-rockpro64-0.7.9-1067-arm64.img.xz, and stretch-minimal-rockpro64-0.7.9-1067-arm64.img.xz, but none has booted. When power is applied, the green LED comes on but no other LED lights up, not even the Ethernet one, and nothing appears on the monitor.

I've tried several microSD cards, all with the same result. I do have experience burning system images, having worked with Raspberry Pi systems. In fact one of the microSD cards I tried was previously used in a RPi2 both before and after the Rockpro64 attempts.

Does anyone have an idea of what to try next? Are there any checksums available for the download images?

Thanks.


Messages In This Thread
Rockpro64 doesn't boot - by SteveJ - 11-13-2018, 03:52 PM
RE: Rockpro64 doesn't boot - by Luke - 11-13-2018, 04:47 PM
RE: Rockpro64 doesn't boot - by SteveJ - 11-14-2018, 08:52 AM
RE: Rockpro64 doesn't boot - by dukla2000 - 11-14-2018, 03:15 AM
RE: Rockpro64 doesn't boot - by daimon - 11-14-2018, 08:55 AM
RE: Rockpro64 doesn't boot - by SteveJ - 11-14-2018, 09:36 AM
RE: Rockpro64 doesn't boot - by tux_on_tour - 11-14-2018, 05:25 PM
RE: Rockpro64 doesn't boot - by dukla2000 - 11-14-2018, 06:28 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  slarm64 (unofficial slackware) ROCKPro64 RK3399 (aarch64) mara 45 28,795 09-10-2021, 04:56 PM
Last Post: mara
  New OS for RockPro64 is here, TwisterOS Armbian jtremblant 85 24,747 08-28-2021, 11:25 AM
Last Post: jtremblant
  Boot/Shutdown on timer captainmorgan 7 289 08-27-2021, 09:08 AM
Last Post: captainmorgan
Question cannot boot openSUSE - what am I doing wrong? Mentaluproar 2 214 08-12-2021, 04:58 AM
Last Post: igorp
  Other boot options than Sdcard for linux 5.x kernel? MisterA 2 388 07-14-2021, 02:37 PM
Last Post: TRS-80
  RockPro64 CRUX-ARM (aarch64) mara 0 379 06-05-2021, 11:29 AM
Last Post: mara
  Power supply underpowered for Rockpro64, deficient PCIe SATA card, or something else? daffy 8 1,285 05-20-2021, 10:04 PM
Last Post: t4_4t
Question My Rockpro64 stopped booting with these error messages please help seaurchin 4 1,076 02-18-2021, 04:27 PM
Last Post: TRS-80
  Rockpro64 not stable... crashes now and then. Pineapple 18 8,210 02-16-2021, 02:45 PM
Last Post: TRS-80
Question Mainline Debian Buster on RockPro64 ? chrestomanci 36 15,961 02-14-2021, 02:37 PM
Last Post: foresto

Forum Jump:


Users browsing this thread: 1 Guest(s)