issues loading firmware and missing pci card
#1
I just got my rockpro64 2gb (board rev 2.1), and while it boots up fine, it isn't detecting my LSI HBA PCIe card.

lspci just gives no output at all, so I don't think it is simply a missing kernel module.

I'm using the debian stretch image off of the wiki.

I'm also getting errors in dmesg that may or may not be relevant:
[    8.566853] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2
[   16.581959] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2
[   32.584126] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2
[   64.586143] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2
[  128.588049] cdn-dp fec00000.dp: [drm:cdn_dp_request_firmware] *ERROR* Timed out trying to load firmware

I did do an apt-get update/upgrade and rebooted, and the issue persists.  uname -a output:
Linux chunk1 4.4.132-1075-rockchip-ayufan-ga83beded8524 #1 SMP Thu Jul 26 08:22:22 UTC 2018 aarch64 GNU/Linux

That kernel doesn't look terribly fresh...

I'll also go ahead and confess that while I'm quite comfortable with linux inside and out, I rarely use debian-based distros, so please do list complete instructions (typically I use Gentoo) or provide links if you want me to do something like run a custom kernel.  

Any suggestions?


Messages In This Thread
issues loading firmware and missing pci card - by rich0 - 11-10-2018, 09:54 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  prevent bluetooth from loading (manjaro, no wifi/bt card installed) flounder 0 441 02-17-2022, 12:10 PM
Last Post: flounder
  HBA Card working on Aufan's builds but not in debian, armbian or dietpi charsi 1 948 10-29-2021, 11:15 AM
Last Post: TRS-80
  Overlays not loading at boot - ROCKPRO64 on Armbian rookieone 0 712 09-28-2021, 04:10 AM
Last Post: rookieone
  Compiling ayufan mainline - DT-overlay missing Mentaluproar 0 861 07-24-2021, 09:46 PM
Last Post: Mentaluproar
  OMV to Kodi Streaming Issues cogito808 12 12,300 05-25-2021, 08:30 AM
Last Post: helpmerock
  Power supply underpowered for Rockpro64, deficient PCIe SATA card, or something else? daffy 8 3,900 05-20-2021, 10:04 PM
Last Post: t4_4t
  Headphone jack issues Manjaro Mangled 2 1,746 03-06-2021, 11:01 PM
Last Post: Mangled
  Building a new SD card linuxha 2 2,285 04-27-2020, 12:32 AM
Last Post: linuxha
  rockpro64 and wayland - missing files Mentaluproar 1 1,941 08-14-2019, 07:51 PM
Last Post: hmuller
  Major issues with 0.8.3 bionic mate and PCIe TheSupercomputer 2 2,669 07-03-2019, 03:38 PM
Last Post: ayufan

Forum Jump:


Users browsing this thread: 1 Guest(s)