Unable to format sdcard
(04-18-2016, 06:13 AM)tkaiser Wrote:
(04-18-2016, 05:58 AM)Nova136 Wrote: Apparently , phoenixcard cant work with the sdcard-usb readers.

WRONG! Phoenix Card is interface agnostic!

You just ignored issue N° 2 from the list of the most common reasons why Pine64 won't boot: http://forum.pine64.org/showthread.php?tid=514

Your USB reader corrupted data while writing to the card and Phoenix Card was able to detect that. If you would have tried to burn a Linux image, burning would have suceeded but Linux would have crashed later. What to do: Always use H2testw or f3 first. It's so easy and nobody does it.
USB ports on a computer seem to have more issues than most realize, and when using low level software like Phoenix Card, Win32Image, and even android adb the communication used is low level, and doesn't always do a lot of good error checking. When you are using an OS to read/write from a USB device using file system access there is more error checking going on than when you are using one of the 3 above. 

When using Phoenix or Win32Image they both appear to issue a command to write to a specific address(sector) and then the next and the next. This is how an image works. After the image is written, Phoenix then will look at the storage and say, hey you have another 3GB free and the instructions in the image file say to expand partition X if there is free space, so it does. Without the source for Phoenix its hard to say for sure but my guess is it finishes each partitions writes and then verifies the data, and if a address is bad it then simply fails. 

Whereas with the OS saving a file to a USB device it pushes a file and says basically store this, the OS then looks for blank space in the file table and drops the file into it, during write the OS is monitoring for things like worn out cells(sectors) etc. if it finds one the OS says "mark that bad and find me another location to write this to" (if the usb hardware even allows that some USB flash drives handle all that without the OS even seeing it). 

One thing many android phone hackers learned is that the USB ports not soldered to their motherboard can increase the number of incidents with these issues. Front panel ports connected using cheap internal non shielded cables seem to be the culprit. 

I know it sounds like nonsense but plenty of people over at XDA have bricked/softbricked phones by flashing new firmware using the front ports on their PC. I am no USB expert but likley you ran afoul of some issue like that Nova136. I have a perfectly good USB 3 flash card adapter that was giving me trouble when I put the microsd card driectly in it last week. When I put the microsd into a microsd to sd card adapter and then used it in the same device, things worked. 

So a few pieces of advice when using usb to flash your microsd with an image. 

Use the USB ports on the back of your dekstop when possible.

If you are having trouble, dont use hubs, USB extension cables, etc. 

Do not plug/unplug anything from the PC while writing an image. 

If you use a KVM, do not switch machines while writing an image. 

Above all test those cards.

Messages In This Thread
Unable to format sdcard - by Nova136 - 04-17-2016, 02:05 PM
RE: Unable to format sdcard - by tkaiser - 04-17-2016, 02:20 PM
RE: Unable to format sdcard - by Milkman - 04-17-2016, 09:43 PM
RE: Unable to format sdcard - by tkaiser - 04-18-2016, 01:07 AM
RE: Unable to format sdcard - by Nova136 - 04-18-2016, 05:58 AM
RE: Unable to format sdcard - by tkaiser - 04-18-2016, 06:13 AM
RE: Unable to format sdcard - by rahlquist - 04-18-2016, 07:30 AM
RE: Unable to format sdcard - by tkaiser - 04-18-2016, 07:45 AM
RE: Unable to format sdcard - by rahlquist - 04-18-2016, 08:42 AM
RE: Unable to format sdcard - by tkaiser - 04-18-2016, 09:13 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Expanding the /data partition in the Android sdcard Terra854 3 3,927 03-18-2016, 12:45 AM
Last Post: JulianM

Forum Jump:

Users browsing this thread: 1 Guest(s)