armsoc_dri.so, No such file or directory
#1
I have a rockpro64 with bionic-minimal-rockpro64-0.7.10-1072-armhf.img installed on a sd card.
It runs just fine until I tried to install a desktop.

I ran /usr/local/sbin/install_desktop.sh mate and it installed a gazilion of packages.

After reboot I just get a cursor on a blank screen. After investigating the logfile ~/.local/share/xorg/Xorg.0.log it says:


...
[  2609.954] (EE) AIGLX error: dlopen of /usr/lib/arm-linux-gnueabihf/dri/armsoc_dri.so failed
(/usr/lib/arm-linux-gnueabihf/dri/armsoc_dri.so: cannot open shared object file: No such file or directory)
[  2609.954] (EE) AIGLX: reverting to software rendering
[  2610.034] (II) IGLX: enabled GLX_MESA_copy_sub_buffer
[  2610.037] (II) IGLX: Loaded and initialized swrast
[  2610.037] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[  2610.038] (II) ARMSOC(0): Setting screen physical size to 508 x 285
[  2610.070] (EE) ARMSOCPrepareAccess: Failed to map buffer
......

I cant find the file armsoc_dri.so anyware. Any tips?
  Reply


Messages In This Thread
armsoc_dri.so, No such file or directory - by expanderbolt - 10-16-2018, 12:59 PM

Possibly Related Threads...
Thread Author Replies Views Last Post
  OpenVPN will not start Cannot open TUN/TAP dev /dev/net/tun: No such file or director frewind 0 112 04-28-2019, 01:31 PM
Last Post: frewind

Forum Jump:


Users browsing this thread: 1 Guest(s)