EMMC not booting while SD does.
#1
Hello all,
I recently ordered a rockpro64 with a few accessories, one of which is an emmc module (https://ameridroid.com/collections/stora...dule-blank).
However, I am unable to get the rockpro64 to boot with just the emmc module plugged in. I used the usb->emmc adapter to dd the Debian stretch image (version 0.7.9) to it. When it wouldn't boot with that image, I tried an SD card and that worked perfectly. Not only that, but the emmc is visible in /dev/ when booted off the SD so the SBC does recognize the emmc....it just won't boot from it.
After that, I tried a plethora of things to try to get emmc to boot:
1. dd the image to the emmc while booted off the SD with the emmc plugged in to the rockpro64.
2. dd the android emmc image to the emmc.
3. Changed every combination of mmc boot partition enable/disable/ack along with the various boot bus options.
4. Plugged in a serial adapter to view the boot process. The attempted emmc boot showed nothing on serial while the SD boot showed the whole process as expected.

A few things to note:
1. Before flashing anything to the emmc, I noticed it was already loaded with an odroid XU3  image, despite the emmc module I ordered stating it's supposed to be empty. Could this be a problem? I know the Odroids use the boot0 boot partition and I guess rockchip doesnt, so I enabled rw on the boot parts and zero'd them out.
2. The Linux mmc tool and dmesg showes the emmc module as hs200 as opposed to the hs400 that the ameridroid site says. The mmc version is 5.1 as confirmed by the linux mmc tool.
3. The linux kernel reports the emmc model number as DG4032 if that helps.

Any help would be appreciated. Thanks.


Messages In This Thread
EMMC not booting while SD does. - by Apokalypz - 08-08-2018, 02:27 AM
RE: EMMC not booting while SD does. - by wittend - 09-06-2018, 09:34 AM
RE: EMMC not booting while SD does. - by _fs - 09-15-2018, 04:22 PM
RE: EMMC not booting while SD does. - by _fs - 09-15-2018, 05:23 PM
RE: EMMC not booting while SD does. - by jnoxon - 09-25-2018, 08:38 PM
RE: EMMC not booting while SD does. - by mocara - 09-26-2018, 12:23 AM
RE: EMMC not booting while SD does. - by jarcik - 10-13-2018, 03:23 AM
RE: EMMC not booting while SD does. - by jarcik - 10-14-2018, 12:52 PM
RE: EMMC not booting while SD does. - by e3k - 03-04-2019, 05:53 AM
RE: EMMC not booting while SD does. - by jnoxon - 09-28-2018, 05:02 PM
RE: EMMC not booting while SD does. - by jarcik - 10-13-2018, 02:56 AM
RE: EMMC not booting while SD does. - by Bullet64 - 03-04-2019, 07:15 AM
RE: EMMC not booting while SD does. - by graham-r - 03-10-2019, 04:12 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Booting my RockPro64 from NVMe drive PsySc0rpi0n 3 671 05-02-2021, 01:56 AM
Last Post: LMM
  eMMC 128gb flailingeffort 1 719 01-18-2021, 04:42 AM
Last Post: Wizzard
Exclamation need help booting off USB 3.0 HDD/SSD idontgetit 1 1,137 10-29-2020, 04:50 AM
Last Post: t4_4t
  Rockpro64 with PCI FC Card - Not booting (Sometimes) MSteam 1 1,000 10-25-2020, 07:42 PM
Last Post: MSteam
  RockPro64 eMMC boot euu 4 3,115 08-24-2020, 11:07 PM
Last Post: t4_4t
  sw4 jumper for disabling eMMC boot / multiboot ChriChri 0 1,001 03-09-2020, 08:54 AM
Last Post: ChriChri
  Availability of 128GB eMMC ? Arwen 1 1,313 07-22-2019, 11:28 AM
Last Post: Arwen
  RockPro64 not booting jekohk 10 4,886 06-09-2019, 01:53 PM
Last Post: Davidos
  board not working with EMMC RockPro64Newbie 1 1,159 05-10-2019, 02:22 AM
Last Post: Unkn0wn
  Problems with booting nJoy. 1 1,156 03-23-2019, 03:36 AM
Last Post: nJoy.

Forum Jump:


Users browsing this thread: 1 Guest(s)