super fast desktop experience, but youtube issue
#14
(08-03-2018, 10:55 AM)frewind Wrote:
(07-31-2018, 03:40 PM)boudiicca Wrote:
(07-31-2018, 07:48 AM)dukla2000 Wrote:
(07-31-2018, 06:31 AM)steamiestoyster Wrote: removing pulseaudio fixed the video playback speed. Now to get the sound working...

First check which card the HDMI is (on RP64 its card 2), then set ~/.asoundrc accordingly. Mine are below.

Code:
$ aplay --list-devices
**** List of PLAYBACK Hardware Devices ****
card 0: rockchipes8316c [rockchip,es8316-codec], device 0: ff890000.i2s-ES8316 HiFi ES8316 HiFi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: ROCKCHIPSPDIF [ROCKCHIP,SPDIF], device 0: ff870000.spdif-dit-hifi dit-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: rkhdmidpsound [rk-hdmi-dp-sound], device 0: HDMI-DP multicodec-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
chris@rockpro64:~$ cat .asoundrc
pcm.!default {
    type hw
    card 2
}

ctl.!default {
    type hw           
    card 2
}

Yep...removing pulseaudio and setting the .asoundrc as per.....sorted....cheers!

heads up.....a fix is coming in the next kernel...should sort it permanently.

Followed the instruction, video now play at the correct speed, but still no sound Sad

Code:
sudo apt-get remove --purge pulseaudio

Code:
rock64@rockpro64:~$ cat .asoundrc
pcm.!default {
    type hw
    card 2
}

ctl.!default {
    type hw
    card 2
}
rock64@rockpro64:~$ aplay --list-devices
**** List of PLAYBACK Hardware Devices ****
card 0: rockchipes8316c [rockchip,es8316-codec], device 0: ff890000.i2s-ES8316 HiFi ES8316 HiFi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: ROCKCHIPSPDIF [ROCKCHIP,SPDIF], device 0: ff870000.spdif-dit-hifi dit-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: rkhdmidpsound [rk-hdmi-dp-sound], device 0: HDMI-DP multicodec-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Code:
sudo apt-get remove --purge pulseaudio

fixed the speed issue for me.  No audio through the headphone jack however.  I really need that to consider this project a success.


Messages In This Thread
RE: super fast desktop experience, but youtube issue - by jwcolby54 - 11-17-2018, 07:32 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
Big Grin Feature Complete Debian Desktop Release Mrfixit2001 158 79,015 05-29-2021, 04:05 AM
Last Post: twilite
  UART4 in Debian Desktop Release of Mrfixit2001 Gienek 1 1,287 05-19-2020, 02:47 AM
Last Post: Gienek
  Release 0.9.14 Ubuntu Mate desktop, LXDE, OMV, Docker CE (container) Luke 1 2,050 12-10-2019, 01:30 PM
Last Post: Helium75
Exclamation eMMC boot issue jwillmer 0 926 07-19-2019, 03:16 PM
Last Post: jwillmer
  computelibrary build issue with latest ubuntu 18 image rahulsharma 0 727 07-08-2019, 09:25 AM
Last Post: rahulsharma
  issue with kodi freezing randomly Slam 3 1,566 05-24-2019, 03:53 PM
Last Post: mknawabi
  Desktop battlenut 8 3,870 11-18-2018, 06:13 PM
Last Post: evilbunny
  Ubuntu Bionic LXDE Desktop /w Firefox and TightVNC stability HenryBenry 4 2,262 10-11-2018, 04:33 AM
Last Post: HenryBenry
  Issue with hwmon - Fan Stop after logout-Login tuxd3v 1 953 09-22-2018, 08:49 AM
Last Post: tuxd3v
  RockPro Wireless+Bluetooth Issue - Linux (ayufan 0.7.8 and previous) JeffD 23 13,494 09-16-2018, 12:08 AM
Last Post: romtorwator

Forum Jump:


Users browsing this thread: 3 Guest(s)