No signal on composite (aka cvbs) output
#4
No, the problem is different, under /sys/class/drm there is no device for composite output (should be called composite, TV or something similar). I didn't do that.

But, in the meantime, I'm a bit further along. After I modified the DTS file (added an &tve), there is now also a device for composite output:

Code:
root@rock64:~# tree /sys/class/drm/
/sys/class/drm/
|-- card0 -> ../../devices/platform/display-subsystem/drm/card0
|-- card0-HDMI-A-1 -> ../../devices/platform/display-subsystem/drm/card0/card0-HDMI-A-1
|-- card0-TV-1 -> ../../devices/platform/display-subsystem/drm/card0/card0-TV-1
|-- controlD64 -> ../../devices/platform/display-subsystem/drm/controlD64
|-- renderD128 -> ../../devices/platform/display-subsystem/drm/renderD128
-- version

The status of the device is connected:

And I also have that the modes are correct, Rock64 supports for composite only these two:

Code:
root@rock64:# cat /sys/class/drm/card0-TV-1/modes
720x576i50
720x480i60

And I also see that the correct mode is selected (720x576i50):

Code:
root@rock64:# cat /sys/class/drm/card0-TV-1/mode
720x576i50
root@rock64:#

But, I still can't get a picture on the TV. Only the composite cable is connected, no HDMI.

I attached the DTS file and dmesg output.


Attached Files
.txt   rk3328-rock64.txt (Size: 13.17 KB / Downloads: 196)
.txt   dmesg.txt (Size: 46.37 KB / Downloads: 137)
  Reply


Messages In This Thread
RE: No signal on composite (aka cvbs) output - by Osiander - 08-02-2018, 05:47 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  CVBS output Osiander 6 3,536 09-02-2018, 10:50 PM
Last Post: tllim
  HDMI output 1280x1024 in any distro Davo-CC 2 1,839 02-03-2018, 07:45 PM
Last Post: Davo-CC

Forum Jump:


Users browsing this thread: 1 Guest(s)