[solved] Unable to start X
#9
(07-12-2018, 10:46 AM)Osiander Wrote: First of all I've flashed the new image and after that "apt update" and install XFCE4 per tasksel.

    OK. I presume you did
tasksel
     and selected XFCE4

     So, here I am.
[    44.071] (II) LoadModule: "armsoc"
[    44.071] (WW) Warning, couldn't open module armsoc
[    44.071] (II) UnloadModule: "armsoc"
[    44.071] (II) Unloading armsoc
[    44.071] (EE) Failed to load module "armsoc" (module does not exist, 0)
[    44.071] (EE) No drivers available.
[    44.071] (EE)
Fatal server error:
[    44.072] (EE) no screens found(EE)
[    44.072] (EE)


     What did you do third to install the armsoc module shown in your log?
     Clearly, you did not do this,
apt-get install xserver-xorg-video-armsoc
...
Get:1 http://ppa.launchpad.net/ayufan/rock64-ppa/ubuntu xenial/main arm64 xserver-xorg-video-armsoc arm64 1.9.3ayufan6.xenial4 [31.1 kB]

     because then your Xorg's log would read as mine does.
[   963.471] (II) LoadModule: "armsoc"
[   963.471] (II) Loading /usr/lib/xorg/modules/drivers/armsoc_drv.so
[   963.471] (II) Module armsoc: vendor="X.Org Foundation"
[   963.471]    compiled for 1.18.4, module version = 1.4.1
[   963.471]    Module class: X.Org Video Driver
[   963.472]    ABI class: X.Org Video Driver, version 20.0
[   963.472] (EE) armsoc: module ABI major version (20) doesn't match the server's version (23)
[   963.472] (II) UnloadModule: "armsoc"
[   963.472] (II) Unloading armsoc
[   963.472] (EE) Failed to load module "armsoc" (module requirement mismatch, 0)
[   963.472] (EE) No drivers available.

     And how did you force the system to select 23 and not 20 when you did that critical, missing third step?

     Please, be kind enough to include these crucial details.

     For now, I fail to see how this issue can possibly be "solved" until someone posts the full solution specifying how to install armsoc version 23. Nonetheless, I offer my attempt to explain how I executed a work-around stated by t4_4t above.

     I have what appears to be a (partially?) functional X screen at boot by doing the following as root. (These are my full steps starting with a freshly flashed microSD. The first two steps are good practice, but are not necessary.)
apt update
apt-get upgrade
tasksel
     I selected MATE; installation of 788 packages ensued.


cd /etc/X11/xorg.conf.d
mv 20-armsoc.conf 20-armsoc.conf-requires_version_23
mv 20-modesetting.conf.bak 20-modesetting.conf

    Then, either of the following gives (a scarcely tested) X at hdmi's console:
startx


    and/or
reboot

    Unlike text console, the GUI returns to life at the hdmi upon input (from my mouse) and lets me see what I type.

    So, ahm, how about version 23 of armsoc and ./install_desktop? How to make those work?
  Reply


Messages In This Thread
[solved] Unable to start X - by Osiander - 07-09-2018, 06:56 AM
RE: Unable to start X - by zet_lab - 07-09-2018, 11:03 AM
RE: Unable to start X - by t4_4t - 07-09-2018, 05:37 PM
RE: Unable to start X - by pfeerick - 07-09-2018, 06:06 PM
RE: Unable to start X - by t4_4t - 07-09-2018, 09:25 PM
RE: Unable to start X - by Osiander - 07-10-2018, 04:09 AM
RE: Unable to start X - by Falkor - 07-11-2018, 06:52 AM
RE: [solved] Unable to start X - by Osiander - 07-12-2018, 10:46 AM
RE: [solved] Unable to start X - by jovval - 10-03-2018, 03:54 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Display limited to 800x600 [SOLVED] Averell 16 12,902 06-05-2020, 11:07 PM
Last Post: ab1jx
  Unable to boot armbian fchazal 2 2,572 05-19-2020, 06:43 PM
Last Post: Rocklobster
Question [SOLVED] Alpine Linux won't boot rock7 1 3,771 10-22-2019, 04:30 PM
Last Post: rock7
  gstreamer unable to process dvbsrc from ATSC tuner dongle grkblood13 1 2,091 08-31-2019, 09:01 PM
Last Post: grkblood13
  Freeze/reboot/errors when compiling - unable to make - reproducible and not isolated jovval 2 2,695 10-02-2018, 08:10 AM
Last Post: jovval
  If you've messed up your eMMC Card - Solved gregb49 11 11,737 07-11-2018, 02:08 PM
Last Post: gregb49
  rock64/ubuntu start-up pas059 36 27,102 06-28-2018, 08:43 AM
Last Post: pas059
  Any reason why ntp time is 6 minutes slow (Solved) Rocklobster 1 1,763 05-29-2018, 05:27 AM
Last Post: Rocklobster
  [Solved] Open VPN +Wi-Fi hotspot - Debian S3phi40T 1 2,116 05-01-2018, 05:51 AM
Last Post: S3phi40T
  [PROBLEM SOLVED] Distcc Help cooker 2 2,862 05-01-2018, 05:35 AM
Last Post: cooker

Forum Jump:


Users browsing this thread: 2 Guest(s)