If you've messed up your eMMC Card - Solved
#1
After some problems with my 0.6.44 install, I decided to go for a fresh installation.

I tried to wipe my 64GB eMMC to carry out a fresh install but whatever I did, it was no longer accessible by Etcher in Win 10 or Linux (Xubuntu 18.04). I tried many things such as deleting partitions in gparted, but gparted could not delete partitions nor set up a new partition table.

Both Win10 and Linux insisted that the eMMC was only 32MB in size, so I was stuck, however I was able to load xenial mate image 0.5.15 onto a SD Card, and use the pin shorting method to get this onto the eMMC card, as described in the wiki article. Pine wiki rock software releases

That ran fine, so I knew that the eMMC card was not faulty, however I also knew that the update would break the OS, which it duly did.

Eventually, out of desperation, I flashed an SD Card with aufan's 0.6.44 image and running that, with the eMMC installed, I managed to do the following on the Rock 64

  1. Through gparted, I deleted the main root partition, the one that was over 50gb in size.
  2. I ran /usr/local/bin/rock64_reset_emmc.sh (sudo ./rock64_reset_emmc.sh) (I took a clue from the wiki - noobs - troubleshooting your device, although the advice was for the Pine64 and was about using /ussr/local/sbin/update_script.sh which was not available for the rock64 - yes I was getting desperate with what appeared to be a dead eMMC card)
I've no idea which of those sorted out the problem, but I was able to reinstall ayufan's
Code:
bionic-lxde-rock64-0.6.44-239-arm64.img.xz
under Win10. Note, Etcher through Linux still insisted that the eMMC card was a 32mb card, but Win10 Etched saw it as a 64gb card with multiple drives.

I'm hoping that this might help someone else who thinks they might have destroyed their eMMC card. I'm assuming that I did some damage to the uboot(?) partition but, really, I have no idea what I did wrong except by trying to wipe everything off the eMMC Card in the first place.

I'm sure someone out there knows a simpler way to restore your eMMC card.
  Reply


Messages In This Thread
If you've messed up your eMMC Card - Solved - by gregb49 - 07-02-2018, 04:59 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Debian (Vanilla) on Rock64 and eMMC - how ? as365n4 4 2,382 09-21-2020, 04:33 AM
Last Post: as365n4
  Display limited to 800x600 [SOLVED] Averell 16 7,497 06-05-2020, 11:07 PM
Last Post: ab1jx
  Nextcloudpi SD card fills up. default_user8 13 5,870 12-04-2019, 01:30 PM
Last Post: Rocklobster
Question [SOLVED] Alpine Linux won't boot rock7 1 2,292 10-22-2019, 04:30 PM
Last Post: rock7
  Clone the SD to eMMC tagyro 1 1,483 02-06-2019, 06:55 AM
Last Post: evilbunny
  Repair corrupt root filesystem on emmc David82 1 1,957 01-31-2019, 01:11 PM
Last Post: Tozzi
  Migrate Linux from microSD to onboard eMMC elik745i 7 4,480 11-03-2018, 08:23 AM
Last Post: mara
  [solved] Unable to start X Osiander 8 6,688 10-03-2018, 03:54 AM
Last Post: jovval
  Tutorial How to write a image in the eMMc card without USB adaptor or serial cable gedas07 2 1,682 08-29-2018, 10:08 AM
Last Post: gedas07
  Rock64: Debian root fs on software RAID1 of eMMC and microSD - is installing it the s jovval 2 1,600 08-03-2018, 12:33 PM
Last Post: jovval

Forum Jump:


Users browsing this thread: 1 Guest(s)