Problem setting Pine64 as a USB device
#3
Thank you for your response.

Trying different USB cable, also sudo lsusb but I see no change.

In the meanwhile I tried:
Modprobe g_webcam as the only gadget module that is included in armbain 5.3x 3.10.105/107, it failed to load:
Code:
[  125.143273] g_webcam gadget: uvc_function_bind
[  125.143306] gadget_is_softwinner_otg is not -int # << this is the same error I get when loading
[  125.143314] gadget_is_softwinner_otg is not -int #    the g_serial module without the use_acm=0
[  125.143322] gadget_is_softwinner_otg is not -int #    option. In both cases it doesn't work.
[  125.143330] gadget_is_softwinner_otg is not -int
[  125.143347] g_webcam gadget: Unable to allocate streaming EP
[  125.143382] g_webcam 1c19000.udc-controller: failed to start g_webcam: -22

I get the same errors about endpoints when I try to insert my compiled g_serial without the use_acm=0 option. It realy does seem that gadgets simply do not work with this(BSP/mostly BSP) kernel 3.10.107 and that's why it's not included .  However I can't find any further information about it.
I using configfs to setup the gadget seem to get the same result.(and functionfs is not configured on Armbian with 3.10.105/107 kernel)

I found out that USB gadgets actualy do work with the mainline kernel(4.13.xx), which is great, but does not really solve my problem, because the mainline kernel does not support DSI MIPI displays at this time. Because of that, I am still trying to make it work on the 3.10.xx kernel.

I am looking for a way to get both of those features working.
  Reply


Messages In This Thread
RE: Problem setting Pine64 as a USB device - by martin357 - 07-02-2018, 02:08 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Building OP-TEE OS for pine64-LTS foreverska 1 185 12-13-2019, 03:32 PM
Last Post: foreverska
  SoPine/Pine64 LTS: Ubuntu Mate is not booting jaganteki 0 430 11-20-2018, 10:49 PM
Last Post: jaganteki

Forum Jump:


Users browsing this thread: 1 Guest(s)