LoadTrustBL error when booting
#1
Question 
Hi,
I got recently a Rock64 4GB so I'm quite new user Smile
I've done already few experiments with ayufan's images from "stable" branch (0.5.x) and must say it works great. I really appreciate that.
So I've tried 0.6.x images but still cannot succeed with booting them. With serial UART adapter debugging I'm getting with any 0.6.x image:
Code:
DDR version 1.06 20170424
In
SRX
LPDDR3
786MHz
Bus Width=32 Col=11 Bank=8 Row=15/15 CS=2 Die Bus-Width=32 Size=4096MB
ddrconfig:7
OUT
Boot1 Release Time: 2017-05-18, version: 2.43
ChipType = 0x11, 188
emmc reinit
emmc reinit
SdmmcInit=2 20
SdmmcInit=0 0
BootCapSize=0
UserCapSize=14804MB
FwPartOffset=2000 , 0
StorageInit ok = 48862
Raw SecureMode = 0
SecureInit read PBA: 0x4
SecureInit read PBA: 0x404
SecureInit read PBA: 0x804
SecureInit read PBA: 0xc04
SecureInit read PBA: 0x1004
SecureInit ret = 0, SecureMode = 0
LoadTrustBL
LoadTrustBL error:-1
Raw SecureMode = 0
SecureInit read PBA: 0x4
SecureInit read PBA: 0x404
SecureInit read PBA: 0x804
SecureInit read PBA: 0xc04
SecureInit read PBA: 0x1004
SecureInit ret = -2, SecureMode = 0
powerOn 725015
Usb re Boot. 6725015
I guess that LoadTrustBL is where the problem starts.. is it bootloader failure?
What's interesting, is that it's the log from try of booting "u-boot-flash-spi-rock64" image - so I guess the SPI is not flashed correctly Sad
Do you have any ideas what I'm doing wrong?
Thanks!
  Reply


Messages In This Thread
LoadTrustBL error when booting - by pedroz - 02-09-2018, 08:35 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Buildroot 2021.08 not booting from SD card jimmy 1 816 11-08-2021, 02:25 AM
Last Post: hunderteins
  opemmediavault plugin error on "Check" clach04 0 3,511 04-21-2020, 10:13 PM
Last Post: clach04
  Booting from USB 3 SSD with other drives attached. default_user8 0 1,227 02-20-2020, 08:39 AM
Last Post: default_user8
  Gpio error wile using GPIOtest.py Aditya Rastogi 0 1,408 01-31-2019, 02:41 AM
Last Post: Aditya Rastogi
Rainbow USB3 Detection Issues When Booting Without USB Device Attached Dargmuesli 0 1,436 01-14-2019, 11:26 AM
Last Post: Dargmuesli
  Rock64 - can not connect via store's USB-to-serial nor see (if) booting. jovval 5 3,725 09-06-2018, 07:06 AM
Last Post: jovval
  gstreamer error sdarktemplar 1 1,927 08-02-2018, 11:08 PM
Last Post: tllim
  docker contaainer error on "docker login" edwinbmiller 0 1,102 06-18-2018, 10:08 AM
Last Post: edwinbmiller
  Apt-get update duplicate entry error Jxck 1 2,182 06-02-2018, 02:26 PM
Last Post: evilbunny
  mmc0: error -110 edwinbmiller 6 4,983 03-29-2018, 12:44 PM
Last Post: edwinbmiller

Forum Jump:


Users browsing this thread: 1 Guest(s)