Gigabit Ethernet problems
#1
Hi all,

I have my Rock64 plugged into a gigabit switch along with my host computer. After adding the fix for the USB power problem I ran into an issue where ssh would frequently hang and I could not even run vi or remote X  tools. Even aptitude would hang when I attempted to search.

Anyway, I was able to fix the problem by installing ethtool and running ethtool eth0 -s advertise 0x008

This forces the board to only use 100Mbps instead of gigabit. My guess is that there may be something misconfigured in the MAC or PHY driver for this board, preventing large data transfers over gigabit (perhaps inter-packet spacing or something like that is wrong).

-Aaron
  Reply


Messages In This Thread
Gigabit Ethernet problems - by aaronw - 10-27-2017, 10:17 PM
RE: Gigabit Ethernet problems - by maal - 10-28-2017, 04:17 AM
RE: Gigabit Ethernet problems - by uttam - 02-16-2019, 03:04 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  on-board ethernet driver michaelanburaj 0 1,807 03-26-2020, 12:01 PM
Last Post: michaelanburaj
  Ethernet latency nethammer 1 2,538 10-17-2019, 05:15 PM
Last Post: nethammer
  Problems with USB 3.0 and SATA disk (UAS) diglam 6 11,302 10-16-2018, 11:05 AM
Last Post: Trash_Can_Man
  USB3 problems scalextrix 2 3,926 09-08-2018, 01:15 AM
Last Post: scalextrix
  Stock debian image - rock64 - gigabit rhille 11 13,933 08-29-2017, 07:48 AM
Last Post: rhille
  Xenial Mate: Screensaver Preview & LibreOffice Slideshow problems moravecz 2 3,269 08-27-2017, 10:37 PM
Last Post: moravecz
  Broken yellow Ethernet light? jl_678 1 2,863 08-27-2017, 04:23 PM
Last Post: MarkHaysHarris777
  Gigabit Ethernet performance testing fire219 0 4,686 07-02-2017, 07:12 AM
Last Post: fire219

Forum Jump:


Users browsing this thread: 1 Guest(s)