Can not get board to boot up reliably
#16
(06-12-2017, 08:25 AM)pkfpeters Wrote: I did not have the time to really do some in depth research, so I first
made a workaround by letting the kernel panic on soft lockups and auto reboot. At least this will result
in an auto retry without having to toggle power. 

I think the fix is triggered by compiling the kernel without preemptive support; see also my
kernel config.

I think that is somewhat similar to what the Armbian guys have done... I'm pretty sure I've seen their kernel panic and reboot, so at least their setup actually tries to get past the problem. It is weird though that removing preemptive support would b0rk thinks though, isn't it? Isn't that exactly what preemptive support was supposed to prevent (i.e. zombie drivers)? Confused Dodgy I'll have to get another plain boot image up and running, and then I'll give it a try... as I can reproduce this 'gremlin' fairly regularly when I don't want to! :-D

(06-13-2017, 02:45 PM)Kaarme42 Wrote: "Sometimes boots up or fails due to 'soft lockup' CPU#0 stuck for 22 seconds
at a point when calling cfg80211."

This is interesting. I think no total HW problem.

I think we're pretty much put a finger on the fact that it is the WiFi driver module that is screwing up... (the fact that it b0rks when doing something related to 80211 is a pretty big hint that it's network related) basically because it is such a unreliable POS of a driver. Problem is it's still hanging around when the WiFi module isn't installed. But I suspect pkfpeters's may still be onto something re: it having some connection to register initialisation sequence... since a few reboots can sometimes 'fix' it, or often simply a full power cycle and then a reboot.
  Reply


Messages In This Thread
Can not get board to boot up reliably - by Leo - 04-24-2017, 01:41 AM
RE: Can not get board to boot up reliably - by pfeerick - 06-13-2017, 08:34 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Debian Base (3.10.102 BSP 2) won't boot without monitor Scion 7 9,301 09-16-2016, 03:58 PM
Last Post: Scion
  Possible to add a boot logo for boot? Darkshadow2913 4 4,220 09-09-2016, 06:02 AM
Last Post: Darkshadow2913
  Very long boot time with Debian image Xabaras76 5 5,354 07-14-2016, 03:49 PM
Last Post: Xabaras76
  Debian base(102) n xfce(101) does not boot HenryD 2 2,144 07-09-2016, 04:50 PM
Last Post: HenryD

Forum Jump:


Users browsing this thread: 2 Guest(s)