Does latest Tow-Boot install/work correctly for everyone?
#4
(08-03-2023, 02:54 PM)tophneal Wrote:
(08-03-2023, 02:27 PM)dukla2000 Wrote:
(08-03-2023, 12:31 PM)tophneal Wrote: ...

So I'm curious now if anyone else has had this or a similar issue when trying to install tow-boot through SD installer or writing directly to mtd0 from within a booted OS. I'd raise it as an issue on the Github, but I want to be sure I haven't overlooked any potential solutions and I know @samueldr has indicated he isn't able to be as active in maintaining/troubleshooting as before.

Not what you asked, but pine64-pinephonePro-2022.07-006 worked fine for me on my PPP. 35Mb spi.installer.img was dd'd to a tatty old SD on my RPro64 then that booted fine on my PPP and I could do the install.

Same RK3399 ...

FWIW my SDcard looks like (on the RPro64)
Code:
$ lsblk
...
mmcblk1      179:96   0   3.7G  0 disk
├─mmcblk1p1  179:97   0    12M  0 part
└─mmcblk1p2  179:98   0    22M  0 part /run/media/chris/57f8f4bc-abf4-655f-bf67-946fc0f9f25b

Are you sure you have the correct bits held/flicked/switched to get your PBP booting from the SDcard?

On the basis there isn't that much difference between the boards would be tempted to at least try the PPP and/or RPro64 Tow-Boots - at least you should get to the Tow-Boot menu, whether you actually flash is another call. But would eliminate that the PBP download is a duffer.

I made sure I wouldn't need to open it up (and force myself to follow through on my decision) by wiping the eMMC already. There's nothing on the eMMC anymore and the PBP only boots when I insert a ready-to-boot SD, like my early Fedora install, into it. In fact, I recall when I first tested the SD installer of 2021.10-03 I had 0 issue with the SD booting before the BSP on the eMMC.

Mine shows as /dev/sda since I'm working off of an SD boot, but it matches yours (aside from the sda2 mount location.) Since posting, I've also tried writing the image to a different, larger SD card, and writing the installer from a different computer. No success with either. Sad

My best guess so far is a bad video driver, based off of some posts concerning an earlier iteration of tow-boot, though a part of me just can't believe that's the case. The issue was years ago, this should be a 2020 batch member, and there's soooooo many successful installs out there. I suppose I should find/dig out the serial cable for this and see if I can get anything from that.

You guess may be right, I have voiced out on last year that tow-boot may be using older video driver and seems like no update :-( This is one of the main reason that product team decided not to preinstalled tow-boot on current Pinebook Pro production batch.
  Reply


Messages In This Thread
RE: Does latest Tow-Boot install/work correctly for everyone? - by tllim - 08-03-2023, 03:21 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  upgrading u-boot--what version? where to get it? bsammon 11 277 Yesterday, 09:33 AM
Last Post: wdt
  uboot wont boot to SD card after upgrade jbradley419 7 1,043 01-19-2024, 02:29 PM
Last Post: wdt
  Video Flashing/adjusting on boot and reboot jbradley419 0 340 01-16-2024, 09:17 AM
Last Post: jbradley419
  Brand new Pinebook Pro doesn't boot after Manjaro update johnboiles 8 2,445 12-15-2023, 02:11 PM
Last Post: wdt
  PBP won't boot after trying to reinstall Manjaro ARM soupgirl 3 801 12-13-2023, 08:17 PM
Last Post: trillobite
  Various freezes during boot & while running several Linux distros - hardware error? donuts 1 663 11-22-2023, 11:47 AM
Last Post: fxc
  Cannot boot to Kali SD card after uboot upgrade jbradley419 4 1,310 09-19-2023, 08:48 AM
Last Post: dachalife
  Boot into NVME drive, no wifi, sound, buttons... PaulQ 0 839 07-13-2023, 01:50 PM
Last Post: PaulQ
  New Pinebook pro won’t boot Generaltuxenburg 4 2,063 06-14-2023, 07:20 AM
Last Post: KC9UDX
  Followed the blog post to install Fedora: PBP not booting anymore koenigs 6 2,036 06-01-2023, 10:58 AM
Last Post: wdt

Forum Jump:


Users browsing this thread: 1 Guest(s)