Has anyone successfully flashed an Ox64 (128Mb) from linux?
#4
(02-05-2024, 01:58 PM)sm12345 Wrote:
(02-27-2023, 09:01 PM)slondr Wrote: I'm following like 6 guides at once, I've tried bflb-mcu-tool, bouffalo-loader, etc., I have my ox64 wired up to a Raspberry Pi Pico and the machine itself appears as a serial port on my computer. But I can't figure out how to actually flash the 3-layer bin files that [1] lists. Every "official" piece of documentation says to use DevCube, but DevCube's linux binary is completely broken (it isn't marked as executable, and when you mark it as executable and try to run it, it craps out asking for some paleolithic version of glibc; the package released for my system's package manager is also named wrong, which is fun). I'm on day 3 of trying to get anything to write to this board and so far have made exactly 0 progress.

This thing is really making me miss by pinephone or rock64 where you just throw in an SD card with an image written to it and it just works.

[1] https://github.com/openbouffalo/buildroot_bouffalo

Hello, did you ever solve this? I have the same issue trying to flash from ubuntu. Devcube does not launch( tried 1.8.3 and 1.8.9) , i tried on Mint also and it does get a bit further (launches but i cannot get the serial connection to work), even though the board is verified working with devcube on windows and i can flash it no problem with windows but would rather work in linux. 

any advice would be a blessing.

You can try the method described here: https://pine64.org/documentation/Ox64/So...ing_method
  Reply


Messages In This Thread
RE: Has anyone successfully flashed an Ox64 (128Mb) from linux? - by Pavlos1 - 02-12-2024, 12:50 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  [Article] Coding Ox64 BL808 SBC the Drag-n-Drop Way lupyuen 3 479 04-02-2024, 07:38 AM
Last Post: Noahstorey
  xz package is severely affected with injected code in some linux distributions. zetabeta 0 162 03-29-2024, 02:57 PM
Last Post: zetabeta
  [Article] QuickJS JavaScript Engine on a Real-Time Operating System (Ox64 + NuttX) lupyuen 0 279 02-17-2024, 07:24 PM
Last Post: lupyuen
  [Article] Emulate Ox64 BL808 in the Web Browser: Experiments with TinyEMU lupyuen 3 469 02-17-2024, 06:53 PM
Last Post: tllim
  [Article] Automated Testing with Ox64 BL808 Emulator (Apache NuttX RTOS) lupyuen 0 266 02-16-2024, 06:54 PM
Last Post: lupyuen
  [Article] Nim on a Real-Time Operating System: Apache NuttX RTOS + Ox64 BL808 SBC lupyuen 2 570 01-05-2024, 12:27 AM
Last Post: lupyuen
  [Article] $8 RISC-V SBC on a Real-Time Operating System: Ox64 + NuttX lupyuen 0 480 12-17-2023, 02:27 AM
Last Post: lupyuen
  [Article] Fixed the UART Interrupt and Platform-Level Interrupt Controller (Ox64) lupyuen 0 483 12-09-2023, 05:24 PM
Last Post: lupyuen
  [Article] RISC-V Ox64 BL808: UART Interrupt and Platform-Level Interrupt Controller lupyuen 1 562 12-03-2023, 04:24 AM
Last Post: WhiteHexagon
  [Article] RISC-V Ox64 BL808 SBC: NuttX Apps and Initial RAM Disk lupyuen 2 640 11-25-2023, 06:42 PM
Last Post: lupyuen

Forum Jump:


Users browsing this thread: 1 Guest(s)