plasma-dialer doesn't call
#1
Received my "PINEPHONE - Beta Edition with Convergence Package Linux SmartPhone" today. Lucky me  Big Grin (or not?)

Vanilla manjaro shown T-Mobile with my SIM card, as expected, because I took it from my old phone and many people report that this trick works just fine, for example here. Unfortunately OS was so glitchy, that I didn't try to make a call and updated it as soon is it got some battery charge. Had no issues with update and newer version looks better:

uname says plasma-mobile 5.16.11.1-manjaro-arm
plasmashell --version says 5.24.2
cat /etc/lsb-release says manjaro 22.01 (funny, but I don't see it here)

All privacy pins are in upper position, ON.

At this point, if I go to Settings > Cellular Networks > SIM Cards, I do see my SIM 0, and it show IMEI, T-Mobile. Modem details detects my phone number and says enabled: true, state: disabled, registration state: unknown registration status, firmware version is missing - that i don't understand and it looks confusing. next it says interface cdc-wdm0 and then detailed info looks good.
for some reason folder "/var/lib/ofono/" contains two folders with my IMEI (second one has "-3" suffix) that is strange.
Also running something like "ofonoctl list" gives an error "could not aquire org.ofono.Manager on dbus"... with a typo in "acquire"...

Finally if I do a call at plasma-dialer (the "Phone" app) it instantly slides "Dialer" screen (or tab whatever) to an "Active call list" screen, that is blank. If I repeat that several times quickly - sometimes I see that something blinks, like it's trying to call, but that disappears immediately. Tried with and without data on. 

T-Mobile requires VoLTE, so I checked that:


Code:
atinout - /dev/EG25.AT out.txt << EOF
AT+CLCC
EOF
gives:
+CLCC: 1,1,0,1,0,"",128
+CLCC: 2,1,0,1,0,"",128
that is exactly as described here 1 in 4th position in both lines means VoLTE on.

So please help me troubleshoot this:

- first of all, what about that ofono thing? is it deprecated or still used, if used - how to make it work?

- where can I find logs of plasma-dialer ?

- can I run Dialer or other application from command line to make a call and see error output?
I know that
Code:
xdg-open tel://1234567890
does work on Librem5, but in my case it doesn't call and doesn't give any output to console... is there anything else in manjaro?

- ...any better suggestion/ideas why it's not calling?
  Reply


Messages In This Thread
plasma-dialer doesn't call - by Ant - 03-03-2022, 10:37 PM
RE: plasma-dialer doesn't call - by acrux - 03-04-2022, 09:03 AM
RE: plasma-dialer doesn't call - by dcinoz - 03-05-2022, 05:37 AM
RE: plasma-dialer doesn't call - by israel - 03-10-2022, 10:55 AM
RE: plasma-dialer doesn't call - by Ant - 03-18-2022, 06:51 PM
RE: plasma-dialer doesn't call - by israel - 03-18-2022, 08:19 PM
RE: plasma-dialer doesn't call - by Ant - 03-18-2022, 09:07 PM
RE: plasma-dialer doesn't call - by israel - 04-08-2022, 03:09 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  My Pine doesn't allow me to install to eMMC on different OS's Kimberley van Buyten 1 262 05-31-2022, 04:26 PM
Last Post: fxc
  WIFI doesn't stay connected Matt73 0 276 03-10-2022, 08:10 AM
Last Post: Matt73
  call immediately terminated jyoung 10 1,667 01-14-2022, 02:19 PM
Last Post: jyoung
  PinePhone Stuck in landscape (Manjaro Plasma) Ephraimlad 1 643 01-04-2022, 05:41 PM
Last Post: jasonriedy
  New phone - setup - only landscape - KDE plasma westsamoa 2 1,004 09-27-2021, 02:23 AM
Last Post: Uturn
  poor call quality try flipping switch six D4rkh0rs3 0 800 05-12-2021, 12:09 PM
Last Post: D4rkh0rs3
  Problems updating KDE Plasma Mobile OS IMSAI8080 1 1,358 03-07-2021, 01:12 PM
Last Post: mark1250
  Wifi doesn't see 5 GHz network lsitongia 5 2,533 03-02-2021, 08:45 AM
Last Post: dukla2000
  No ability to cancel out of Applications in Both KDE Plasma AND Mobian Basic 10 4,983 03-02-2021, 05:20 AM
Last Post: Basic
  Verizon With Manjaro Plasma? U.P.Penguin 2 1,650 02-23-2021, 12:01 PM
Last Post: U.P.Penguin

Forum Jump:


Users browsing this thread: 1 Guest(s)