3/32 upgrade board, Arrived Without Firmware, Troubleshooting Steps to SOLVED
(skip to last edit to see solution, leaving all steps to make searching for solution easier)
I finally received my new 3/32 upgrade board for my pinephone.
I read the wiki and watched the video, and did the board swap.
It looks like it was not flashed with a bootloader at the factory?
Instead I see a LED flash from the back of the board when I insert the USB and then I lsusb I get
Onda (unverified) V972 tablet in flashing mode
Nothing on the screen though.
I also tried booting a jumpdrive SD but nothing happened, no bootloader,  got the same lsusb response.

I found a copy of the factory-test image(pine64-pinephone-20200726-phosh-v20.05-factory.img) on my computer and with that in the SD slot gave me a pink LED when I inserted USB.
I waited an 20min with the pink LED and dark screen in case anything was being flashed.
I then rebooted did the other tests and then chose the automated test, it is sitting for a long time at 12% testing the LIS3MDL after instantly testing MPU-6050.
this link should help you find the factory test image https://images.postmarketos.org/pinephone/
For some reason my jumpdrive SD is not working/booting so I am DL'ing from this link the Debian image and will try that once the download is finished.
I got the Debian Factory image and booted it, run the auto-test, I don't outright fail and instantly passes the MPU-650, but I never pass the LIS3MDL, just hangs forever at 12% so I never get the option to flash......
Got advice after opening a Pine64 service ticket, they recommended I go to
choose the Beta Edition link and DD the image to SD
This image passes the tests and I am flashing my EMMC, I loaded the OS and ran setup, ran sudo halt and DD the latest JumpDrive to SD
Flashed Debian Mobile mobian-pinephone-phosh-20210421.img to EMMC via jumpdrive
Booted and ran Mobian setup on my Pinephone from a 3/32 upgrade board that arrived unconfigured.
now grabbing software updates, and will enable unstable repos once I have everything configured.

Messages In This Thread
3/32 upgrade board, Arrived Without Firmware, Troubleshooting Steps to SOLVED - by biketool - 06-22-2021, 10:03 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  firmware udate Quectel EG25-G modem alwi 3 241 06-18-2022, 01:32 AM
Last Post: user641
  Connection woes, modem troubleshooting within Bewilderforce 0 630 10-06-2021, 04:02 AM
Last Post: Bewilderforce
  camera firmware problems kqlnut 25 10,334 09-02-2021, 07:49 PM
Last Post: Zebulon Walton
  pinephone circuit board design, conductive parts zetabeta 1 848 08-12-2021, 05:28 AM
Last Post: wibble
  Replaced USB-C side board, touch screen goes nuts Zebulon Walton 2 1,782 04-14-2021, 09:50 AM
Last Post: israel
  Fail safe way to update ANX7688 firmware scholbert 24 14,242 04-01-2021, 01:28 PM
Last Post: zborgerd
  PinePhone replacement board won't stop vibrating acohl 8 4,597 02-28-2021, 03:36 PM
Last Post: Zebulon Walton
  Updated board, still have USB C charging problem xonq 7 3,328 01-31-2021, 10:47 AM
Last Post: xonq
  Possibility of a future board revision novhack 3 1,909 01-25-2021, 04:56 AM
Last Post: y2ktibltd
  New motherboard - ANX firmware won't flash. --- 17 5,908 12-26-2020, 01:53 PM
Last Post: p1x3l3d

Forum Jump:

Users browsing this thread: 1 Guest(s)