Pinebook Pro doesn't boot most of the time unless connected via USB-serial!
#1
My Pinebook Pro has evolved into a lazy AI. It sometimes boots, but most of the time it can't be bothered.

It all started yesterday, when after a couple months of non-use, I decided to re-install a fresh manjaro. Since I was trying different versions of the distro, I cloned a couple of times to the eMMC and finally settled on a minimal version which I cloned to the eMMC using dd.

After that, the machine failed to boot, with only the power led turning on, but in orange. I tried rebooting a few times and finally opened up the case, flipped the switch and connected the serial to USB cable to check for any error messages.

The machine turned on!

I tried a couple of reboots, all worked ok, so I disconnected the serial cable.
 
The machine stopped turning on!

Since then, the machine mostly turns when connected via serial but not every time. It also sometimes starts without a problem without the cable connected, but most of the time it doesn't!

I managed to capture some boot logs.

Failed boot 1:
Code:
U-Boot TPL 2020.07-2 (Aug 14 2020 - 07:33:56)
Channel 0: LPDDR4, 50MHz
BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB
Channel 1: LPDDR4, 50MHz
BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB
256B stride
256B stride
lpddr4_set_rate: change freq to 400000000 mhz 0, 1
lpddr4_set_rate: change freq to 800000000 mhz 1, 0
Trying to boot from BOOTROM
Returning to boot ROM...

U-Boot SPL 2020.07-2 (Aug 14 2020 - 07:33:56 +0000)
Trying to boot from MMC2
mmc_load_image_raw_sector: mmc block read error
Trying to boot from MMC2
mmc_load_image_raw_sector: mmc block read error
Trying to boot from MMC1
mmc_load_image_raw_sector: mmc block read error
SPL: failed to boot from all boot devices
### ERROR ### Please RESET the board ###

Failed boot 2:
Code:
U-Boot TPL 2020.07-2 (Aug 14 2020 - 07:33:56)
Channel 0: LPDDR4, 50MHz
BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB
Channel 1: LPDDR4, 50MHz
BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB
256B stride
256B stride
lpddr4_set_rate: change freq to 400000000 mhz 0, 1
lpddr4_set_rate: change freq to 800000000 mhz 1, 0
Trying to boot from BOOTROM
Returning to boot ROM...

U-Boot SPL 2020.07-2 (Aug 14 2020 - 07:33:56 +0000)
Trying to boot from MMC2

and finally a working boot:
Code:
U-Boot TPL 2020.07-2 (Aug 14 2020 - 07:33:56)
Channel 0: LPDDR4, 50MHz
BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB
Channel 1: LPDDR4, 50MHz
BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB
256B stride
256B stride
lpddr4_set_rate: change freq to 400000000 mhz 0, 1
lpddr4_set_rate: change freq to 800000000 mhz 1, 0
Trying to boot from BOOTROM
Returning to boot ROM...

U-Boot SPL 2020.07-2 (Aug 14 2020 - 07:33:56 +0000)
Trying to boot from MMC2


U-Boot 2020.07-2 (Aug 14 2020 - 07:33:56 +0000) Manjaro ARM

SoC: Rockchip rk3399
Reset cause: POR
Model: Pine64 Pinebook Pro
DRAM:  3.9 GiB
PMIC:  RK808
MMC:  mmc@fe310000: 2, mmc@fe320000: 1, sdhci@fe330000: 0
In:    serial
Out:  serial
Err:  serial
Model: Pine64 Pinebook Pro
Net:  No ethernet found.
Hit any key to stop autoboot:  0
starting USB...
Bus usb@fe380000: USB EHCI 1.00
Bus usb@fe3c0000: USB EHCI 1.00
Bus dwc3: Register 2000140 NbrPorts 2
Starting the controller
USB XHCI 1.10
Bus dwc3: Register 2000140 NbrPorts 2
Starting the controller
USB XHCI 1.10
scanning bus usb@fe380000 for devices... 1 USB Device(s) found
scanning bus usb@fe3c0000 for devices... 3 USB Device(s) found
scanning bus dwc3 for devices... 1 USB Device(s) found
scanning bus dwc3 for devices... 1 USB Device(s) found
      scanning usb for storage devices... 0 Storage Device(s) found

Device 0: unknown device
Card did not respond to voltage select!
switch to partitions #0, OK
mmc0(part 0) is current device
Scanning mmc 0:1...
Found /extlinux/extlinux.conf
Retrieving file: /extlinux/extlinux.conf
236 bytes read in 16 ms (13.7 KiB/s)
1: Manjaro ARM
Retrieving file: /initramfs-linux.img
8462110 bytes read in 384 ms (21 MiB/s)
Retrieving file: /Image
33174016 bytes read in 1458 ms (21.7 MiB/s)
append: initrd=/initramfs-linux.img console=tty1 console=ttyS2,1500000 root=LABEL=ROOT_MNJRO rw rootwait bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash
Retrieving file: /dtbs/rockchip/rk3399-pinebook-pro.dtb
80685 bytes read in 30 ms (2.6 MiB/s)
## Flattened Device Tree blob at 01f00000
  Booting using the fdt blob at 0x1f00000
  Loading Ramdisk to f46f3000, end f4f04f1e ... OK
  Loading Device Tree to 00000000f46dc000, end 00000000f46f2b2c ... OK

Starting kernel ...

:: running early hook [udev]
Starting version 246.5-1-arch
:: running hook [udev]
:: Triggering uevents...
:: performing fsck on '/dev/mmcblk2p2'
ROOT_MNJRO: clean, 60318/3809280 files, 760427/15205211 blocks
:: mounting '/dev/mmcblk2p2' on real root
:: running cleanup hook [udev]

Welcome to Manjaro ARM!

I reinstalled u-boot and followed the instructions to dd the 2 files, didn't make a difference.
I re-seated the eMMC module, it didn't make a difference.

The strangest thing is the fact that, when connected via serial, the machine boots most of the time! I'm afraid that this would that it could be hardware issue, maybe having to do with intermittent power failure. Everything seems ok and plugged in on the board however. The charging light also turns on.

Really sorry for the very long post, especially since it's my very first. Tried to include any relevant info.

Any help will be greatly appreciated.


Messages In This Thread
Pinebook Pro doesn't boot most of the time unless connected via USB-serial! - by nib0 - 09-24-2020, 04:02 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  How is youtube and general web browsing on the PineBook Pro? catloaf 4 332 06-22-2022, 01:49 PM
Last Post: gravedigger
  U-Boot, video console, and visual artifacts dsimic 19 7,912 06-21-2022, 05:28 AM
Last Post: Tazdevl
  Selling Pinebook Pro (ISO) + nvme from Sweden DavidL 5 334 06-20-2022, 03:20 PM
Last Post: DavidL
Question Pinebook Pro end-user ready? Watercourse 3 317 06-19-2022, 10:17 AM
Last Post: Watercourse
  Pinebook Pro not powering on wantageek 20 4,540 06-19-2022, 07:59 AM
Last Post: moserwi
  Pinebook got wet walterbe 9 2,358 06-10-2022, 10:51 AM
Last Post: walterbe
  ANSI Pinebook Pro For Sale sir_mud 1 166 06-09-2022, 08:11 AM
Last Post: gilwood
  In Search Of ISO: Pinebook Pro USA [Got one locally] ozoned 1 198 06-02-2022, 09:16 AM
Last Post: sir_mud
  How to use original PINEBOOK Pro USB-C Docking Deck with my PBP? Comoq 2 249 05-30-2022, 02:45 AM
Last Post: jpalus
  Pinebook Pro Upgrade? StriderofRohan 21 5,761 05-23-2022, 04:51 AM
Last Post: gravedigger

Forum Jump:


Users browsing this thread: 1 Guest(s)