"Fancy" screenshot tool not working
#8
(09-04-2020, 07:38 PM)ragreenburg Wrote:
(09-04-2020, 07:50 AM)spaetz Wrote:
(09-02-2020, 01:19 PM)ragreenburg Wrote:
(09-02-2020, 12:49 PM)spaetz Wrote: Hi there, that woild have been me. Will check the instruction and make the list of dependencies more precise. It had worked on the pinephone when I tried it. Sorry, hut no time today....
All is well, whenever you figure it out just feel free to let me know!
OK, tried it again and updated the instructions somewhat:

https://wiki.mobian-project.org/doku.php...screenshot

These are the dependencies:
Code:
sudo apt install libnotify-bin grim

and this is the screenshot script (I adapted it to store in /home/mobian rather /home/purism

Code:
#!/bin/bash
SCREENSHOT=${HOME}/Pictures/$(date +%Y-%m-%d-%H%M%S).png
notify-send -t 1000 screenshot "Taking a screenshot in 5 seconds"
sleep 5
grim "$SCREENSHOT"
notify-send screenshot "Screenshot stored at ${SCREENSHOT}
Totally unrelated but I figure you know more about this then I do. Do you know where the information is stored when running the command to scale an app?
I think that this script is only not so useful for the main screen, since that one can only be seen if no apps are running.
In that case you can connect with SSH, and run grim from there.
Except unless you want to show off the background, it might have no meaning to make a screenshot of the main screen anyway.


Messages In This Thread
RE: "Fancy" screenshot tool not working - by ryo - 11-30-2020, 04:29 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  firefox-esr stopped working after June 18 update HLing 3 80 1 hour ago
Last Post: dukla2000
  mobile data on mobian not working synaption 1 174 06-02-2021, 03:16 PM
Last Post: Aberts10
  can't get file transfer working. Help, please! quixote 25 1,664 05-28-2021, 06:53 PM
Last Post: Rainer
  chats not working rvh 0 167 05-18-2021, 07:48 AM
Last Post: rvh
  Run Mobian Unstable without risking being stuck without a working phone C0ffeeFreak 3 914 04-23-2021, 01:10 PM
Last Post: RTP
  UFW (uncomplicated firewall) Start On Boot - Mobian (working) theD0ctor 2 559 02-28-2021, 09:58 PM
Last Post: theD0ctor
  some flatpaks not working sfb 2 561 02-15-2021, 10:31 AM
Last Post: C0ffeeFreak
  Keypad not working during call Zebulon Walton 4 618 02-10-2021, 06:56 AM
Last Post: Zebulon Walton
  Mobile network is not working tlo 11 5,091 12-15-2020, 02:49 PM
Last Post: jim.uren@gmail.com
  Mobian virtual keyboard stopped working jim.uren@gmail.com 0 575 11-11-2020, 11:43 AM
Last Post: jim.uren@gmail.com

Forum Jump:


Users browsing this thread: 1 Guest(s)