How to reset board to default state?
(09-01-2020, 12:45 AM)evilbunny Wrote:
(09-01-2020, 12:30 AM)kkdao Wrote:
(08-31-2020, 11:39 PM)evilbunny Wrote:
(08-31-2020, 05:48 PM)kkdao Wrote: I have a Rockpro64 board in which I flashed an Ubuntu OS via an eMMC and installed a system onto it. However, I messed something up during the install and would like to completely start from scratch. There is nothing important on the drive I have attached to the board like this setup here, expect I have an NVMe M.2 SSD:

So I would like to unmount the drive, reformat and redo the LVM volumes I had setup, and do anything else necessary to go back to default configuration settings so I can start from scratch trying to install that system again.

Any tips or pointers would be greatly appreciated!

All data/settings are on the emmc chip, you just need to reflash it and it will be back to defaults...
I hoped that would be the case, but when I tried to re-install the system above again before, I would get systemd.service 'depenedency' errors relating to the mount pointSad

You might need to unmount the partitions, I use etcher and it does it automatically for me.
I've actually tried re-flashing the eMMC with Etcher with a new image of the Ubuntu OS, but I still get errors when trying to run the system again. After looking deeper into the errors I have figured out there is an issue with my drive still being mounted somehow. So when I do 'e2fsck -f /dev/nvme0n1' or 'fsck.ext4 /dev/nvme0n1' I get back:

ext2fs_open2: bad magic number in super-block
e2fsck: Superblock invalid, trying backup blocks...
e2fsck: Bad magic number in super-block while trying to open /dev/nvme0n1
The superblock could not be read or does not describe a valid ext2/ext3/ext4 filesystem. If the device is valid and it really contains an exy2/ext3/ext4 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>
e2fsck -b 32768 <device>
but when I try running e2fsck with the suggested alt superblock i get:
/dev/nvme0n1 contains a LVM2_member file system

I did all this in root FYI (sudo -) after SSHing into my system.
Another thing I probably should've mentioned at the beginning was WHY this all occurred in the first place and it's because I accidentally unplugged the power cord from the outlet while the system was on and running. So that's why the mount point is somehow messed up seemingly.

Messages In This Thread
How to reset board to default state? - by kkdao - 08-31-2020, 05:48 PM
RE: How to reset board to default state? - by kkdao - 09-01-2020, 05:48 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Gentoo, Current state, Test Phase khaosgrille 12 10,886 06-23-2019, 07:14 PM
Last Post: necrose99
  How to release default swap space jzhang18 2 2,922 08-27-2018, 11:20 AM
Last Post: jzhang18

Forum Jump:

Users browsing this thread: 1 Guest(s)