Forum issues after the cluster move
#3
It's Firefox 45.9.0esr, released 2017.04.19, the last pre-Electrolysis ESR version.

According to ssllabs' database, it supports TLS 1.2.
https://www.ssllabs.com/ssltest/viewClie...07&key=127

According to their server test,
https://www.ssllabs.com/ssltest/analyze....219.133.83

The forum supports TLS 1.2 & 1.3, but the handshake simulation section shows,
Firefox 31.3.0 ESR / Win 7 - Server sent fatal alert: handshake_failure
Firefox 47 / Win 7 R - Server sent fatal alert: handshake_failure
Firefox 49 / XP SP3 - RSA 2048 (SHA256) - TLS 1.2 > http/1.1

and a number of other TLS 1.2 browsers getting bumped to plain http.

Looking at the specific TLS 1.2 cipher suites supported, there is just no overlap. The still-good ones FF45 supports would be,
TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256 (0xc02b) Forward Secrecy 128
TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 (0xc02f) Forward Secrecy 128

and the closest the server has enabled are,
TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (0xc030) ECDH x25519 (eq. 3072 bits RSA) FS 256
TLS_DHE_RSA_WITH_AES_256_GCM_SHA384 (0x9f) DH 4096 bits FS 256

(but it does have one weak one enabled.)


Also, www.pine64.org is available via IP6, but according to their testing the SSL config is out of sync with the IP4 one & substantially behind it (e.g. no TLS 1.3):
https://www.ssllabs.com/ssltest/analyze....a136%3a207
  Reply


Messages In This Thread
RE: Forum issues after the cluster move - by Dendrocalamus64 - 06-09-2020, 05:53 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Poll: Move production outside of China? KNERD 10 1,021 04-22-2021, 02:23 PM
Last Post: xalius
  Disappearing forum alerts dsimic 3 274 04-20-2021, 09:24 PM
Last Post: dsimic
  Complain about all the PINE 64 "issues here" - let's have a bit of fun /snark dgdimick 0 250 03-27-2021, 12:54 AM
Last Post: dgdimick
Exclamation Force HTTPS on forum Danct12 4 623 03-02-2021, 04:55 PM
Last Post: KC9UDX
  Extra newlines in forum post TRS-80 5 830 02-26-2021, 09:47 PM
Last Post: KC9UDX
  Anyone having issues with the forum? RegularGuy 11 1,318 02-16-2021, 04:21 PM
Last Post: dgdimick
  Forum issue: not receiving emails marcih 9 2,421 02-11-2021, 06:36 AM
Last Post: marcih
  Account delete on Pine64 Forum User 12599 3 2,671 01-06-2021, 09:14 PM
Last Post: moulder
  Is the forum software of Pine64 open source? Peter Gamma 2 1,545 10-07-2020, 02:38 AM
Last Post: Peter Gamma
  Please create a PineTab section in the forum eaglecup 2 2,561 07-29-2020, 12:26 PM
Last Post: JamesGrelf

Forum Jump:


Users browsing this thread: 1 Guest(s)