Left-side USB 3.0 port not working
#1
I've been having trouble getting my Pinebook Pro's left-hand USB port, the large Type-A one with the blue interior and superspeed pins, to work at all. I can get power from it alright (though no data on whether negotiation is working yet), but nothing I plug into it enumerates or shows up in `lsusb`, nor does `dmesg` show any events. This applies to both USB-2.0-only devices, as well as those that support USB 3.0. The other USB ports - the Type-C one, and the 2.0 Type-A one on the right side, are both working just fine, so I'm suspecting the hardware here. I'm mainly posting this thread to ask if anyone else can confirm that their 3.0 port works, just so we can narrow it down to a spurious defect in my particular unit (one that I, confident with a soldering iron, might repair) or a more general design flaw or firmware bug that needs more professional attention.

So, does your left Type-A USB port work?
  Reply
#2
(11-07-2019, 07:22 PM)diodelass Wrote: I've been having trouble getting my Pinebook Pro's left-hand USB port, the large Type-A one with the blue interior and superspeed pins, to work at all. I can get power from it alright (though no data on whether negotiation is working yet), but nothing I plug into it enumerates or shows up in `lsusb`, nor does `dmesg` show any events. This applies to both USB-2.0-only devices, as well as those that support USB 3.0. The other USB ports - the Type-C one, and the 2.0 Type-A one on the right side, are both working just fine, so I'm suspecting the hardware here. I'm mainly posting this thread to ask if anyone else can confirm that their 3.0 port works, just so we can narrow it down to a spurious defect in my particular unit (one that I, confident with a soldering iron, might repair) or a more general design flaw or firmware bug that needs more professional attention.

So, does your left Type-A USB port work?

I only tried to plug a mouse receiver in it, and it didn't work. I should probably check if the kernel was compiled with xHCI support.
  Reply
#3
Could you post what distros you are using ?
  Reply
#4
(11-07-2019, 11:54 PM)electriccrowbar Wrote: Could you post what distros you are using ?

The default Debian and Ubuntu Bionic.
I think I only tried to use it in Debian, haven't tried Ubuntu. I'll let you know when I have a chance to try.
  Reply
#5
(11-08-2019, 12:09 AM)VoxUnius Wrote:
(11-07-2019, 11:54 PM)electriccrowbar Wrote: Could you post what distros you are using ?

The default Debian and Ubuntu Bionic.
I think I only tried to use it in Debian, haven't tried Ubuntu. I'll let you know when I have a chance to try.

Default Debian, left usb port mouse Logitech m325 working ok.
  Reply
#6
(11-07-2019, 11:54 PM)electriccrowbar Wrote: Could you post what distros you are using ?

Ubuntu Bionic, one of ayufan's images, is what I have now. I didn't get it to work under either this or the factory Debian install, though.
  Reply
#7
I also had problem with the USB3 not working with the stock debian image (even after updates).
Now it is working after I installed Ubuntu/Mate
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  pinebook pro trackpad randomly stops working chewie 3 143 05-08-2021, 06:53 AM
Last Post: KC9UDX
Question External Monitor not Working sciolus 5 624 05-05-2021, 02:05 AM
Last Post: aurora.borealis
  Some keyboard keys not working oddsocks 10 656 04-20-2021, 08:33 AM
Last Post: dsimic
  Microphone not working on Pinebook Pro vfr400racer 2 624 03-21-2021, 02:56 AM
Last Post: vfr400racer
Photo PineBook Docking Deck charging port? ColoBill 3 1,002 02-26-2021, 10:07 PM
Last Post: Paull
  Anyone have a microphone working on a Pinebook Pro? Rachel Stone 5 973 02-20-2021, 05:21 AM
Last Post: dsimic
  Brand-new Pinebook Pro - keyboard not working guy100 8 2,800 10-09-2020, 10:49 AM
Last Post: guy100
  Keyboard - Some keys not working Christoph.Krn 1 1,125 08-27-2020, 07:15 PM
Last Post: rdmarsh
  How's 2.4 GHz Wi-Fi Working for You? diodelass 8 3,764 06-20-2020, 03:21 PM
Last Post: xmixahlx
  Microphone not working linuxfreund 0 887 06-09-2020, 02:11 PM
Last Post: linuxfreund

Forum Jump:


Users browsing this thread: 1 Guest(s)