[2/5/2016][DEPRECATED]Script to automate GUI installation on Ubuntu
(05-01-2016, 10:15 AM)dr5mn Wrote: this is a sandisk sd card, tried a few ones and got the same result each time. (i only buy real ones Smile )

i also followed all instructions to the letter. can't do fsck from the pine, kept telling me that /dev/mmcblk0p2 was mounted, and would not allow me to umount. if i put the card into another linux machine and do fsck it comes up with hundreds if not thousands of errors that need to be fixed.

fixed all errors by literally just holding in the y key, put card back into pine, ran the bash command and it executed the script by terra, but ended with another error: failed to fetch......components-arm64.yml.gz hash sum mismatch and also unable to parse package file......ports.....xenial_inrelease (1)

Maybe try downloading the script before executing it. Be sure to have git installed. 

git clone https://github.com/Terra854/pine64-ubuntu-gui.git
sudo chmod a+x pine64-ubuntu-gui/install-ubuntu-gui.sh
sudo ./pine64-ubuntu-gui/install-ubuntu-gui.sh
Donate BTC: 3Eav9uqXi8Nx1axb7QjK6xV4km4K9YGv9a
Ok guys, the script has been updated with new software marked for installation.

Full changelog:

- Included new drivers
- Included new software for Lubuntu installation.

Links at the first post.
Donate BTC: 3Eav9uqXi8Nx1axb7QjK6xV4km4K9YGv9a

Problem solved with the 20160501 build of Xubuntu posted on the wiki page.

With the same SD card...
(05-03-2016, 11:36 AM)dr5mn Wrote: With the same SD card...

Be careful! Don't execute /usr/local/sbin/resize_rootfs.sh again.
(05-03-2016, 12:43 PM)tkaiser Wrote:
(05-03-2016, 11:36 AM)dr5mn Wrote: With the same SD card...

Be careful! Don't execute /usr/local/sbin/resize_rootfs.sh again.

What tkaiser said. Have "resize filesystem" as a separate choice on top of the list of GUI package installermenus instead of running it inside all the installpackages. Some (like me) want to install more than one desktop environment, because reasons.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Issues with both Deb and Ubuntu germanshep 0 2,560 08-28-2018, 05:47 PM
Last Post: germanshep
  OpenWRT installation guide Sander 0 3,185 07-09-2018, 09:42 AM
Last Post: Sander
  Help debug my pine64A+ ubuntu/plex hangs XaRz 8 10,162 11-02-2017, 06:34 AM
Last Post: XaRz
  Ubuntu 16.04 cannot resolve dns - connection timed out; no servers could be reached marcosti 2 10,159 03-01-2017, 02:46 PM
Last Post: dkryder
Question Ultrawide Display for Ubuntu Mate DE dudeytsang 1 5,071 01-01-2017, 07:26 AM
Last Post: CaptainZalo
  [30/11/2016] pine64-config Terra854 10 15,917 11-30-2016, 08:15 AM
Last Post: Terra854
  SUNVOX - Software installation related topic janeku 17 22,688 11-26-2016, 01:06 PM
Last Post: janeku
  [09/10/2016] [ALPHA] Fedora Images for Pine64 Terra854 3 7,976 11-18-2016, 12:23 PM
Last Post: gregjo
  Pine64+Ubuntu+Tvheadend+DVBT Dongle Shai 3 6,472 10-03-2016, 04:23 AM
Last Post: Shai
  Dmesg output Ubuntu Mate S265 1 3,656 10-02-2016, 07:28 AM
Last Post: MarkHaysHarris777

Forum Jump:

Users browsing this thread: 2 Guest(s)