canNOT boot after a normal apt upgrade
The latest upgrade push kernel 4.4.126 and crash Rock64 when reboot.

By using serial cable, there is a short moment that user can select to boot from the previous kernel (the lovely stable 4.4.77).  So, be claim, everything is still there, I believe.

Unfortunately, seems that there is no hope for pure ssh remote control boxes.

Anyway, any elite kind enough to post a know-how on how to change the default boot order specifically for Rock64 on this forum.

Thank you

p.s.  if possible, also a know-how to prevent the kernel from being updated automatically.

the 1st know-how

$ sudo vi /boot/efi/extlinux/extlinux.conf

change the 2nd line from
default kernel-latest
default kernel-previous
2nd know-how
tested work on a fresh burnt sdcard with 4.4.77

[email protected]:~$ sudo apt-cache showpkg linux-image
Package: linux-image

Reverse Depends:
Reverse Provides:
linux-image-4.4.77-rockchip-ayufan-136 0.5.15 (= )
linux-image-4.4.77-rockchip-ayufan-118 0.5.10 (= )
linux-image-4.4.77-rockchip-ayufan-104 0.5.9 (= )
linux-image-4.4.77-rockchip-ayufan-102 0.5.8 (= )
linux-image-4.4.71-rockchip-ayufan-77 0.4.12 (= )
linux-image-4.4.70-rockchip-ayufan-85 0.4.17 (= )
linux-image-4.4.70-rockchip-ayufan-83 0.4.16 (= )
linux-image-4.4.70-rockchip-ayufan-66 0.4.3 (= )
linux-image-4.4.70-rockchip-ayufan-62 0.3.7 (= )
linux-image-4.4.70-rockchip-ayufan-57 0.3.4 (= )
linux-image-4.4.70-rockchip-ayufan-55 0.3.3 (= )
linux-image-4.4.70-rockchip-ayufan-54 0.3.2 (= )
linux-image-4.4.70-ayufan-29 0.2.1 (= )
linux-image-4.4.70-ayufan-28 0.2.0 (= )
linux-image-4.4.126-rockchip-ayufan-227 0.6.41 (= )
linux-image-4.4.126-rockchip-ayufan-226 0.6.40 (= )

[email protected]:~$ sudo apt-mark hold linux-image-4.4.126-rockchip-ayufan-227 linux-image-4.4.126-rock
linux-image-4.4.126-rockchip-ayufan-227 set on hold.
linux-image-4.4.126-rockchip-ayufan-226 set on hold.

Run "apt upgrade" and you'll see that 4.4.126 is gone.

However, some people said this method induce instability due to rapid changes on all packages. So, you are warned.
I can confirm that with the latest kernel update the system hangs at boot.
Getting back to previous kernel it runs again without issues.

That's a big issue though

On the other hand the hold command you wrote did not worked for me.

I set on hold the packages
at version 0.5.15

that avoid my kernel to be upgraded

I'm using the Xenial minimal image on SD

Possibly Related Threads...
Thread Author Replies Views Last Post
  Help me understand the boot up process olivercfc 0 74 11-10-2019, 08:30 AM
Last Post: olivercfc
Brick Rock64 stuck in boot, please help! Malmgren 7 277 11-05-2019, 07:02 AM
Last Post: Malmgren
Question [SOLVED] Alpine Linux won't boot rock7 1 293 10-22-2019, 04:30 PM
Last Post: rock7
  Rock64 Rev3 doesn't boot and leds blinking fast dishins 2 216 08-12-2019, 06:31 AM
Last Post: dishins
  how to upgrade? skipper 0 128 06-10-2019, 02:07 AM
Last Post: skipper
  Forcing u-boot to detect USB3 storage jandastroy 8 808 04-02-2019, 10:06 PM
Last Post: t4_4t
  Consistent boot from SSD? Is it possible? SirRyanTheGeek 1 189 04-02-2019, 12:28 PM
Last Post: SirRyanTheGeek
  Not able to boot Armbian [email protected] 4GB wundidajah 1 258 03-29-2019, 05:30 AM
Last Post: dkryder
  Boot from USB - What's about resizing the partitions? hg6806 5 280 02-28-2019, 11:09 PM
Last Post: evilbunny
  Rock64 fedora core 29 boot issue: Help please? forwardbackwards 5 947 12-31-2018, 04:32 AM
Last Post: toons

Forum Jump:

Users browsing this thread: 1 Guest(s)