Xenial Mate: Screensaver Preview & LibreOffice Slideshow problems
Using Xenial Mate on Rock64 4GB, I have consistent problems with the Control Center Screensaver and the LibreOffice Impress Slideshow. 

In the Control Center Screensaver whenever I press the Preview button, the system locks up. The mouse cursor moves around, but both keyboard and mouse are not able to do anything.

In LibreOffice Impress, when I try to run a Slideshow (F5), the Slideshow is not seen, but the system appears to be locked up. The mouse cursor moves, but you cannot do anything on the desktop. However, if you press the Esc key, then LibreOffice Impress returns to normal mode. It seems like it tried to launch the Slideshow, but the Slideshow never appears.  Note that the LibreOffice Impress Slideshow function worked correctly and reliably in the Debian image Build 20170809. So there is something unique about the CXenial Mate image. 

Any suggestions would be very much appreciated.
We'll take these one at a time;  although, they are related.

... first, I have reproduced the anomalous behavior;  for which there is one more related glitch-- namely if the check-box is selected on the screen-saver panel ( under preferences look and feel ) "lock screen when screensaver is active" then when the screen saver runs the machine locks and apparently will not allow you to unlock it !!

Not true, at least for the second part;  even though there is no "unlock dialogue"  if you enter your password the screen will unlock...   obviously remove the checkmark to lock the screen when the screen saver becomes active. 

This will not work on the glitch you reported...  but the following will ( although, its messy ).

1)  press  ctrl + alt + F1   to pull up our dearly beloved fbcon.

2)  logon 

3)  start htop with :

         sudo htop

4)  find the lightdm top process;  you might need to configure htop to display in tree view;

5)  select the lightdm process with the cursor and press F9  (defaults to SIGTERM which is what we want)

6)  press the Enter key
         ( the desktop processes will all die )

7)  on the lightdm  logon panel -- Logon

... We'll talk about the rest later .

Note :  I've also had this same behavior happen when the screensaver triggers with the settings panel open !   Its a PITA because then I have to go out and kill the lightdm again and start over;  really needs a reboot.

We need to find out if there is an upstream bug report for this, and if not report it.

Note:  To emulate the screensaver bug ( but without locking up the whole lightdm ) click the System --> lock screen

...  the screen will lock, but you'll be able to move your mouse around;  nothing else will work.  If you move the mouse ( or type a key ) the unlock dialogue will NOT appear !  ... try it  press some keys !  

... to unlock the screen press the enter key ( tries to unlock and clears the buffer ) then type your password and press the enter key;  the screen will unlock--  never does the unlock dialogue appear !

marcushh777    Cool

please join us for a chat @  irc.pine64.xyz:6667   or ssl  irc.pine64.xyz:6697

( I regret that I am not able to respond to personal messages;  let's meet on irc! )

I replicated your solutions and they work as described.
These do not keep you from entering the problem, but they let you escape from an otherwise bad situation.

When you enter a 'lock up' from Control Center -> Screensaver -> Preview, then your 'ctrl + alt + F1' procedure does indeed let you get back to a working desktop. Great!

Likewise, from System -> lock screen, the mouse moves, but nothing else appears to work. However as you indicate, by pressing the Enter key, blindly typing my password, and again pressing the Enter key, I can resume with a fully operational desktop. How the heck did you ever figure this one out? After the fact, it seems plausible, but I don't think I would ever have thought to try the Enter-password-enter combination on my own.  Great!

As suggested, I've unchecked the "lock screen when screensaver is active" check-box on the Screensaver window. I haven't let the system go to screensaver when idle yet, but this should happen overnight.

Thank you very much for the workarounds!!! Anything I can do to help get a fundamental solution to this problem?

What about the LibreOffice Impress Slideshow issue?


Possibly Related Threads…
Thread Author Replies Views Last Post
  Release 0.9.14 Ubuntu Mate desktop, LXDE, OMV, Docker CE (container) Luke 1 4,253 09-19-2019, 07:00 AM
Last Post: Malmgren
Information New Builds from ayufan (0.8.X) w Video/3D/Mate desktop Luke 37 55,474 09-09-2019, 04:01 AM
Last Post: ayufan
  Gigabit Ethernet problems aaronw 2 6,259 02-16-2019, 03:04 AM
Last Post: uttam
  Problems with USB 3.0 and SATA disk (UAS) diglam 6 12,196 10-16-2018, 11:05 AM
Last Post: Trash_Can_Man
  USB3 problems scalextrix 2 4,236 09-08-2018, 01:15 AM
Last Post: scalextrix
  Xenial Mate + Emmc Guettt 2 3,334 05-31-2018, 02:49 AM
Last Post: pas059
  compiling meteor on xenial-minimal-rock64-0.5.15-136-armhf.img.xz maudy 0 1,991 05-02-2018, 05:35 PM
Last Post: maudy
  Rock64 Xenial Mate Community Build Image [microSD to eMMC] [0.5.15-136] Guld 6 8,006 03-14-2018, 08:26 PM
Last Post: colgs3b
Brick Mate Kiosk Problem on Rock64 RocknKiosks 1 2,706 02-11-2018, 05:01 PM
Last Post: RocknKiosks
  Debian Mate arm64 0.5.15 - mouse polling rate S3phi40T 0 1,676 02-10-2018, 02:08 PM
Last Post: S3phi40T

Forum Jump:

Users browsing this thread: 1 Guest(s)