Armbian - Xenial Desktop (Pinebook)
#71
(12-14-2018, 05:12 AM)ImmortanJoe Wrote:
(12-14-2018, 04:24 AM)igorp Wrote: Both versions must/should work.

I didn't test eMMC for this latest build for 1080p with legacy kernel 3.10.y and which is a bit pointless to invest into. Others were tested many times and install is super easy. It is possible that eMMC which is in your Pinebook is not supported in the kernel. It is rare but possible.

Isn't Legacy using the same BSP kernel as the shipped KDE Neon?

You are right though. I don't see the eMMC listed with fdisk -l
Although that appears to be the issue, I don't see why that would make the whole installation section of armbian-config go missing.

I kind of wanted to dump the legacy Ambian onto the eMMC to replace KDE Neon which is useless to me, and continue to run Armbian mainline from MicroSD. This is solely because the legacy release supports BT and appears to support suspend. Besides that it's a pain because it doesn't support the newer version of ext4.

I confirm, the eMMC drive is not recognized by the legacy kernel. For the moment I'll still use the mainline on the eMMC and the legacy on the SD card.
  Reply
#72
Anyone know of a fix for the jumpy trackpad on xenial? I love armbian, but the trackpad on my 1080p pinebook is nearly unusable for me.
  Reply
#73
How can I control the screen brightness? Seems like xbrightness does not work.
I'm using Stretch with mainline
  Reply
#74
(01-07-2019, 09:31 AM)fitter Wrote: How can I control the screen brightness? Seems like xbrightness does not work.
I'm using Stretch with mainline

If xbrightness does not work with Armbian, and it does not work with Archlinux/Manjaro neither there was this discussion with some scripts.
I have not tried them though..

https://forum.pine64.org/showthread.php?tid=5062
  Reply
#75
If you are using the Armbian with kernel 3.10 you need to format the eMMC as ext2 in order to boot from eMMC, it won't boot with ext4.

On mine I can't get the 4.19 kernel version to boot at all.
  Reply
#76
I see that armbian stretch has moved from unsupported to supported, finally.

However, I'm still stuck on 5.60 and dev branch. I wonder, if there's any way to upgrade to supported next branch and 5.69 version?

Update: I've looked everywhere through armbian-config, but can't seem to find a switch between dev <-> next branches. I can switch to nightly, but this takes me to the 5.68-dev, that still has no sound and has backlight problems.
  Reply
#77
So it isn't just me. I guess there is no obvious way to shift branches. That's unfortunate.

I've mostly been using the original preview of Armbian. It works well, besides the lack of support for some of the hardware.

The last week I've mostly been using the smelly version from MicroSD because all I've been doing is scripting and web browsing in short bursts.

Odd. I didn't have any issue with using the brightness control that's a part of the battery applet. Just remember CLICK AND DRAG. If you just click on the bar to lower brightness it'll jump straight to zero.

Slow window resizing on both versions of Armbian can be worked around by disabling compositing, with the aveat that dragging becomes slower.

Overlay scrollbar bugs seem to be he cause of the lack of scrollbar in terminal windows. I think they can be disabled. I just installed lxterminal and set it to default instead.

For whatever reason, Firefox is way faster than Chromium too if it's bothering anyone.


(01-08-2019, 08:07 PM)WZ9V Wrote: If you are using the Armbian with kernel 3.10 you need to format the eMMC as ext2 in order to boot from eMMC, it won't boot with ext4.

the eMMC isn't even visible as a device with the legacy kernel.
  Reply
#78
I've ended up going with re-imaging way.

I've backed up my /home for data and settings, then exported a list of installed packages from dpkg (to quickly restore package set to previous state).
  Reply
#79
I've been having trouble taking advantage of any of the Mali gpu (OpenGL ES/OpenCL/Vdpau/etc..). I see the lima driver being loaded in the kernel (lima 1c4000.gpu)...
Any suggestions? Is there a non-free deb package I should download?
Thanks
  Reply
#80
(03-02-2019, 03:59 PM)tequilasunrise Wrote: I've been having trouble taking advantage of any of the Mali gpu (OpenGL ES/OpenCL/Vdpau/etc..). I see the lima driver being loaded in the kernel (lima 1c4000.gpu)...
Any suggestions? Is there a non-free deb package I should download?
Thanks

Still a bit early to use LIMA, may be mid of this year is a good time. Currently PinePhone development still progress with MALI and will replace to LIMA when ready to do so.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Pinebook 1080p / KDE Neon freezes every 5-10 min pyrrhumain 4 100 Yesterday, 07:34 PM
Last Post: pyrrhumain
  will openMP work on a pinebook? rustythorn 2 77 07-23-2019, 01:42 PM
Last Post: tophneal
Information Manjaro ARM for Pinebook erchache2000 61 3,910 07-20-2019, 04:09 AM
Last Post: Luke
  Wi-fi stops working - Armbian cel 1 89 06-26-2019, 01:57 PM
Last Post: cel
  pinebook 1080p crash and fix nano2 2 162 06-24-2019, 07:41 PM
Last Post: pyrrhumain
  NIxOS installation guide for Pinebook Surehand53 0 127 06-23-2019, 03:46 AM
Last Post: Surehand53
  Improve the life of your Pinebook battery by setting charger's voltage limits wlad 0 130 06-11-2019, 02:27 PM
Last Post: wlad
  Adding coherent_pool to boot.cmd on Xenial Mate by Ayufan causes boot loop k_mp 0 59 06-11-2019, 01:36 PM
Last Post: k_mp
  How can I reliably get battery status on pinebook tillea 5 1,249 06-11-2019, 10:10 AM
Last Post: wlad
  Failure in setting the display backlight with Armbian 5.86 [SOLVED] wlad 0 71 06-11-2019, 03:36 AM
Last Post: wlad

Forum Jump:


Users browsing this thread: 1 Guest(s)