Docker 1.12 on Pine64 ?
#1
Hello,

   there is a solution to make docker 1.12 running on pine64 ? With Debian or with other Linux distribution ?

For now I installed Debian Jessie pine64-image-debianbase-310102bsp image but the version of docker is 1.6.

Thanks for you're advices.

Regards
  Reply
#2
Use the Ubuntu Xenial image instead... you are probably hitting the wall on Debian as the part of the debian philosophy/methodology is to hold packages back (a LOT) longer to allow more time for bugs and conflicts to be found and fixed (hence why it is (was?) preferred for low-maintenance production servers). So you don't get the latest and greatest unless you're willing to fiddle a lot. One of the many reasons Ubuntu came into being. Anyway, on the ubuntu xenial image, I am currently running

Code:
Docker version 1.12.1, build 23cf638

and I don"t remember having to fiddle with any special configuration stuff... I think I just did a "sudo apt-get install docker.io" and let it install all the dependencies.
  Reply
#3
Thanks pfeerick. I'll go to install it to test.
  Reply
#4
Not so good I have kernel error :


Code:
Dec  3 16:45:42 pine64 kernel: [ 1147.944296] aufs au_opts_verify:1602:dockerd[780]: dirperm1 breaks the protection by the permission bits on the lower branch
Dec  3 16:45:42 pine64 dockerd[747]: time="2016-12-03T16:45:42.336452000Z" level=warning msg="Couldn't run auplink before unmount /var/lib/docker/aufs/mnt/10d904b007bd428f40a736cc787f26fc589e223246cf3c42e4387a6beb0438e3-init: exec: \"auplink\": executable file not found in $PATH"

Do you have those errors on you're installation ?

Seally boy !!! Tongue  I don't use arm64 docker images ...


Code:
# docker run -i -t arm64el/helloworld-arm64el
Hello from Docker.
 This message shows that your installation appears to be working correctly on arm64el.
  Reply
#5
(12-03-2016, 10:46 AM)guidtz Wrote: Seally boy !!! Tongue  I don't use arm64 docker images ...

Yeah... the trick here is to instruct docker to use aarch64 or armhf images, as docker defaults to amd64... so if you use pre-made docker recipes you'll need to edit the file before you build the container to specify aarch64/armhf. Unless docker has an option to set/override the default architecture? so in instead of ubuntu as the distro, use aarch64/ubuntu or armhf/ubuntu. And the same goes if you wanted a debian base...i.e. aarch64/debian or armhf/debian.

You can see all the ready to use aarch64 base images here, and the armhf base images here. Just keep in mind that these are only tempoary solutions until Docker work out how they are going to implement multi-architecture support into the docker registry

But good to see it's working for you... Wink have fun!
  Reply
#6
Better solution is to use aarch64 base images no ? Now I have to test it in swarm cluster

Let there be rock  Cool

Do you know threads or documentations about compiling recent kernel on pine64 ?
  Reply
#7
(12-03-2016, 10:46 AM)guidtz Wrote: ...

Code:
Dec  3 16:45:42 pine64 kernel: [ 1147.944296] aufs au_opts_verify:1602:dockerd[780]: dirperm1 breaks the protection by the permission bits on the lower branch
/docker
This is a known limitation due to the old aufs implementation in the 3.10 kernel.

(12-03-2016, 10:46 AM)guidtz Wrote:
Code:
Dec  3 16:45:42 pine64 dockerd[747]: time="2016-12-03T16:45:42.336452000Z" level=warning msg="Couldn't run auplink before unmount /var/lib/aufs/mnt/10d904b007bd428f40a736cc787f26fc589e223246cf3c42e4387a6beb0438e3-init: exec: \"auplink\": executable file not found in $PATH"
Did you install the aufs-tools packages (cgroup-lite and apparmor is recommended as well)?

(12-03-2016, 09:34 PM)guidtz Wrote: ...
Do you know threads or documentations about compiling recent kernel on pine64 ?

You may try this one.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  ROK OS v7 OK Bitcoin Fullnode OpenBazaar for Pine64+ OKtoshi 9 9,310 05-21-2021, 12:14 PM
Last Post: killor
  lost eth0 on my pine64 psarazin 7 1,951 03-22-2021, 05:55 PM
Last Post: kuleszdl
  Debian Pine64 h264/5 Video under vlc ozcy 6 6,871 04-15-2020, 05:27 AM
Last Post: dmitrymyadzelets
  Debian 10 (Buster) in deep freeze - includes support for Pine64+ amp 5 5,061 07-22-2019, 09:29 PM
Last Post: amp
  Pine64 Debian Stretch/mainline [4.14.7] CallMeFoxie 50 64,733 07-22-2019, 09:24 PM
Last Post: amp
  Script to build pure Debian images for Pine64+ amp 1 1,959 05-01-2019, 09:09 PM
Last Post: tllim
  Debian (Stretch) for Pine64-LTS wgray 2 2,936 04-04-2019, 09:54 PM
Last Post: wgray
  Announcement: OMV (OpenMediaVault) for PINE64 DuDu371 11 17,765 12-07-2018, 09:52 PM
Last Post: flinkazoid
  Debian Stretch on Pine64 (run rock64 images on pine64) douglasmiranda 3 4,408 07-25-2017, 11:14 PM
Last Post: douglasmiranda
  pine64 not booting bgwATbewas 4 3,224 02-07-2017, 01:07 PM
Last Post: Luke

Forum Jump:


Users browsing this thread: 1 Guest(s)