Anyone got jackd working?
#1
Trying to get Guitarix to run on the Pine64 and it needs me to set up and configure jackd.  I've never had good luck with that.  Anyone here manage to get it configured / working?

I figure if I can get it to work, I can salvage an old amp into a pretty spiffy Pine64 powered multi-effects practice amp.
  Reply
#2
yea, it's coming back to me now....pulseaudio and jack don't play well together. Grabbed the compatible version of pulseaudio-module-jack from the Jessie Backports repository. I know I still got some configing ahead of me but I'll see if I can get it to work. I was able to verify that my USB guitar cable was being detected by the Pine64. I could probably grab Audacity right now a record to it without using Jack Audio. Then again, I am eyeballing this board for a possible guitar effects machine as a kind of father-son project so.....
  Reply
#3
putting pulseaudio on top of jack on top of alsa didn't seem to work. Although I may have neglected to add myself to real time access at the time. I've got myself added to an "audio" group that in PAM has access to realtime. That took all the memory allocation messages away. Now it's just the jackd starts and immediately dies....even if I launch with pasuspend -- jackd {parameters}. Message is "child process terminated with signal 7"

I never could get jack to work...
  Reply
#4
I know, I'm the only one posting to my own thread, effectively making it my "jack journal" but, I just want to drop this link here for future reference...

https://sourceforge.net/p/guitarix/wiki/..._-ARM_SoC/

Short answer is there are "issues" with getting jack to run on Arm, but it's possible (might require patching jack). External sound card seems to be a must. The above link appears to have a (complex) solution using what appears to be a similar processor to the Pine.
  Reply
#5
Well, if makes you feel any better, I'll come out of the woodwork for long enogh to admit that you're not talking to yourself... you're not going mad or anything... 

I have absolutely no experience with using jackd, so havn't posted anything as I had nothing to say that would help. It sounds like it's a niche need, so I dont fancy your chances finding anyone else already on the forum who can help, but you never know! However, since you have the modivation to solve the problem though, I'm sure you'll be posting the answer to the problem soon enough, thus helping some other unfortunate soul out... or throwing your hands up and admitting defeat... for now. Fingers crossed!

I'll return the stage back to you now! Big Grin
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Information Howto: OctoPrint Working on Pine 64 chaos_actual125 21 16,397 03-21-2021, 11:45 PM
Last Post: Impaled
  Captive portal at school not working on the Pinebook pro WilliamZieg 2 1,663 02-06-2020, 10:41 PM
Last Post: xmixahlx
  Q4OS WiFi Dongle not working cheezmeister 3 2,435 04-07-2017, 08:01 AM
Last Post: iccoldbeer
  HowTo working with MPD and analog sound caragk 3 5,692 11-09-2016, 08:44 AM
Last Post: jkmooney
Exclamation JAVA App. not working correct wrongway 0 971 09-14-2016, 11:14 AM
Last Post: wrongway
  Internet not working properly cezar.suteu@gmail.com 2 1,591 06-17-2016, 01:12 AM
Last Post: cezar.suteu@gmail.com
  wget not working? slerched 3 1,992 06-01-2016, 08:15 AM
Last Post: slerched
  Wireless mouse & kbd recognized but not working thehamguy1 9 4,004 05-17-2016, 11:44 AM
Last Post: thehamguy1

Forum Jump:


Users browsing this thread: 1 Guest(s)