Waydroid install instructions end up attempting to use wrong URLS to aquire .debs
#1
I've been attempting to install Waydroid (with these instructions https://wiki.debian.org/Mobian/How-to#Ho...a_Waydroid, which links to: https://docs.waydro.id/usage/install-on-desktops). And for some reason it appears apt is attempting to use urls that just don't work (Failed to fetch...). After some URL exploring it looks like the last part of the url is wrong... And I have ran apt update & apt upgrade

Any ideas why this is happening and/or are there better directions out there?

Heres the command output of 'apt install' & 'cat /etc/os-release' for system version info.

sudo apt install waydroid
[sudo] password for mobian:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  apparmor arch-test bridge-utils busybox-static
  cloud-image-utils debootstrap distro-info
  distro-info-data fakechroot genisoimage
  ibverbs-providers libaio1 libboost-thread1.74.0
  libdistro-info-perl libfakechroot libfmt9
  libgbinder libgfapi0 libgfrpc0 libgfxdr0
  libglibutil libglusterfs0 libibverbs1 libiscsi7
  liblxc-common liblxc1 libpam-cgfs librados2
  librbd1 librdmacm1 libssh-4 libsubid4 liburing2
  lxc lxc-templates lxcfs mmdebstrap
  python3-gbinder qemu-block-extra qemu-utils
  uidmap uuid-runtime
Suggested packages:
  apparmor-profiles-extra apparmor-utils ifupdown
  mtools squid-deb-proxy-client
  ubuntu-archive-keyring shunit2 wodim cdrkit-doc
  btrfs-progs lvm2 python3-lxc qemu-user-static
  apt-transport-tor genext2fs perl-doc qemu-user
  squashfs-tools-ng
The following packages will be REMOVED:
  busybox
The following NEW packages will be installed:
  apparmor arch-test bridge-utils busybox-static
  cloud-image-utils debootstrap distro-info
  distro-info-data fakechroot genisoimage
  ibverbs-providers libaio1 libboost-thread1.74.0
  libdistro-info-perl libfakechroot libfmt9
  libgbinder libgfapi0 libgfrpc0 libgfxdr0
  libglibutil libglusterfs0 libibverbs1 libiscsi7
  liblxc-common liblxc1 libpam-cgfs librados2
  librbd1 librdmacm1 libssh-4 libsubid4 liburing2
  lxc lxc-templates lxcfs mmdebstrap
  python3-gbinder qemu-block-extra qemu-utils
  uidmap uuid-runtime waydroid
0 upgraded, 43 newly installed, 1 to remove and 0 not upgraded.
Need to get 5,445 kB/27.0 MB of archives.
After this operation, xxx MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Err:1 http://deb.debian.org/debian bookworm/main arm64 qemu-utils arm64 1:7.2+dfsg-7
  404  Not Found [IP: 2a04:4e42:44::644 80]
Err:2 http://deb.debian.org/debian bookworm/main arm64 debootstrap all 1.0.128+nmu2
  404  Not Found [IP: 2a04:4e42:44::644 80]
Err:3 http://deb.debian.org/debian bookworm/main arm64 distro-info-data all 0.58
  404  Not Found [IP: 2a04:4e42:44::644 80]
Err:4 http://deb.debian.org/debian bookworm/main arm64 distro-info arm64 1.5
  404  Not Found [IP: 2a04:4e42:44::644 80]
Err:5 http://deb.debian.org/debian bookworm/main arm64 liblxc1 arm64 1:5.0.2-1
  404  Not Found [IP: 2a04:4e42:44::644 80]
Err:6 http://deb.debian.org/debian bookworm/main arm64 liblxc-common arm64 1:5.0.2-1
  404  Not Found [IP: 2a04:4e42:44::644 80]
Err:7 http://deb.debian.org/debian bookworm/main arm64 libpam-cgfs arm64 1:5.0.2-1
  404  Not Found [IP: 2a04:4e42:44::644 80]
Err:8 http://deb.debian.org/debian bookworm/main arm64 lxc arm64 1:5.0.2-1
  404  Not Found [IP: 2a04:4e42:44::644 80]
Err:9 http://deb.debian.org/debian bookworm/main arm64 lxcfs arm64 5.0.3-1
  404  Not Found [IP: 2a04:4e42:44::644 80]
Err:10 http://deb.debian.org/debian bookworm/main arm64 qemu-block-extra arm64 1:7.2+dfsg-7
  404  Not Found [IP: 2a04:4e42:44::644 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q..._arm64.deb  404  Not Found [IP: 2a04:4e42:44::644 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/d...u2_all.deb  404  Not Found [IP: 2a04:4e42:44::644 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/d...58_all.deb  404  Not Found [IP: 2a04:4e42:44::644 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/d..._arm64.deb  404  Not Found [IP: 2a04:4e42:44::644 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/l..._arm64.deb  404  Not Found [IP: 2a04:4e42:44::644 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/l..._arm64.deb  404  Not Found [IP: 2a04:4e42:44::644 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/l..._arm64.deb  404  Not Found [IP: 2a04:4e42:44::644 80]E: Failed to fetch http://deb.debian.org/debian/pool/main/l..._arm64.deb  404  Not Found [IP: 2a04:4e42:44::644 80]


E: Failed to fetch http://deb.debian.org/debian/pool/main/l..._arm64.deb  404  Not Found [IP: 2a04:4e42:44::644 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q..._arm64.deb  404  Not Found [IP: 2a04:4e42:44::644 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

mobian@mobian:~$ cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 12 (bookworm)"
NAME="Debian GNU/Linux"
VERSION_ID="12"
VERSION="12 (bookworm)"
VERSION_CODENAME=bookworm
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"
  Reply
#2
now i take from my memory, which may have some serious inaccuracies.

i think mobian did have some issues with signing keys. if you have those old keys, updates may not work as intended.

does apt-get update give any errors?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Phoch Trixie weekly install seems nice reTestability 0 440 03-10-2024, 08:47 AM
Last Post: reTestability
  mobian installed to eMMC - how to install tow-boot grump_fiddle_reinstall 6 2,800 11-22-2023, 11:46 AM
Last Post: aLoop100o
  apt trying to install a package version not in the repo chainingsolid 1 778 11-12-2023, 03:54 AM
Last Post: evilbunny
  Recent install, no wifi user641 3 1,740 01-12-2023, 03:06 PM
Last Post: user641
  Time is wrong after reboots stucked at 27th august user641 2 1,516 09-08-2022, 01:39 PM
Last Post: user641
  snap install exceeded maximum runtime jojuma 0 869 07-17-2022, 07:52 AM
Last Post: jojuma
  Waydroid Intallation on Bookworm Dinosaur1946 6 4,937 01-30-2022, 12:03 AM
Last Post: Dinosaur1946
  Waydroid error: not using Wayland. But I am! quixote 7 7,160 01-09-2022, 02:47 PM
Last Post: jsch
  22 July 2116 -- wrong Date & Time Anna 7 6,513 07-30-2021, 07:29 PM
Last Post: bcnaz
  Best/easiest way to install minimal Debian on PinePhone? mcgee 6 5,871 07-18-2021, 09:35 AM
Last Post: swiley

Forum Jump:


Users browsing this thread: 1 Guest(s)