Tow-boot problems and restoring uboot
(05-18-2022, 11:53 AM)wibble Wrote: Based on the doc linked in post #4 I think zeroing 32k starting at an 8k offset should remove enough of the u-boot from the SD for the pinephone to boot from eMMC, but I haven't tried it. Something like this, assuming I've remembered which device is uSD and which eMMC - do check!
dd if=/dev/zero of=/dev/mmcblk0 bs=1024 seek=8 count=32

 i have tried it and it booted from emmc like it should

 but when i tried to tell tow-boot to boot from sd card the boot hanged

 so i think that dd command wipes too much of u-boot

 and it is for use the sd card as storage only


multi-distro sd doesn't boot either when i tell it to boot feom emmc

and then tell tow-boot to boot from sd again

after the aqua led the phone vibrate three times with red led then yellow

and fall back to boot from emmc (manjaro phosh if it matters)

You'll need to be more specific about exactly what you're trying to do as the details may matter. We have 3 bootloaders with differing capabilities and requirements:
tow-boot - configuration is baked in, so it should 'just work' with standard partitioning from distros that use the specific layout it needs. It won't work with distros that don't follow the layout it needs, or more complicated partitioning and multibooting options.
u-boot - can be configured so can be made to work in some situations where tow-boot can't, but as it doesn't have display support there are practical limitations to using it for multi-option situations.
pboot - from Megous, with a gui - very versatile but rarely used beyond the multi-OS SD image, and you'll need to do the config yourself.

The reason for overwriting (part of) u-boot (or whatever other bootloader) on the SD is to make sure it won't work as a bootloader, otherwise the bootloader on the emmc won't be used. The bootloader on the emmc must be capable of booting whatever you have on the SD though.
i have manjaro phosh on the emmc and i flashed tow-boot to it
  manjaro boots fine but when i swiched boot to sd with arch phosh (from dreemurrs -embeded) that i wiped it's boot loader
  and it didn't boot.  i flashed arch on this sd again with boot loader but i'll wipe it again and see what happens

and i described what happens with milti-distro sd in #11

dmes - dmesg from manjro boot on emmc

 dmesa  - dmesg from arch on sd rederected from tow-boot on emmc

  you can see it tries to load danctnix kernel  but at the end manjaro is booted


Attached Files
.txt   dmesa.txt (Size: 34.19 KB / Downloads: 122)
.txt   dmes.txt (Size: 33.42 KB / Downloads: 116)
I see you've asked at - posting here for anyone who's missed it.
(08-14-2022, 09:26 AM)wibble Wrote: I see you've asked at - posting here for anyone who's missed it.

 i wanted to post here as well but file attachment refused to work

 maybe because i was on windows xp


Possibly Related Threads…
Thread Author Replies Views Last Post
  mobian installed to eMMC - how to install tow-boot grump_fiddle_reinstall 6 2,466 11-22-2023, 11:46 AM
Last Post: aLoop100o
  How to check if tow-boot is installed? jojuma 3 1,209 09-29-2023, 11:29 PM
Last Post: tllim
  Mobian boot failed with zstd message after upgrade. Mahgue 0 747 09-01-2023, 11:29 AM
Last Post: Mahgue
  Stability problems with 6.1 kernel Zebulon Walton 9 2,894 05-12-2023, 08:09 AM
Last Post: zetabeta
  4G data on default startup / boot dcinoz 1 936 04-29-2023, 11:24 PM
Last Post: dcinoz
  PinePhone won't boot after software update jb2000 2 1,494 03-17-2023, 07:26 AM
Last Post: Zebulon Walton
  Boot log analyses -> GPU no regulator (mali) found freelectro 0 1,049 03-06-2023, 12:06 PM
Last Post: freelectro
  boot gets stuck shortly after disk decryption vortex 8 4,313 02-13-2023, 02:11 AM
Last Post: sharase
  [solved] Black screen at boot time mdk 0 1,077 01-13-2023, 03:33 AM
Last Post: mdk
  No boot after upgrade: vibration, red LED, then 2 vibrations and yellow LED 3x5co 1 1,084 01-04-2023, 06:46 PM
Last Post: 3x5co

Forum Jump:

Users browsing this thread: 2 Guest(s)