Telephony Dead
#1
For a short time after installing Biktorgj's firmware I was able to sometimes make and receive calls though audio was poor and they often terminated.
However after some upgrades (one of which included modemmanager) that ended.  The modemmanager log now produces

  <info>  [modem1] simple connect state (8/8): all done
  <info>  [modem1] 3GPP registration state changed (home -> searching)
  <warn>  [modem1] couldn't load operator code: Current operator MCC/MNC is still unknown 
  <warn>  [modem1] couldn't load operator name: Current operator id is still unknown
  <info>  [modem1] state changed (connected -> disconnecting)
  <info>  [modem1] state changed (disconnecting -> searching)

and then loops forever with

  <info>  [modem1] 3GPP registration state changed (searching -> idle)
  <info>  [modem1] state changed (searching -> enabled)
  <info>  [modem1] simple connect started...
  <info>  [modem1] simple connect state (4/8): wait to get fully enabled
  <info>  [modem1] simple connect state (5/8): register
  <info>  [modem1] 3GPP registration state changed (idle -> searching)
  <info>  [modem1] state changed (enabled -> searching)

With frequent interjections of

  <warn>  [modem1] couldn't load operator code: Current operator MCC/MNC is still unknown
  <warn>  [modem1] couldn't load operator name: Current operator id is still unknown

Evidently this problem is unique to my Pinephone.  I guess it's going to have to become a PDA.
Perhaps someday an upgrade will happen to fix it.
  Reply
#2
Rebooting has no effect but power cycling by pulling the battery gets me

[/dev/cdc-wdm0] Allocating new client ID...
[/dev/cdc-wdm0] Registered 'wds' (version 1.67) client with ID '2'
<info> [modem0/bearer1] QMI IPv4 Settings:
<info> [modem0/bearer1] address: 100.151.236.32/26
<info> [modem0/bearer1] gateway: 100.151.236.33
<info> [modem0/bearer1] DNS #1: 10.177.0.34
<info> [modem0/bearer1] DNS #2: 10.177.0.210
<info> [modem0/bearer1] MTU: 1500
<info> [modem0] state changed (connecting -> connected)
<info> [modem0] simple connect state (8/8): all done

After that a few calls go through and then back to the old behavior.
  Reply
#3
It might be a long shot, but consider filing an Issue at Biktorgj's firmware repo? You may have stumbled on a bug. And if not, someone may be able to help you otherwise.
Cheers,
TRS-80

What is Free Software and why is it so important for society?

Protocols, not Platforms

For the most Linux-y experience on your Linux phone, try SXMO!
  Reply
#4
The problem was present before I installed Biktorgj's firmware.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Telephony stopped working biketool 5 1,622 03-06-2022, 03:30 AM
Last Post: biketool
  SMS after dead battery antiX-Dave 4 4,481 06-05-2020, 08:11 PM
Last Post: antiX-Dave

Forum Jump:


Users browsing this thread: 1 Guest(s)