Disable on screen keyboard permanently.
#1
OK my PinePhone is in the keyboard case. I go into "Settings --> Accessibility" and disable the on screen keyboard. On reboot the on screen keyboard is re-enabled even though the phone is still in the keyboard case.

Is there a way to disable the on screen keyboard so that I can turn it on and off manually but if I turn it off it will be off when I reboot?
  Reply
#2
Maybe a desktop icon that allows toggling the on/off setting ?
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#3
The problem I have had is similar but would require the same fix. I resize my desktop display to 175% to better fit all the icons onto the screen without scrolling. I use the apply to make the change but when the phone is turned off or rebooted the settings have not been saved. A permanent save feature would be helpful. Thanks for your comment. I have your same problem when I use my bluetooth keyboard with my phone. Each time I begin a new session with the keyboard I have to go to settings and disable the onscreen keyboard. Thanks for your comment.
  Reply
#4
(02-04-2022, 01:09 PM)gilwood Wrote: The problem I have had is similar but would require the same fix. I resize my desktop display to 175% to better fit all the icons onto the screen without scrolling. I use the apply to make the change but when the phone is turned off or rebooted the settings have not been saved. A permanent save feature would be helpful. Thanks for your comment. I have your same problem when I use my bluetooth keyboard with my phone. Each time I begin a new session with the keyboard I have to go to settings and disable the onscreen keyboard. Thanks for your comment.

Not sure what distro you are using, but you may be able to change the scale factor in /etc/phosh/phoc.ini. Change the setting under [outputBig GrinSI-1]. For example to "scale = 1.75".

For the keyboard, I have not tried this yet, but there is a script on this page: https://wiki.mobian-project.org/doku.php...ccessories

-john
  Reply
#5
Is there a simple command that can be issued at the terminal or via an on-screen icon that can toggle the on-screen keyboard on and off in Mobian? Having it active obviously makes for awkward use of the hardware keyboard. I don't necessarily need it to be permanently disabled but it would be nice to have a quick way to disable it with a single icon press.
  Reply
#6
Based on the script on the wiki page I guess something like this should work as the basis for a script which you could then add a .desktop file for:

if [ $(gsettings get org.gnome.desktop.a11y.applications screen-keyboard-enabled) = "true" ]; then gsettings set org.gnome.desktop.a11y.applications screen-keyboard-enabled false; else gsettings set org.gnome.desktop.a11y.applications screen-keyboard-enabled true; fi
  Reply
#7
(02-15-2022, 08:05 AM)wibble Wrote: Based on the script on the wiki page I guess something like this should work as the basis for a script which you could then add a .desktop file for:

if [ $(gsettings get org.gnome.desktop.a11y.applications screen-keyboard-enabled) = "true" ]; then gsettings set org.gnome.desktop.a11y.applications screen-keyboard-enabled false; else gsettings set org.gnome.desktop.a11y.applications screen-keyboard-enabled true; fi

Thanks, that works great!

What I did was use that in a shell script ~/bin/keybd, that displays the result before exiting:

Code:
#!/bin/bash

if [ $(gsettings get org.gnome.desktop.a11y.applications screen-keyboard-enabled) = "true" ]; then gsettings set org.gnome.desktop.a11y.applications screen-keyboard-enabled false; else gsettings set org.gnome.desktop.a11y.applications screen-keyboard-enabled true; fi

echo ""
echo ""
echo ""
echo =====================================================""
echo "Toggling on-screen keyboard..."
echo "Keyboard is now: $(gsettings get org.gnome.desktop.a11y.applications screen-keyboard-enabled)"
echo =====================================================""

sleep 2

I installed xterm since I found that unlike King's Cross the xterm window closes completely after it exits (no need to swipe up).

Code:
sudo apt install xterm

Then I created the desktop file in ~/.local/share/applications/keybd_toggle.desktop:

Code:
[Desktop Entry]
Name=04 Toggle Keybd
Type=Application
Icon=input-keyboard.png
Exec=/usr/bin/xterm -fg white -bg black -e /home/mobian/bin/keybd
Categories=Utility;
X-Purism-FormFactor=Workstation;Mobile;

This makes for a very quick way to toggle the onscreen keyboard. (The reason for the number "04" in the name is to put this near the top of the screen. I have my most frequently used icons named that way, currently prefixed 00 through 04.)
  Reply
#8
(02-04-2022, 01:49 PM)johns Wrote:
(02-04-2022, 01:09 PM)gilwood Wrote: The problem I have had is similar but would require the same fix. I resize my desktop display to 175% to better fit all the icons onto the screen without scrolling. I use the apply to make the change but when the phone is turned off or rebooted the settings have not been saved. A permanent save feature would be helpful. Thanks for your comment. I have your same problem when I use my bluetooth keyboard with my phone. Each time I begin a new session with the keyboard I have to go to settings and disable the onscreen keyboard. Thanks for your comment.

Not sure what distro you are using, but you may be able to change the scale factor in /etc/phosh/phoc.ini. Change the setting under [outputBig GrinSI-1]. For example to "scale = 1.75".

For the keyboard, I have not tried this yet, but there is a script on this page: https://wiki.mobian-project.org/doku.php...ccessories

-john

Thanks I'm running Mobian bookworm. Tried the edit of phoc.ini but the /phosh/phoc.ini does not exist under etc. Even tried to search the hidden files. I'm a Linux newbie so be kind but any assistance is appreciated. Thanks
  Reply
#9
(03-01-2022, 05:08 PM)gilwood Wrote: Thanks I'm running Mobian bookworm. Tried the edit of phoc.ini but the /phosh/phoc.ini does not exist under etc. Even tried to search the hidden files. I'm a Linux newbie so be kind but any assistance is appreciated. Thanks

https://wiki.mobian-project.org/doku.php...-variant-2
  Reply
#10
(03-02-2022, 06:26 AM)wibble Wrote:
(03-01-2022, 05:08 PM)gilwood Wrote: Thanks I'm running Mobian bookworm. Tried the edit of phoc.ini but the /phosh/phoc.ini does not exist under etc. Even tried to search the hidden files. I'm a Linux newbie so be kind but any assistance is appreciated. Thanks

https://wiki.mobian-project.org/doku.php...-variant-2

Right, forgot that you have to copy /usr/share/phosh/phoc.ini to /etc/phosh/phoc.ini to edit initially.

(Also know that once you do that, going forward after upgrades you may want to compare those two files to see if anything has changed in the /usr/share/phosh copy that you may want to also apply to your customized copy in /etc/phosh.)

-john
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Keyboard keeps disappearing the moment it's touched jojuma 1 225 10-29-2023, 08:34 AM
Last Post: walter1950
  New keyboard issue sandspur 29 9,833 10-05-2023, 02:27 AM
Last Post: grump_fiddle_reinstall
  how to disable ipv6 at kernel level with towboot? vusra 2 673 07-09-2023, 01:25 AM
Last Post: vusra
  Unable to do initial setup of Weather due to keyboard LibrePhoneUser 2 820 07-07-2023, 03:29 AM
Last Post: jojuma
  Screen stay black unless power key pressed short freelectro 0 492 06-24-2023, 01:55 PM
Last Post: freelectro
  Unsuspend → Black screen mdk 15 3,895 06-22-2023, 11:20 AM
Last Post: Melechtna
  Lock screen question: always squeekboard tuxcall 1 1,011 02-02-2023, 08:51 PM
Last Post: Haibara23
  [solved] Black screen at boot time mdk 0 850 01-13-2023, 03:33 AM
Last Post: mdk
  Battery problem with a Pinephone keyboard and Mobian elode 2 1,861 12-22-2022, 07:10 PM
Last Post: acid andy
  Disable headphone controls 3x5co 0 541 09-10-2022, 07:11 AM
Last Post: 3x5co

Forum Jump:


Users browsing this thread: 1 Guest(s)