No audio on HDMI after u-boot upgrade
Hello all,

A couple of months ago I flashed the spi from my RockPro64. It worked and I was able to boot from USB3. Tried it a couple of times just to see how it worked but kept booting from the sd card (I've been using LibreELEC, btw).

The thing is yesterday I got a case to a ssd I had here, connected it to the USB3 and tried to boot. It didn't work. I imagined that it could be due to some lack of support from the relatively old u-boot I had flashed before, so I downloaded the newest version from here. I followed the instructions from here and things at first seemed to have worked fine.

Now the issues:

- First thing I noticed (and that had me thinking the flash proccess worked) is that now I have a verbose boot that I didn't have before. The ssd still doesn't boot from the USB3 port but I noticed it boots from the USB2 (maybe it was already booting from USB2 with the old u-boot, but I didn't do this test before reflashing). When connected to USB 3 it shows a lot of debug messages, but doesn't boot.

- If instead I use an USB flash drive it boots ok (both from USB2 and 3), which makes me think that it's maybe some compatibility issue with my case/adaptor, although it works fine with USB2.

- But the worst part is the audio... After upgrading there's no audio from HDMI, no matter if I boot a LibreELEC img from the sd card or USB2/3. I even tried to erase the spi using the img "erase_spi.img", but it didn't work (at least I think it didn't, because I still can boot from USB and the debug messages still show up).

- I also noticed that if I boot from another img I had here (this time a 'complete' Linux - Manjaro, not LibreELEC) audio works.

I'm attaching the logs I see when booting from the sd card after upgrading u-boot (no HDMI audio):

U-Boot 2021.04-11556-g9ecacf77d2 (Jun 30 2021 - 17:48:07 +0000)

SoC: Rockchip rk3399
Reset cause: POR
Model: Pine64 RockPro64 v2.1
DRAM: 3.9GiB
MMC: mmc0fe310000: 2, mmc0fe320000: 1, sdhci@fe330000: 0
Loading Environment from SPIFlash... SF: Detected gd25q128 with page size 256 bytes
*** Warning - bad CRC, using default environment

In: serial
Out: vidconsole
Err: vidconsole
Model: Pine64 RockPro64 v2.1
Net: eth0: ethernet@fe300000
starting USB...
Bus usb@fe300000: USB EHCI 1.00
Bus usb@fe3a0000: USB OHCI 1.0
Bus usb@fe3c0000: USB EHCI 1.00
Bus usb@fe3c0000: USB IHCI 1.0
Bus dwc3: usb maximum-speed not found
Register 2000130 MbrPorts 2
Starting the controller
scanning bus usb@fe30000 for devices... 1 USB DEvice(s) found
scanning bus usb@fe3a0000 for devices... 1 USB Device(s) found
usb@fe3c0000 for devices... 1 USB Device(s) found
usb@fe3c0000 for devices... 1 USB Device(s) found
scanning dwc3 for devices... 1 USB Device(s) found
           scanning usb for storage devices... 0 Storage Device(s) found
Hit any key to stop autoboot: 0
Card did not respond to voltage select!: -110
switch to partitions 0, OK
mmc1 is cuurent device
Scanning mmc 1:1...
Found /extlinux/extlinux.conf
Retrieving file: /extlinux/extlinux.conf
220 bytes read in 6 ms (37.1 KiB/s)
1:      LibreELEC
Retriving file: /KERNEL

Is there anything I can do to at least fix the audio? Since I use this RP64 mostly to consume media (LibreELEC) it's essential.

I appreciate any help from someone more experienced.

The same happened to me using Batocera.

I tried (and made it possible) to enable 933MHz ram speeds (need to tweak the procedure a bit):

I got it working properly on my Manjaro Linux in the emmc. Everything works and ram speed is bumped to 933MHz.

However while trying the microSD with Batocera (booting thanks to u-boot on the SPI), the audio doesn't work at all.

If you have installed mtd-utils.....
then nandtest (with no switches) is an easy way to erase SPI (-k to retain data)
something like......nandtest /dev/mtdblock0...... it does take ~15m though

Possibly Related Threads…
Thread Author Replies Views Last Post
  RP64 Won't Boot After Power Down ColPanic_ 10 7,699 06-27-2023, 07:31 AM
Last Post: dkebler
  Any suggestions for USB audio devices? unixpoet 0 590 06-03-2023, 11:11 AM
Last Post: unixpoet
  RockPro64 doesn't boot when PCIe to M.2 adapter is installed Cerberus 3 3,473 11-27-2021, 11:38 PM
Last Post: Cerberus
  Carte PCIe bloquant le démarrage du Noyau / PCIe card blocking Kernel boot dml-pc 4 4,966 02-17-2021, 11:35 AM
Last Post: dml-pc
  Won't boot with SATA card rjzak 4 5,715 01-09-2021, 05:56 PM
Last Post: kuleszdl
  Won't boot with 2.5GBe PCIe adaptor connected voltagex 1 2,890 10-20-2020, 12:22 PM
Last Post: xmixahlx
  rockpro 64 does not boot up automatically after software reboot rahulsharma 12 13,419 04-17-2020, 09:00 AM
Last Post: pgwipeout
  No boot with Supermicro AOC-SASLP-MV8 (serial output) kram0000 0 1,772 10-22-2019, 04:00 PM
Last Post: kram0000
Music ROCK64 Stereo Audio DAC Add-on FancyPBJ 1 3,165 08-27-2018, 03:07 PM
Last Post: Luke

Forum Jump:

Users browsing this thread: 1 Guest(s)