LTE data does not work on T-Mobile US with latest postmarketOS 21.06 SP3
I have a Pinephone Beta Edition (3 GB) running the latest postmarketOS 21.06 SP3 (kernel 5.13.12) Plasma and all updates installed (Discover does not show any updates when connected to WiFi and while Falkon works) and I have never been able to get LTE data working. I am on T-Mobile US network, have good reception, can see all the modem (IMEI) and SIM (IMSI, Subscriber Number etc) information and have received text messages and calls but mobile internet refuses to work (it is not just the browser either as apk is not able to connect either with WiFi disabled). I have verified the APN settings as well and they match what is listed on T-Mobile's website. I have tried turning Mobile Data on and off in the Plasma Control Center, rebooting, various combinations of those and changing the Authentication Method in APN settings. I am perplexed (as it seems that for those who cellular related issues it often is messaging and calls and VoLTE that do not work properly while LTE data does) and also a bit frustrated by this (one of the main reasons I decided to get a Pinephone right now is that it would be better for tethering than my iPhone, especially with the USB C dock that comes with the 3 GB version). Right now there is no check mark in the 'Active:" box below "Internet" on the Cellular Networks -> Access Point page of the Plasma System Settings app but even when there was, internet would not work, even though the AP type is listed specifically as "internet".
I'm on Mobian and mobile data never worked for me reliably, but I was able to get it to work sometimes. I think it only works over 3G, but I'm not entirely sure.

I tried setting Network Mode to 3G only in modem settings just now and I got a connection, so maybe you can try that.

Possibly Related Threads…
Thread Author Replies Views Last Post
  can I retrieve accidentally deleted voice mail with T mobile ? HLing 4 1,079 12-13-2023, 01:24 AM
Last Post: oldschool
  how to backup user data? Uturn 1 736 08-30-2023, 05:23 AM
Last Post: Kevin Kofler
  New Zealand network providers mobile data Linux2thabone 3 3,385 08-05-2023, 06:17 AM
Last Post: SchizoPinePhone225
  Temporary fix for Modem Not Coming Back on in SXMO Postmarketos Pinephone kebab 2 2,196 07-16-2023, 11:14 AM
Last Post: kebab
  US Mobile, via T-Mobile, won't support Pinephone Pro - SOLVED, SIMPLY jovval 10 3,611 07-07-2023, 12:06 PM
Last Post: jovval
  Problems updating KDE Plasma Mobile OS IMSAI8080 6 3,570 06-30-2023, 11:39 PM
Last Post: ionmich
  Current Situation With Setup and Carrier Activation With Tracfone Verizon T-Mobile pinephoneuser22 0 756 05-26-2023, 08:40 PM
Last Post: pinephoneuser22
  Cellular Data, Mobian - "No WWAN Adapter Found" justneedsomedatathanks 3 4,379 05-25-2023, 09:03 PM
Last Post: justneedsomedatathanks
  Cannot call at several mobile phones Gon 3 1,446 05-04-2023, 05:18 AM
Last Post: Gon
  Error while dist upgrade PostmarketOS shellchocolat 0 768 03-16-2023, 02:56 AM
Last Post: shellchocolat

Forum Jump:

Users browsing this thread: 1 Guest(s)