Potential Solution for RTL8812AU issues, need help with next steps

Like many before me, I did not buy the USB wifi adapter in the PineStore because I thought that I should be able to use any RTL8812AU chip that I could find. Obviously I'm out of luck and feeling pretty frustrated.

So far, I've been unable to use any android image successfully except for Ayufan's 7.1, and the stock 7.1.2 SD image. The 8.1 SD image is missing partitions on boot (something I read led me to believe this is because the img labeled for SD is actually for EMMC), and the 9.0 image doesn't boot at all. Both the standby and power on lights turn on and stay on any time I've tried to use that image. I read elsewhere that the only working image for 9.0 is the 64 GB one, and I do have an extra 128GB SD card lying around, so I'll try that one later.

At any rate, 7.1.2 works perfectly for my use case with a few tweaks, except I can't get any RTL8812AU chips to work. I have tried 5 different ones just today. I can see the RTL8812au.ko module exists in /system/lib/modules, and DMESG shows that my wifi adapter is recognized, VID/PID and all. When I try turning on wifi through network settings, DMESG says that rfkill-wifi driver failed to initialize successfully, and states that it failed to turn on the generic adapter. Basically there is a missing piece in there somewhere but I'm not sure where.

On ODROID's forums I found this thread: https://forum.odroid.com/viewtopic.php?t=24326 which seems super promising, but I'm not sure how I would go about applying the principles found there to android 7.1.2 on my Rock64. I don't see /etc/modprobe.d or a wifi_list.txt or anything of the sort. Can anyone point me in the right direction?
Here is what I see in dmesg when I try to turn on the wifi:

Any updates? I need help.
getting over it mod apk

Forum Jump:

Users browsing this thread: 1 Guest(s)