DOA 2GB Pine
I received my 2GB Pine yesterday, so was pleased to see it after such a long wait.

However, there is no HDMI output, the box is dead. I've tried with 2A / 3A (specific for RPI etc) chargers, different images, removing all peripherals when booting up etc  etc etc. I've gone through the '6 most common problems' - all fine from my perspective.

Nothing, no HDMI output of any form. I get a red light (well, that's useful... wtf change the red/green indicator in pre-prod to make it just show power. Stupid)

I wondered if it was down to dodgy EDID, not so, tried on several TV's, monitors etc. I used to work for a broadcaster doing linux system engineering, so I have access to diagnostic tools and a pretty good idea of debugging.. Nothing at all. Dead.

Really disappointed but that's life. 

So, what's my recourse for a refund. By any luck I should get that next year due to the pace this has been going so far.
Since some time ago, Pine64 introduced different Android images that work only with the LCD touch screen output. Those images won't output HDMI signal. Have you by any chance used one of those LCD images? If so, you have to burn an image that supports HDMI output.

Have you also tried the board with a 1080p TV? There is a known issue with older 720p TV's as well as any kind of adapters such as HDMI to DVI, HDMI to VGA etc.

It would also be a good idea if you could try different HDMI cables as the one you use might be defective or incompatible.

Burning another image to a different micro SD card would also be very helpful to determine what's going on with your board.
Easiest way to see if the board is DOA.

1) burn linux
2) connect just power and ethernet cable
3) watch for ethernet LED activity
4) ssh into the pine.

If this works, we'll do further troubleshooting
You can find me on IRC, Discord and Twitter

Even better : attach a USB-TTL to Debug header and see the boot logs.
As I mentioned, I've tried several images, none work.

There is *no* link light whatsoever, therefore no DHCP to get an IP, no SSH etc.

It's dead... jim.

So, what's the returns and refund policy?

Also, what's the deal with zipping a binary image that's already gzipped.

The decompressed image is smaller than the compressed one, for both the Android and Ubuntu versions. No idea who thought that was a good idea, lol
Did you try longsleep kernel images from ?
And, as I said, did you look at the Serial Debug header to see where it is starting to choke ?
Yes, I've tried those images, as stated before, I've tried several.

No, I'm not getting a serial convertor out. For starters, I don't have one to hand - I'd have to buy one, more cost on myself. I've got a serial to usb convertor for rs232 console connections and access to hdmi interrogation tools, but not specific stuff to attach to board headers (and not getting the soldering iron out either!) Also, I should not be expected to debug via jtag/serial/whatever to fix something I've paid for, waited 6 months for and doesn't work on arrival. It's not worth my time or effort. The box is broken, there isn't even any link light, which is a pretty fundamental thing. The only thing that works is the red led, that's it. The SoC never gets any warmer than ambient, there are 0 clock cycles being used there.

I'd just like information about how to proceed to get a working replacement or a refund as I have requested a few times Smile

If there is none, that's fine, I'll just put it to bed and carry on with life, it's not the end of the world Big Grin
How did you burn the images to the card?  I hear Rufus works better than the phoenix card software.   I ran into intermittent issues with phoenix card myself.
I'm in the same boat, at the same level of frustration. I get that this is a bit of a kitbashers tool, but a large amount of my aggravation is less about the board itself, and more about the complete lack of:

1) Quality Control
2) Professionalism
3) Support

..that this thing has seen. I get that Pi relies heavily on community, as does Arduino, But sweet Christ maybe have ONE or TWO locked down and stable releases at launch?

Because of their seemingly horrible QC (warped boards, DOA, etc.), their kind of goofy moves ("Hey!!! We threw in a few extra pieces - one's a stretch goal, one's something you ordered..but why put documentation in there when you can use the of course WE won't say much on the web, but there's a community!!), and other odd crap, when something does go wrong for the user, it could be:

1) They did something wrong by not understanding the clear-as-mud online guide to 500 Half-Assed OS builds (to be more completely honest, I'm sure at least one of the builds is Completely-Assed)
2) The board is experiencing a problem
3) The board is fine but the OS build has an issue
4) Something else

So when we hit an issue like I and the OP have, where there is no video, the apparently official response from Pine64 is "try a bunch of things, and if one works...well that's sure to tell everyone else!!!"

On the good side, this is only the second of my more than fifty KS projects that was completely disappointing.
(06-16-2016, 08:44 AM)Havensal Wrote: How did you burn the images to the card?  I hear Rufus works better than the phoenix card software.   I ran into intermittent issues with phoenix card myself.

I have the same question. 

... if you use a gnu+linux system and the dd command to write the image file (use a linux image file; either debian, or ubuntu) that board will work-- unless you ESD shocked it when you ripped it out of its static package... every board is tested before it ships, they are NOT shipping DOA boards/ this is bogus.

I would like to know the total number of boards in the wild to date/ ??

Let me just state emphatically, I have experienced professionalism, creativity, innovation, quality and response in every way from the Pine64 team; period. My board arrived two weeks later than I expected (so what?). The board arrived in good condition (clean, flat, sound, and fully functional with straight pins in a professionally wrapped static protection and a quality shipping box) !!

I have no complaints, and my board is functioning with SEVERAL distros... I have not found one yet that does not work !

But then, I have a good attitude, I know what I'm doing, and I'm not a troll !
If your board is bad, get off this forum and ship the board back where it came from with a polite note that states you'd like a refund. Stop whining about it, stop bashing the Pine64 team, and stop making an ass out of yourself on this public communications channel (its not becoming, and its not helpful).

(happy PineA64 user)


Possibly Related Threads…
Thread Author Replies Views Last Post
  PINE A64 SBC: Clone of a functional 32GB SD card doesn't boot burningkrome 3 1,868 05-19-2023, 07:43 AM
Last Post: crocspot
  PINE A64 Ubuntu 18 or 20 IMG with touchscreen? burningkrome 0 711 04-29-2023, 05:13 AM
Last Post: burningkrome
  Pine A64 does only boot with Android 5.1 Dude 6 4,233 07-03-2022, 02:18 PM
Last Post: Dude
  Pine A64+ vs LCD do not boot DDS 3 6,167 02-23-2021, 05:33 PM
Last Post: thedu
  Autodetect if Pine unit is a Pine A64+ or PineA64-LTS pkfpeters 1 3,471 02-09-2021, 12:17 AM
Last Post: tllim
  Pine 64 | 2GB x2 & Acrylic Cases x2 for Sale | Canada - GTA ViperVi 1 4,639 01-18-2021, 03:45 PM
Last Post: squidius
  sd format?for pine 64 angegardien 3 8,022 12-06-2020, 03:53 PM
Last Post: junkyj753
  Node Red on the Pine DonFL 0 2,866 12-16-2019, 04:21 PM
Last Post: DonFL
Photo Pine A64+ from Kick starter running Pi-Hole netHolio 0 3,317 12-02-2019, 09:36 PM
Last Post: netHolio
  NetBSD for Pine A64(+) Luke 3 6,920 10-05-2019, 11:04 PM
Last Post: mrgtwentythree

Forum Jump:

Users browsing this thread: 1 Guest(s)