Gimp makes stock Manjaro KDE/X11 crash
#1
I can open Gimp, but as soon as I open any image in it, KDE or X11 (don't know) starts blacking out, screen goes black, parts of screen go black, cursor does whatever it wants... Basically have to hard restart.

Is there a package missing or something? Thanks!!
  Reply
#2
(04-10-2021, 03:19 AM)stozi Wrote: I can open Gimp, but as soon as I open any image in it, KDE or X11 (don't know) starts blacking out, screen goes black, parts of screen go black, cursor does whatever it wants... Basically have to hard restart.

Is there a package missing or something? Thanks!!

It looks like you are hitting https://gitlab.freedesktop.org/mesa/mesa/-/issues/4389.

Until the fix to Mesa is merged and makes its way to an update (which might take a couple of weeks), you can try the workaround, which is to set the environment variable PAN_MESA_DEBUG=noafbc for X. Depending on how launch X, it might be enough to just put it in /etc/environment.

Alternatively, you can also try using GIMP from a Wayland compositor or Xephyr window. Even a Wayland compositor running nested inside the X session should work.
  Reply
#3
(04-10-2021, 04:39 AM)icecream95 Wrote: Alternatively, you can also try using GIMP from a Wayland compositor or Xephyr window. Even a Wayland compositor running nested inside the X session should work.

I have the same issue with GIMP so (based on your suggestion) I used:
Code:
GDK_BACKEND=wayland gimp
and it seems to work fine now. Better than ever in fact! Big Grin  Thanks!
  Reply
#4
(04-16-2021, 10:46 PM)MtnSk8 Wrote:
(04-10-2021, 04:39 AM)icecream95 Wrote: Alternatively, you can also try using GIMP from a Wayland compositor or Xephyr window. Even a Wayland compositor running nested inside the X session should work.

I have the same issue with GIMP so (based on your suggestion) I used:
Code:
GDK_BACKEND=wayland gimp
and it seems to work fine now. Better than ever in fact! Big Grin  Thanks!
I just switched to KDE wayland, which is all good, just the copy function (in general) is now strangely unreliable
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Games compilation howto on the Pinebook-pro (Manjaro Linux and Debian native) astr0baby 200 146,393 51 minutes ago
Last Post: wpeckham
  Manjaro KDE dolphin not showing usb device straightwalker 0 38 07-30-2021, 09:51 AM
Last Post: straightwalker
  printing -- Manjaro ARM KDE plasma straightwalker 8 631 07-04-2021, 10:55 PM
Last Post: KC9UDX
  MAC Spoofing failing in manjaro slow_motion 6 2,373 07-02-2021, 10:59 PM
Last Post: user526
  Estimated stock dreamer_ 8 1,250 05-03-2021, 12:23 PM
Last Post: KC9UDX
Sad Webcam not working in pinebook pro with Manjaro jcarball 2 569 04-28-2021, 03:23 PM
Last Post: jcarball
  No Sound on Default Manjaro KDE carlosqueso 4 836 04-01-2021, 07:17 AM
Last Post: carlosqueso
  No WIFI network discovery in any manjaro installation (but works on fedora) pineitup 1 629 02-05-2021, 09:10 AM
Last Post: BlueJayLinux
  Wifi very slow on PBP Manjaro? WeaseleyRon 2 696 01-21-2021, 10:21 AM
Last Post: moonwalkers
  Can the Activity LED be enabled under Manjaro? Cralex 1 798 01-07-2021, 12:36 AM
Last Post: rimaille

Forum Jump:


Users browsing this thread: 1 Guest(s)