Gimp makes stock Manjaro KDE/X11 crash
#1
I can open Gimp, but as soon as I open any image in it, KDE or X11 (don't know) starts blacking out, screen goes black, parts of screen go black, cursor does whatever it wants... Basically have to hard restart.

Is there a package missing or something? Thanks!!
  Reply
#2
(04-10-2021, 03:19 AM)stozi Wrote: I can open Gimp, but as soon as I open any image in it, KDE or X11 (don't know) starts blacking out, screen goes black, parts of screen go black, cursor does whatever it wants... Basically have to hard restart.

Is there a package missing or something? Thanks!!

It looks like you are hitting https://gitlab.freedesktop.org/mesa/mesa/-/issues/4389.

Until the fix to Mesa is merged and makes its way to an update (which might take a couple of weeks), you can try the workaround, which is to set the environment variable PAN_MESA_DEBUG=noafbc for X. Depending on how launch X, it might be enough to just put it in /etc/environment.

Alternatively, you can also try using GIMP from a Wayland compositor or Xephyr window. Even a Wayland compositor running nested inside the X session should work.
  Reply
#3
(04-10-2021, 04:39 AM)icecream95 Wrote: Alternatively, you can also try using GIMP from a Wayland compositor or Xephyr window. Even a Wayland compositor running nested inside the X session should work.

I have the same issue with GIMP so (based on your suggestion) I used:
Code:
GDK_BACKEND=wayland gimp
and it seems to work fine now. Better than ever in fact! Big Grin  Thanks!
  Reply
#4
(04-16-2021, 10:46 PM)MtnSk8 Wrote:
(04-10-2021, 04:39 AM)icecream95 Wrote: Alternatively, you can also try using GIMP from a Wayland compositor or Xephyr window. Even a Wayland compositor running nested inside the X session should work.

I have the same issue with GIMP so (based on your suggestion) I used:
Code:
GDK_BACKEND=wayland gimp
and it seems to work fine now. Better than ever in fact! Big Grin  Thanks!
I just switched to KDE wayland, which is all good, just the copy function (in general) is now strangely unreliable
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  MAC Spoofing failing in manjaro slow_motion 5 1,897 06-15-2021, 11:28 AM
Last Post: saturday31
  Estimated stock dreamer_ 8 969 05-03-2021, 12:23 PM
Last Post: KC9UDX
Sad Webcam not working in pinebook pro with Manjaro jcarball 2 433 04-28-2021, 03:23 PM
Last Post: jcarball
  No Sound on Default Manjaro KDE carlosqueso 4 603 04-01-2021, 07:17 AM
Last Post: carlosqueso
  Games compilation howto on the Pinebook-pro (Manjaro Linux and Debian native) astr0baby 197 135,100 03-03-2021, 02:28 AM
Last Post: SpaceLord
  No WIFI network discovery in any manjaro installation (but works on fedora) pineitup 1 513 02-05-2021, 09:10 AM
Last Post: BlueJayLinux
  Wifi very slow on PBP Manjaro? WeaseleyRon 2 577 01-21-2021, 10:21 AM
Last Post: moonwalkers
  Can the Activity LED be enabled under Manjaro? Cralex 1 691 01-07-2021, 12:36 AM
Last Post: rimaille
  All White Screen on Manjaro I3 nomadicoder 1 924 12-31-2020, 11:44 AM
Last Post: nomadicoder
Question cannot connect to wireless - Pine64/Manjaro markbesw 0 597 12-16-2020, 05:11 PM
Last Post: markbesw

Forum Jump:


Users browsing this thread: 1 Guest(s)