SD card read/write troubles
Hello. Some time ago I bought 2 pinebooks.

Pinebook #1 was sometimes used, different distros were tried and regularly updated. Now Manjaro Arm Sway Profile occupies his EMMC drive.

Pinebook #2 was (with few exceptions) shelved. If used, then only for browsing and not updated. His EMMC drive has still the original stock KDE neon image.

I decided to update pinebook #2 to Manjaro OS. On pinebook #1 I prepared SD card with my current favorite pinebook distro and tested ii right there on #1 if it is working. Yes, #1 booted from SD. Then I inserted the SD card to #2. It couldn't boot. Black screen. So I tried different distros, even the original one. No boot. I've also tried to flash the SD card on #2 with no effect, still no boot. Then I tried to mount the SD card, to see if files are alright and found out, that the card couldn't be mounted (card is recognized, partitions are visible in file manager, but can't be mounted cause of unrecognized file system).I even can't fomat the SD card on #2 with gparted (write error).

My experiment showed me, that if I write an image on #1 (using dd), then the SD card can be booted & read on #1, but not on #2. If I do the same procedure on #2, the SD card is not bootable nor usable on both pinebooks.

Does anybody have an idea what went wrong? Is there any other way to flash an image to EMMC without booting from SD? How can I 100% figure out if it is a HW, SW, SDcard or user related problem?

Thank you for your answers & suggestions.

Fun story: Meanwhile I've tried to run packages upgrade on #2. Something went wrong and now some packages are missing, DE is half broken (no panels or start menu) and I have to connect to wifi via CL Big Grin
I tried another SD card I've borrowed from a family's member's e-book reader. The card was possible to read on the pb#1 (the working one) and when there was no filesystem read error on pb#2 (the one with SD card issues), I've flashed an OS to the card (manjaro sway). I've booted pb#2 with the SD card and guess what, It booted. I was happy.

So maybe the SD card reader works and the card was the problem? No, because when I tried an OS update or started download of an OS image (to flash to EMMC), the system always froze. As long I did not try to write large data portion to SD card, the system was working flawlessly. So it has to be some SD card reader issue. I used, an USB stick as storage for OS image, flashed it to EMMC and now I have the latest manjaro on pinebook #2. Mission accomplished.

Possibly Related Threads…
Thread Author Replies Views Last Post
  How to write image to emmc module on the pinebook eclay 16 34,276 06-11-2020, 03:03 PM
Last Post: jezek
  pinebook 14" sd card slot stopped working eclay 3 4,803 12-03-2018, 01:51 PM
Last Post: dkryder
  Pinebook accessories (emmc usb card) RockPro64Newbie 0 2,037 09-11-2018, 07:19 PM
Last Post: RockPro64Newbie
Lightbulb Pinebook SDIO gpio control using SD card slot blog post MarkHaysHarris777 15 23,910 10-11-2017, 04:55 AM
Last Post: MarkHaysHarris777
  New Pinebook 14'' does not boot from sd card felfail 21 24,535 07-28-2017, 12:09 AM
Last Post: pfeerick
  sd card schematics on pinebook advait 3 4,264 07-19-2017, 12:47 AM
Last Post: advait
  SPI to the SD card specifications uminded 10 12,143 06-20-2017, 03:34 AM
Last Post: pfeerick

Forum Jump:

Users browsing this thread: 1 Guest(s)