USB Dock Flashes When Connected
So I chose this dock because the Wiki suggested it would work well:

When I plugged it in unpowered, it seemed to work fine.  I got a USB-C to USB-C cable today and plugged it in, and it rapidly turned on and off.  I kept getting messages like:
[87032.432708] usb 7-1.1.4: new high-speed USB device number 69 using xhci-hcd
[87032.684652] usb 7-1.1.4: New USB device found, idVendor=2109, idProduct=0101, bcdDevice= 2.03
[87032.684666] usb 7-1.1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[87032.684673] usb 7-1.1.4: Product: USB 2.0 BILLBOARD             
[87032.684680] usb 7-1.1.4: Manufacturer: VIA Technologies Inc.         
[87032.684686] usb 7-1.1.4: SerialNumber: 0000000000000001
[87033.893737] usb 7-1: USB disconnect, device number 66
[87033.893749] usb 7-1.1: USB disconnect, device number 67
[87033.893755] usb 7-1.1.2: USB disconnect, device number 68
[87033.919565] usb 8-1: USB disconnect, device number 72
[87033.919583] usb 8-1.1: USB disconnect, device number 73
[87034.037223] usb 7-1.1.4: USB disconnect, device number 69
[87034.101502] usb 8-1.2: USB disconnect, device number 74
[87034.119502] cdn-dp fec00000.dp: [drm:cdn_dp_check_sink_connection [rockchipdrm]] *ERROR* Get sink capability timed out                                                                       
[87034.119603] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] *ERROR* Enable dp failed -19                                                                                       
[87034.865090] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Not connected. Disabling cdn
[87034.872486] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Not connected. Disabling cdn
[87035.645057] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Not connected. Disabling cdn
[87035.884195] usb 8-1: new SuperSpeed Gen 1 USB device number 75 using xhci-hcd
[87035.966055] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Connected, not enabled. Enabling cdn
It just keeps turning the power (and connection) on and off.  I'm on the default Manjaro and the only things plugged into the hub are the power and a USB mouse.  The power appears to work fine alone plugged directly  into the USB-C port, and the hub seems to work fine on my phone.

I'm stuck, any ideas?
Eh, looks like it's a bad dock. It didn't work under Debian either, so I switched out the power brick I was using. It worked fine for about 20 minutes, but had a high-pitched whine the entire time and got really hot. After heating up for a while, it just stopped working. I'm gonna call it a loss and maybe spend a bit more on a dock that won't do such things.

Possibly Related Threads…
Thread Author Replies Views Last Post
  pinebook pro dock display out mamboman777 1 282 08-27-2021, 06:09 AM
Last Post: bikerlatt1
  USB C dock with internal display mirrored to projector and one extended display jbrock 4 274 07-19-2021, 04:00 PM
Last Post: jbrock
  [SOLVED] Red light flashes next to barrel-port Carl 31 16,673 01-18-2021, 09:34 AM
Last Post: dsimic
  Pinebook Pro doesn't boot most of the time unless connected via USB-serial! nib0 16 4,646 09-29-2020, 10:24 PM
Last Post: wdt
  USB-C Dock with HDMI no output coolmule 2 1,673 06-04-2020, 09:13 PM
Last Post: axel

Forum Jump:

Users browsing this thread: 1 Guest(s)