External USB C Monitor not working
#11
(06-16-2020, 01:24 PM)DrYak Wrote: In my experience in playing  with various docks:

- sometimes, the PineBook only works in one single cable orientation (troubles negociating which lanes used for USB3 and which lanes used for Display Port), try flipping the USB-C connector the other side up.

- make sure that you have set up the resolution to something sufficiently low that that can be handled by only two Display Port lanes (as the other two are needed for USB3). Do no attempt to run 4kp60, it won't work.

Flipping the USB-C connector works for me most of the time.
  Reply
#12
I have a usbC hub with Displayport out put that WAS working until I updated my machine this month. Any troubleshooting suggestions?
  Reply
#13
You didn't say,,,, manjaro???.. A known regression
sudo pacman -Syyu linux-pinebookpro linux-pinebookpro-headers
to get tsy's kernel
  Reply
#14
(08-24-2020, 01:33 PM)wdt Wrote: You didn't say,,,, manjaro???.. A known regression
sudo pacman -Syyu linux-pinebookpro linux-pinebookpro-headers
to get tsy's kernel
Damn, I have the same issue as the one above, after an update as far as i can recall, the usb c display capabilities were lost. Now i have gotten the linux-pinebookpro and header packages but it still doesn't work, mind you is hardware that used to work prior to this update..
Any suggestions?
  Reply
#15
Flip plug? dmesg |grep -i error ; dmesg|grep -i fail
Check manjaro forum, that suggestion is now 2 weeks old
  Reply
#16
(09-03-2020, 10:53 AM)wdt Wrote: Flip plug?  dmesg |grep -i error  ;  dmesg|grep -i fail
Check manjaro forum, that suggestion is now 2 weeks old
Thanks man, I actually switched the usb switch upside down and also powered the pbp on with the usb c dock.. boy this is a weird issue..


Attached Files
.jpg   IMG_20200903_141957.jpg (Size: 318.95 KB / Downloads: 510)
"That, according as it is written, He that glorieth, let him glory in the master."

1 Corinthians 1:31
  Reply
#17
(08-24-2020, 01:33 PM)wdt Wrote: You didn't say,,,, manjaro???.. A known regression
sudo pacman -Syyu linux-pinebookpro linux-pinebookpro-headers
to get tsy's kernel

Thanks for this, it actually helped me get Manjaro working with my monitor. (While slow, I was able to get it to display 4K30 with the laptop closed.)
  Reply
#18
I am seeing the same problem. I have a new Pinebook Pro running Manjaro 5.7.19-1-MANJARO-ARM #1 SMP Wed Sep 2 20:43:09 +03 2020 aarch64 GNU/Linux. I am unable to get it to detect a Dell UltraSharp 27 4K USB-C Monitor - U2720Q external display plugged in via the included USB-C cable. Charging works, but video out does not.

The user manual says the monitor supports: 1 x USB Type-C (Alternate mode with DisplayPort 1.4, USB 3.0 upstream port, Power Delivery PD up to 90 W).

When I plug the cable into the Pinebook Pro, dmesg shows the following:

Code:
[Mon Sep 21 10:39:06 2020] usb 7-1.5: USB disconnect, device number 11
[Mon Sep 21 10:39:06 2020] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Not connected. Disabling cdn
[Mon Sep 21 10:39:06 2020] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Not connected. Disabling cdn
[Mon Sep 21 10:39:30 2020] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Not connected. Disabling cdn
[Mon Sep 21 10:39:30 2020] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Not connected. Disabling cdn
[Mon Sep 21 10:39:30 2020] typec_displayport port0-partner.0: No compatible pin configuration found:0000 -> 0014, 001c <- 0000
[Mon Sep 21 10:39:30 2020] usb 7-1: new high-speed USB device number 12 using xhci-hcd
[Mon Sep 21 10:39:30 2020] usb 7-1: New USB device found, idVendor=0451, idProduct=8442, bcdDevice= 1.00
[Mon Sep 21 10:39:30 2020] usb 7-1: New USB device strings: Mfr=0, Product=0, SerialNumber=1
[Mon Sep 21 10:39:30 2020] usb 7-1: SerialNumber: 52010851800D
[Mon Sep 21 10:39:30 2020] hub 7-1:1.0: USB hub found
[Mon Sep 21 10:39:30 2020] hub 7-1:1.0: 6 ports detected
[Mon Sep 21 10:39:30 2020] usb 8-1: new SuperSpeed Gen 1 USB device number 6 using xhci-hcd
[Mon Sep 21 10:39:30 2020] usb 8-1: New USB device found, idVendor=0451, idProduct=8440, bcdDevice= 1.10
[Mon Sep 21 10:39:30 2020] usb 8-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[Mon Sep 21 10:39:30 2020] hub 8-1:1.0: USB hub found
[Mon Sep 21 10:39:30 2020] hub 8-1:1.0: 4 ports detected
[Mon Sep 21 10:39:31 2020] usb 7-1.5: new high-speed USB device number 13 using xhci-hcd
[Mon Sep 21 10:39:31 2020] usb 7-1.5: New USB device found, idVendor=0451, idProduct=82ff, bcdDevice= 2.00
[Mon Sep 21 10:39:31 2020] usb 7-1.5: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[Mon Sep 21 10:39:31 2020] hid-generic 0003:0451:82FF.000A: hiddev97,hidraw2: USB HID v1.11 Device [HID 0451:82ff] on usb-xhci-hcd.1.auto-1.5/input0

I have tried rotating the cable and also booting with it plugged in. The monitor works in a Macbook Air (2018) but not with the Pinebook. As this is still on the 5.7 kernel, it seems unrelated to the regression in the 5.8 kernel. I posted on the Manjaro forums but they didn't know how to debug it. Any suggestions?
  Reply
#19
(09-23-2020, 01:44 AM)davidmytton Wrote: I am seeing the same problem. I have a new Pinebook Pro running Manjaro 5.7.19-1-MANJARO-ARM #1 SMP Wed Sep 2 20:43:09 +03 2020 aarch64 GNU/Linux. I am unable to get it to detect a Dell UltraSharp 27 4K USB-C Monitor - U2720Q external display plugged in via the included USB-C cable. Charging works, but video out does not.

The user manual says the monitor supports: 1 x USB Type-C (Alternate mode with DisplayPort 1.4, USB 3.0 upstream port, Power Delivery PD up to 90 W).

When I plug the cable into the Pinebook Pro, dmesg shows the following:

Code:
[Mon Sep 21 10:39:06 2020] usb 7-1.5: USB disconnect, device number 11
[Mon Sep 21 10:39:06 2020] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Not connected. Disabling cdn
[Mon Sep 21 10:39:06 2020] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Not connected. Disabling cdn
[Mon Sep 21 10:39:30 2020] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Not connected. Disabling cdn
[Mon Sep 21 10:39:30 2020] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Not connected. Disabling cdn
[Mon Sep 21 10:39:30 2020] typec_displayport port0-partner.0: No compatible pin configuration found:0000 -> 0014, 001c <- 0000
[Mon Sep 21 10:39:30 2020] usb 7-1: new high-speed USB device number 12 using xhci-hcd
[Mon Sep 21 10:39:30 2020] usb 7-1: New USB device found, idVendor=0451, idProduct=8442, bcdDevice= 1.00
[Mon Sep 21 10:39:30 2020] usb 7-1: New USB device strings: Mfr=0, Product=0, SerialNumber=1
[Mon Sep 21 10:39:30 2020] usb 7-1: SerialNumber: 52010851800D
[Mon Sep 21 10:39:30 2020] hub 7-1:1.0: USB hub found
[Mon Sep 21 10:39:30 2020] hub 7-1:1.0: 6 ports detected
[Mon Sep 21 10:39:30 2020] usb 8-1: new SuperSpeed Gen 1 USB device number 6 using xhci-hcd
[Mon Sep 21 10:39:30 2020] usb 8-1: New USB device found, idVendor=0451, idProduct=8440, bcdDevice= 1.10
[Mon Sep 21 10:39:30 2020] usb 8-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[Mon Sep 21 10:39:30 2020] hub 8-1:1.0: USB hub found
[Mon Sep 21 10:39:30 2020] hub 8-1:1.0: 4 ports detected
[Mon Sep 21 10:39:31 2020] usb 7-1.5: new high-speed USB device number 13 using xhci-hcd
[Mon Sep 21 10:39:31 2020] usb 7-1.5: New USB device found, idVendor=0451, idProduct=82ff, bcdDevice= 2.00
[Mon Sep 21 10:39:31 2020] usb 7-1.5: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[Mon Sep 21 10:39:31 2020] hid-generic 0003:0451:82FF.000A: hiddev97,hidraw2: USB HID v1.11 Device [HID 0451:82ff] on usb-xhci-hcd.1.auto-1.5/input0

I have tried rotating the cable and also booting with it plugged in. The monitor works in a Macbook Air (2018) but not with the Pinebook. As this is still on the 5.7 kernel, it seems unrelated to the regression in the 5.8 kernel. I posted on the Manjaro forums but they didn't know how to debug it. Any suggestions?
You can try the old default OS, but I don't know if the image with Mrfixit2001's Debian OS has USB-c fully working. Almost month ago, I've switched to Manjaro and I wanted to have this older OS on a SD card, but WiFi wasn't working (I don't remember if it was working when I got PBP with preinstalled OS, but I think it was) and the update script wasn't working either when I've tried to update using Ethernet dongle. The update script was comparing installed version with version string from Mrfixit2001 github, then it would download whatever is needed from Mrfixit2001's svn. Try to avoid doing 'apt upgrade'. You can try to contact Mrfixit2001. If your monitor will not work with PBP on Mrfixit2001 Debian Desktop version 2.0, then you can try one of the compatible HDMI adapters. If your monitor would work with Mrfixit2001 system, then there is hope it will work someday with Manjaro. But I'm not suggesting using this Debian Desktop as a daily driver, because it will slowly deteriorate with every 'apt upgrade'.
  Reply
#20
Err, did you actually do this?
sudo pacman -Syyu linux-pinebookpro linux-pinebookpro-headers
A normal update does NOT install this, must be explicitly installed
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Slackware Linux working on PBP vxzero 0 394 06-05-2024, 04:30 PM
Last Post: vxzero
  No external monitorvia USB-C over Dockingstation bnjmnhg 14 3,917 11-28-2023, 01:35 PM
Last Post: zaius
  Manjaro ARM: enabling external monitors & fixing Broadcom WiFi after updating trifleneurotic 2 1,228 11-14-2023, 10:57 AM
Last Post: trifleneurotic
  USB 3 port not working with Armbian zaius 3 1,228 11-13-2023, 01:54 PM
Last Post: zaius
  Sleep and external display - Are there any options? chris88233 7 2,297 09-04-2023, 09:03 PM
Last Post: wdt
  Camera not working with Cheese cypresstwist 1 1,446 08-18-2023, 02:02 AM
Last Post: juliamenendez
  5GHz wifi not working snorwood 11 6,298 01-16-2023, 03:41 PM
Last Post: ehcorn
  Pinebook Pro wifi not working Queliffrel 1 1,460 11-30-2022, 06:30 AM
Last Post: myself600
  Resume from suspend not working after flashing Tow-Boot to SPI xp19375 3 2,204 10-31-2022, 10:14 AM
Last Post: wdt
  Webcam not working in Manjaro with Cheese, but works in Armbian petaramesh 1 1,251 09-30-2022, 10:09 AM
Last Post: crazyquark

Forum Jump:


Users browsing this thread: 1 Guest(s)