So to preface, I originally thought this device was amazing. Decent build quality and other than the factory somehow defaulting wifi to off, I thought it was good!

My first mistake was trying to install anything other than what was on the emmc already. I tried manjaro-xfce and the wifi wasn't detected - at all. When I plugged in a usb wifi adapter to update the installation, it refused to boot after the update. I went through the process twice, same result.

After that, it was an endless slog. Did I mention that there's no eject on the sdcard reader? Is that intentional? Am I supposed to have to find a flat screwdriver to get my sdcard out every time? I did try USB (since I think I read that's supported), but it wouldn't boot from that on either port.

I tried again, with the original KDE manjaro "supported release". I tried three different sdcards, two computers and four different programs/methods to write the images. Every time, it either wouldn't boot, booted into read-only mode or I got endless loops of "authentication failure" when trying to boot and start the installer. I tried mrfixit's version and then used manjaro-arm-installer too. I even tried dd-ing from the SD card when I could actually convince it to start. No go.

After a while I managed to get the manjaro i3 version to install AND have wifi (victory), but I don't WANT to use i3, so I updated and installed XFCE. Fine. Then I rebooted, or tried to. Wouldn't power on. Read up on the wiki, and figured the emmc was loose. Checked. Reseated. Tried the reset button. Finally had no choice but to disable emmc. Fine. Boots again, but seems to corrupt the sdcard too. Bought a new sdcard in case this was the problem. Nope.

So I have a $200 paperweight and nothing to show for it. It won't reliably boot from sdcard (again, why is there no eject functionality?) and the emmc is seemingly useless. I cannot express how disappointed I am.
And now I need to eat a little crow, while also making another point.

After two days of fighting this thing, I accidentally got a little too enthusiastic while removing an SD card and my screwdriver slipped rather forcefully into the slot.


Turns out the mechanism was jammed, not missing. In turn, this seems to have caused my SD cards to read, but not reliably. Once I fixed this, reset the emmc again and then flipped the switch at just the right moment, all seems to be fine. Lesson learned all around, because there shouldn't be the slippery kind of QC that lets this go without being tested so it doesn't happen to a user.
This sounds like you have some sort of hardware issue. 
The Pinebook Pro doesn't normally behave like that. 
I think I'd recommend sending Pine an email about that, if this doesn't help:

Booting from USB is not supported, but dd'ing an image to the SD card works reliably. 

I have never had to use the eMMC switch and I would suggest you don't touch it (for the most part). 
A serial cable would be nice to have now, so you could post more debug output (you don't happen to know how to solder and have a UART adapter and a 3.5mm headphone plug?). 

Are you using high-quality SD cards? Please try with SanDisk Ultra, SanDisk Extreme or Samsung Evo/Evo Plus cards.
After you have a system running from SD card, you can download and dd your image from the running Linux system to the eMMC flash and it will get booted. 

Good luck,
(06-02-2020, 05:30 PM)cephalien Wrote: And now I need to eat a little crow, while also making another point.

We all do that every so often... brings us back to Earth again! Wink

cephalien Wrote:Did I mention that there's no eject on the sdcard reader? Is that intentional?

'friad that's normal for microSD slots... they are either friction, meaning you need to be able to grip the card to pull it out, or sprung 'n latched like the PBPs, which you can sometimes foul up if you push the card in at an angle. I find a thumbnail/index fingernail to insert, and again a thumbnail/index fingernail is enough to coax the blighter out. Be sure to cover the socket though, because if that bugger fires out when you try to release it, it'll fly clear across the other side of the room... to join it's many, many friends. Big Grin Big Grin

Sounds like you've gotten the issue under control now though, so fingers crossed this dark moment is now over!

I also don't think the PBP currently has USB boot support. The rockpro64 does have USB boot support, but I don't see anything suggesting the PBP's uboot does... which is strange. On the wiki, there is this mention "Pinebook Pro is capable of booting from eMMC, USB 2.0, USB 3.0, or an SD card." ... although if you read further, you'll see "Booting off USB storage is not currently available, but will be in the future. "
I'm back, but I'm gonna un-eat some of that crow.

Yeah, forcing the ejector unstuck solved 'some' of my issues, but most still remain.

1) No matter what distribution I use, it works intermittently at best. Even with the 'flagship' Manjaro ARM, I'm able to install it then the first set of pacman updates reliably causes it to show a green light but not go any farther. This is the emmc, so I'm not blaming a poor SDcard for this. I tried the emmc installer and also dd'ing directly to the emmc. First boot? Fine. Updates? Black screen on reboot. This is true of both KDE and the XFCE variant.

2) I tried running from the SD card. Four of them. Different brands, different sizes. Half the time when I go to restart after the first boot, I get "unrecovered journal" errors and the system locks up or I get vague "authentication error" when I try to login.

I get that this device is supposed to be a hacker's device, but seriously. It MUST be defective at this point.
The U-Boot that came with Manjaro, either the one supplied by Pine64 or the one on Manjaro's web site, seems to not work reliably booting off the eMMC. My ANSI Pinebook Pro came from the earlier batch, with Debian. I decided that I wanted Manjaro. Trying it out on SD card worked fine. However, after loading in on the eMMC, it just was not reliable for booting.

After reading a bit, it appears that the default Debian U-Boot files are more reliable. So, I went back to those, (I have good backups, so easy for me). Since then, Manjaro XFCE has been quite reliable for booting. Have not tried many other things, just getting the desktop configured and customized took a bit of time.

Now to get the default Debian's U-Boot, that's a different story. Sorry, I don't have easy instructions to do that.

I have this long wish list for the Pinebook Pro, many items are about booting.
Arwen Evenstar
Princess of Rivendale
the manjaro black screen issue is related to uboot, i believe. they transitioned their boot process right before this release and it wasn't ready - needs a fix.

i know everyone is bored of me saying this, but debian unstable arm64 + 5.7 hwaccel kernel + mrfixit uboot v2.0 is easily the best working os for pbp.
+1 mrfixit uboot
>Sorry, I don't have easy instructions to do that.
Install mrfixit to SD, boot, do mrfixit update (icon on task bar)
save emmc mbr or gpt mbr (sector 0 or sector 0-33)
dd 1st 16M,, SD->emmc
restore mbr
And SD cards,, there are many screeds on armbian site about crap SD cards
It's true,, for this purpose, most are CRAP
test with iozone if you don't believe
IMO samsung evo is best, sandisk are OK (depends on version)(test all cards for fakes)
80-90% are CRAP
I'm going to try and take some of this information and use it, starting with the mrfixit uboot flash. I'll get back to you.
(06-08-2020, 11:51 AM)cephalien Wrote: I'm going to try and take some of this information and use it, starting with the mrfixit uboot flash. I'll get back to you.

I have not had any SD card issues,  Using various brands, on my : ANSI PBP,    ISO PBP,   or my Brave Heart phone.

Both my PBP's are running the "mrfixit Debian" though.

I am considering test driving the A-wai Mobian OS on  one of them, I think I read that OS is ready, ...  or will be ready for the PBP soon.

There are a lot of very informative posts throughout this forum,  
  ..  although sometimes you have to dig through a lot to find what you are looking for.

...  of Note,   the SD card has boot priority,   but the boot information is loaded on the eMMC  ( see notes in wiki )
         Personally,  I use the USB to eMMC adapter   to load the OS on my eMMC.  ( but I'm an amature here )

Forum Jump:

Users browsing this thread: 1 Guest(s)