PINE64
debian+phosh running on PinePhone - Printable Version

+- PINE64 (https://forum.pine64.org)
+-- Forum: PinePhone (https://forum.pine64.org/forumdisplay.php?fid=120)
+--- Forum: PinePhone Software (https://forum.pine64.org/forumdisplay.php?fid=121)
+---- Forum: Mobian on PinePhone (https://forum.pine64.org/forumdisplay.php?fid=139)
+---- Thread: debian+phosh running on PinePhone (/showthread.php?tid=9016)



RE: debian+phosh running on PinePhone - bcnaz - 03-20-2020

Ahh  yeah,  I think that 'else where' on the first inital start-up, 
    I turned off the requirement to sign in,  you did too ?   I hit the "Skip" button
           Not sure how you get back there ?
 There probably is, or you could just reflash your SD card and start fresh,  then Not hit Skip on that page..?
I do not do terminal very well....
    SO  I try for GUI solutions
  ( I hand typed all my contacts into the contact book, took hours so reflashing is not attractive )


RE: debian+phosh running on PinePhone - rico - 03-20-2020

Hello friends !

Just to remind you something :
This is not to use in production (not yet)
One of the reasons is that we currently use 'sid' as base.
I use it everyday at home and i know that it can break.
Another reason is 'still in high development' that mean sometimes an will work and sometimes you'll have to flash again.

The last, but to my mind the most important, it can be impossible to reproduct a bug on a clean install if the big appear on a modified OS. By the way a modified os can perfectly work as the clean install is not working.

My point of view :
I'm building every morning and try to fix some bugs from the minimal phone install.
When the minimal will be ok (meaning call, sms, data, contacts, webdav... Wifi, hotspot ok) then i'll add to my build other softwares will try to find bugs again.

Now let's build and Enjoy your day Wink


RE: debian+phosh running on PinePhone - buffer - 03-21-2020

(03-20-2020, 06:15 PM)Zweitaktmotor Wrote:
(03-20-2020, 05:27 PM)bcnaz Wrote: Are you using auto-log-in ?
Seems to me when using GUI, you can make the choice at the log-in screen ...  ?

In Settings, "Automatic Login" is greyed out and cannot be enabled (unless there is an unlock button somewheree off the screen).

Well first off a Wayland implementation of MATE for all distros is probably around the corner (https://www.phoronix.com/scan.php?page=news_item&px=MATE-Usable-Wayland-Mir-Video) but probably doesn't work yet

So you'll probably be using Xorg and I'm not sure if there will be missing configurations etc because this version of Debian is purely using Wayland as a display manager (and I do see this as an advantage, Xorg is a nightmare). Other desktop environments are not guaranteed to work, especially ones requiring Xorg, and you'll probably have to do it all yourself. If I was you I would wait for a fully working implementation of MATE for Wayland.

You can at least test out other desktop environments by installing them and also gdm, then you would just log out and be taken to gdm's login manager. At the login manager is where you would change the selected desktop.


RE: debian+phosh running on PinePhone - a-wai - 03-21-2020

(03-19-2020, 05:40 AM)vinnie Wrote: - I noticed that by pulling down the panel (which also contains the power off button) and pressing the side button to turn off the screen (without pulling up the previous panel), when I turn on the screen again the touch doesn't respond anymore and the only thing I can do is to turn off the phone by holding down the side button for a long time (is this a dangerous operation? someone told me that I risk to damage the modem firmware by not following a proper shutdown procedure)
Ouch, nice catch! I could replicate here, I'll check with the future phoc release (should be a matter of days), as it could go away with it.

(03-19-2020, 07:42 AM)vinnie Wrote: and thanks too for your answer Smile , do you also have a modem tip? maybe I need to activate something with an AT command?
(03-19-2020, 11:13 PM)buffer Wrote: Oh wow, during calls the other person cannot hear me but I can hear them. I can't figure out why! Huh
Did you have to configure anything first? Did they work out of the box?
Everything modem-related works out of the box, but it's recommended you disable PIN code verification on your SIM card.
Mobile data should be enabled in Settings -> Mobile on first (and sometimes, second) boot.

(03-19-2020, 09:24 AM)Zweitaktmotor Wrote: I would like to have the high resolution as well. Is there any way to swich?
See https://puri.sm/posts/easy-librem-5-app-development-scale-the-screen/

(03-20-2020, 03:18 PM)dukla2000 Wrote: It seems to me mobile data stability has regressed significantly. I am virtually unable to get it to work myself now whereas a week or so ago it just worked out of the box from Settings. Now disabling WiFi (which is useful to establish if mobile data is working) means the phone has a tendency to enable Airplane mode - you have to keep checking that is not the case.
AFAIK, disabling Wifi will show "Airplane mode enabled", but won't disable mobile data, this is a UI bug.
However, the safest way to disable Wifi without entering airplane mode is through the "Power" settings panel.

(03-20-2020, 05:15 PM)Zweitaktmotor Wrote: I installed MATE desktop and would like to try it. But what command do I need to switch from PHOSH to MATE?
As @buffer mentioned, you need to install gdm3, but also disable the phosh systemd service, else they would probably collide (both are designed to run automatically and take over the display)

Also, regarding the keyboard, please note that Purism is working on some nice enhancements, including a terminal layout with the Ctrl key Wink


RE: debian+phosh running on PinePhone - buskmann - 03-21-2020

(03-21-2020, 08:54 AM)a-wai Wrote: Also, regarding the keyboard, please note that Purism is working on some nice enhancements, including a terminal layout with the Ctrl key Wink

That looked really cool! Cant wait..

A thing i see now is that in the browser and gedit, i can pick my layout and it shows up, but in the terminal(Kings cross and gnome-terminal) it seems that its locked to just one layout. The layouts show up and i can choose them, but the layout remains the same.


RE: debian+phosh running on PinePhone - buffer - 03-21-2020

(03-21-2020, 08:54 AM)a-wai Wrote:
(03-19-2020, 11:13 PM)buffer Wrote: Oh wow, during calls the other person cannot hear me but I can hear them. I can't figure out why! Huh
Did you have to configure anything first? Did they work out of the box?
Everything modem-related works out of the box, but it's recommended you disable PIN code verification on your SIM card.
Mobile data should be enabled in Settings -> Mobile on first (and sometimes, second) boot.
Well actually I DID all that, I have 4G reception and everything modem related works, and 1) PIN code verification is not used on my carrier as I do not need to use any PIN codes 2) is disabled by default on the OS 3) we need to define "calls work" because if calls "work" then am I the only one here who has this problem (see below):

I've been trying to troubleshoot it once a day every day. Trying to verify that it wasn't my own doing, I:
  • eliminated the possibility of data corruption by using only unmodified images from your website running off the SD card without resizing the partition.
  • I tried various possible sound settings: Default, Phone, Internal/External, this and that.
  • Initially I just thought that the mic worked and I was getting an echo, but I eliminated that possibility by using earbuds and muting the mic on the other non-pinephone: with that done, zero sound is picked up by the physical microphone

At the time of writing I used the March 15th image.

Today I encountered a weird thing, that occurs when setting is to Phone Call, output device is Internal Earpiece, and input device is Internal Microphone: on the other line, you can hear scratchy noises, and internal sounds. So, you can hear scratchy internal notification sounds (drip, glass, sonar, etc, but not bark) and you can hear scratchy sound of a youtube video I downloaded and played in mpv to test. I am sure it is coming from within the software, not that the microphone is picking it up, after all at no point when I speak directly into the microphone does it pick up my voice.

 Another interesting thing is that when I plug in the power cord you can also HEAR on the other line, the power transference when I plug in the cord and when I run programs that increase power consumption such as apt. (I have now heard apt singing to me in electric, and my life is forever changed.) It makes sense that the microphone would pick up noise from the power cord since they are right next to each other...

But I am certain that software settings are supposed to configure the microphone to pick up the correct sounds. I always suspected it to be a microphone problem. I'm not saying that it's a modem problem at all. Just that when people are saying the calls just work, I know people are leaving out a key piece of information: unmute or configure the microphone before your calls will actually work. So far I've yet to hear from other users here about what they did, hopefully one of them can shed some light.

As for how to do that? I did check out alsamixer settings and even on the sound card itself, but I couldn't figure it out: the microphone on the default view is already unmuted. There are also a handful of microphone related settings on the sound card itself which mystifies me. I did hours of research but I'm in the dark. If this configuration was included out of the box, that would be really useful. I will put it on the wiki at least.

Threads related to microphone, may be outdated: https://forum.pine64.org/showthread.php?tid=9179&highlight=pinephone+microphone https://forum.pine64.org/showthread.php?tid=9201&page=2&highlight=pinephone+microphone

I get no sound when I tried recording with gnome-sound-recorder to test the mic with different settings. I double checked all settings. Recording is silent.

Thanks in advance I do appreciate the work you're doing on this distro and I want to contribute ports etc. Hopefully another user here can confirm the issue or clarify the workaround or share some documentation.

Append:

.jpg   2020-03-21-192017.jpg (Size: 69.89 KB / Downloads: 234)

Checking alsamixer again (press F6 - select 1- Pinephone sound card), I see that when I change mic profile from Default to Phone, or from Phone to Default, in phosh sound settings, both Mic1 and Mic2 are muted. However (press F6 again - select 0- Default) on the main menu the capture device remains unmuted. However, unmuting the mics does not help make sound get recorded.


RE: debian+phosh running on PinePhone - bcnaz - 03-21-2020

 *
  "Out of the Box"  March 15 release, and 're-sized' per 'Disks'  
   
     'Calls work both directions with fair audio for me..'  ?

        Chats (SMS) and contact book 'work'     --  though will need some polish 'eventualy'

         wifi works, update appears to work.

   Only major item is 'data'  is not working, but I think that is my sim card.

 I Did make a connection a few times, but I got the message that my plan does not include data (But it does)

After over an hour on the phone with a AT&T tech he concluded I needed a new sim card.

SO  I am hopeful when that arrives in the mail I 'May' have working data.

Wanted to add : I am pretty much just a GUI driver, so I would like to find ways to contribute , you guys are putting some excellent efforts into this project.

Can I contribute via PayPal ?

ALSO :

I want to mention I REALLY appreciate having someone here at the Forum to talk to  !

 Thank You  !


RE: debian+phosh running on PinePhone - rico - 03-22-2020

Just my point of view about your questions

Donate is a good way to thanks people working hard on that project. In the other hand this is the bad way for me.
Currently i can participate without deadlines, without the need of results, just for my pleasure and also for my knowledge.
I'm not the most active but i try to get things better.
If i have an answer, i give it without the need of moneyback.
I really think this is a community, a kind of 'pinephone friends help group' who love Debian and doing our best to show that philosophy.
I bought that phone for my own pleasure and also because i was waiting for that.

Thanks to you too.

PS: i just talk for myself.


RE: debian+phosh running on PinePhone - bcnaz - 03-22-2020

I wanted a linux phone back when the original Ubuntu Touch came out,    I had UT on a convertible Asus tablet back then, it worked great.

  But I could not find a linux phone to purchase at that time.

****

Since I discovered the PBP and the PP I have been kind of hanging around this forum since.

I wound up buying a ISO PBP,  then the ANSI PBP,  and finally the PP Brave Heart....  and thankful to get them.


RE: debian+phosh running on PinePhone - buskmann - 03-22-2020

Did a "sudo apt upgrade" for more or less one hour ago, and it stopped at 84%. Last thing it put out was: e2scrub_all.service is a disabled or a static unit not running, not starting it.

So i guess its time to reflash.. Big Grin Actually been looking forward to that.. hehe..