PINE64

Full Version: Trouble Installing PHP5
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm trying to install PHP5 so that I can run a Dokuwiki server, but I get this error message:

Code:
[email protected]:~$ sudo apt-get install php5-fpm php5-gd                                   Reading package lists... Done
Building dependency tree
Reading state information... Done
Package php5-fpm is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php5-gd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'php5-fpm' has no installation candidate
E: Package 'php5-gd' has no installation candidate

I've added additional repositories and then run apt-get update, but no luck.
Code:
sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) main universe restricted multiverse"

Any suggestions on how to get PHP5 installed?

Thanks.
(04-19-2016, 08:59 AM)JCMPine64 Wrote: [ -> ]I'm trying to install PHP5 so that I can run a Dokuwiki server, but I get this error message:

Code:
[email protected]:~$ sudo apt-get install php5-fpm php5-gd                                   Reading package lists... Done
Building dependency tree
Reading state information... Done
Package php5-fpm is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php5-gd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'php5-fpm' has no installation candidate
E: Package 'php5-gd' has no installation candidate

I've added additional repositories and then run apt-get update, but no luck.
Code:
sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) main universe restricted multiverse"

Any suggestions on how to get PHP5 installed?

Thanks.
In my sources there only is php7.0 available.….

Maybe you give this a try?

Gesendet von meinem K00L mit Tapatalk
PHP7 installs just fine on Ubuntu

Code:
[email protected]:~# apt-get install -s php7.0-fpm
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages were automatically installed and are no longer required:
 libnih1 libnl-route-3-200 seccomp ubuntu-core-security-apparmor
 ubuntu-core-security-seccomp ubuntu-core-security-utils ubuntu-snappy-cli
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
 php-common php7.0-cli php7.0-common php7.0-json php7.0-opcache
 php7.0-readline
Suggested packages:
 php-pear
The following NEW packages will be installed:
 php-common php7.0-cli php7.0-common php7.0-fpm php7.0-json php7.0-opcache
 php7.0-readline
0 upgraded, 7 newly installed, 0 to remove and 60 not upgraded.
Inst php-common (1:35ubuntu6 Ubuntu:16.04/xenial [all])
Inst php7.0-common (7.0.4-7ubuntu2 Ubuntu:16.04/xenial [arm64])
Inst php7.0-json (7.0.4-7ubuntu2 Ubuntu:16.04/xenial [arm64])
Inst php7.0-opcache (7.0.4-7ubuntu2 Ubuntu:16.04/xenial [arm64])
Inst php7.0-readline (7.0.4-7ubuntu2 Ubuntu:16.04/xenial [arm64])
Inst php7.0-cli (7.0.4-7ubuntu2 Ubuntu:16.04/xenial [arm64])
Inst php7.0-fpm (7.0.4-7ubuntu2 Ubuntu:16.04/xenial [arm64])
Conf php-common (1:35ubuntu6 Ubuntu:16.04/xenial [all])
Conf php7.0-common (7.0.4-7ubuntu2 Ubuntu:16.04/xenial [arm64])
Conf php7.0-json (7.0.4-7ubuntu2 Ubuntu:16.04/xenial [arm64])
Conf php7.0-opcache (7.0.4-7ubuntu2 Ubuntu:16.04/xenial [arm64])
Conf php7.0-readline (7.0.4-7ubuntu2 Ubuntu:16.04/xenial [arm64])
Conf php7.0-cli (7.0.4-7ubuntu2 Ubuntu:16.04/xenial [arm64])
Conf php7.0-fpm (7.0.4-7ubuntu2 Ubuntu:16.04/xenial [arm64])

There is no PHP5 in Xenial as it is outdated and slow.
(04-19-2016, 11:52 AM)longsleep Wrote: [ -> ]PHP7 installs just fine on Ubuntu

Code:
[email protected]:~# apt-get install -s php7.0-fpm

There is no PHP5 in Xenial as it is outdated and slow.

Yes, PHP7 installs just fine, but when I follow the instructions for installing DokuWiki it fails at
Code:
sudo nginx -t


Not sure if I screwed something up, if the instructions being for a VPS mean that it can't work, or if Pine64 can't do it.