PINE64

Full Version: Centos 7 on rock64
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I want to run Centos 7 on rock64 rk3328 chipset. Any sort of help is appreciated.

Regards,
(10-29-2018, 04:23 AM)smnoufal Wrote: [ -> ]I want to run Centos 7 on rock64 rk3328 chipset. Any sort of help is appreciated.

Regards,

Hi smnoufal,

I would try to see if you can get any armbian rock64 distribution to work on it. If that works then you can try sliding the centos 7 file system on it. For inspiration see what I did for pine64 here: 

https://github.com/Project31/centos-pine64

Cheers,
--Kurt
(12-12-2018, 12:24 PM)kurtstam Wrote: [ -> ]
(10-29-2018, 04:23 AM)smnoufal Wrote: [ -> ]I want to run Centos 7 on rock64 rk3328 chipset. Any sort of help is appreciated.

Regards,

Hi smnoufal,

I would try to see if you can get any armbian rock64 distribution to work on it. If that works then you can try sliding the centos 7 file system on it. For inspiration see what I did for pine64 here: 

https://github.com/Project31/centos-pine64

Cheers,
--Kurt
Thanks Kurt,


I will have a look on the above link.
(12-25-2018, 07:27 AM)smnoufal Wrote: [ -> ]
(12-12-2018, 12:24 PM)kurtstam Wrote: [ -> ]
(10-29-2018, 04:23 AM)smnoufal Wrote: [ -> ]I want to run Centos 7 on rock64 rk3328 chipset. Any sort of help is appreciated.

Regards,

Hi smnoufal,

I would try to see if you can get any armbian rock64 distribution to work on it. If that works then you can try sliding the centos 7 file system on it. For inspiration see what I did for pine64 here: 

https://github.com/Project31/centos-pine64

Cheers,
--Kurt
Thanks Kurt,


I will have a look on the above link.
Hi Kurt,

I have inserted empty microsd and run install.sh, i am stuck on screenshot attached
Hi smnoufal,

You can try the ready to go image: https://project31.github.io/pine64/. I've created it running from the rock64 branch on https://github.com/Project31/centos-pine64/tree/rock64

Cheers,

--Kurt
Thanks Kurt, for centos 7 on rock64,

I followed your instruction and glad to inform you that successfully loaded cenntos 7. once i tried to enlarge the sd card and rebooted as per your  instruction and it ffiled to boot. I think partition got deleted.

smnoufal

kurtstamHi smnoufal,

You can try the ready to go image: https://project31.github.io/pine64/. I've created it running from the rock64 branch on https://github.com/Project31/centos-pine64/tree/rock64

Cheers,

--Kurt


Log in
to use Ginger
Limited mode
centos
[url=javascript:]×[/url]
Hi  smnoufal,

1. So I take it then things work ok /before/ you try to enlarge the partition on the sd card? 

2. I would re-flash the image and start over. I would try to take baby steps so you can pinpoint what works for you. Whenever you work fdisk you have to be careful.. Double check:
  1. name of the device (/dev/rdisk)
  2. using fdisk, use `p` to list the partitions
3. Try to capture the output when following the instructions and post it here. That can be helpful.

Cheers,

--Kurt