PINE64

Full Version: How install Qbittorrent on Debian?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
How install Qbittorrent on Debian?
I try but end-up with errors
Well it would help for a start if you describe what you did and what the errors are :-)
(03-14-2018, 08:36 AM)xalius Wrote: [ -> ]Well it would help for a start if you describe what you did and what the errors are :-)


I folow this tutorial https://www.tecmint.com/install-qbittorr...-in-linux/
the error:


Code:
[email protected]:~$ sudo apt-get install qbittorrent
[sudo] password for rock64:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 qbittorrent : Depends: libboost-system1.65.1 but it is not installable
               Depends: libqt5core5a (>= 5.8.0) but 5.7.1+dfsg-3+b1 is to be installed
               Depends: libqt5gui5 (>= 5.8.0) but 5.7.1+dfsg-3+b1 is to be installed
               Depends: libqt5network5 (>= 5.8.0) but 5.7.1+dfsg-3+b1 is to be installed
               Depends: libtorrent-rasterbar9 (>= 1.1.6+git20180215.01c41fadcf+patched-configure) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
[email protected]:~$
Anyone?
(03-14-2018, 08:57 PM)Callisto Wrote: [ -> ]
Code:
               Depends: libqt5core5a (>= 5.8.0) but 5.7.1+dfsg-3+b1 is to be installed
               Depends: libqt5gui5 (>= 5.8.0) but 5.7.1+dfsg-3+b1 is to be installed
               Depends: libqt5network5 (>= 5.8.0) but 5.7.1+dfsg-3+b1 is to be installed
               Depends: libtorrent-rasterbar9 (>= 1.1.6+git20180215.01c41fadcf+patched-configure) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
[email protected]:~$



It looks like you half upgraded packages, and then decided to set the apt repository to an older version.

The quick fix would be to re-flash an image. Otherwise you need to downgrade/upgrade to a later version.
Right now this image for rock64 board come with half upgraded packages:
http://wiki.pine64.org/index.php/ROCK64_...0171222.5D